Bug 163536 - Screensaver sometimes shows on 1/4 part of screen
Summary: Screensaver sometimes shows on 1/4 part of screen
Status: RESOLVED DUPLICATE of bug 66492
Alias: None
Product: kscreensaver
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-08 16:55 UTC by Alexey Chernov
Modified: 2008-07-27 20:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Photo of screensaver (837.86 KB, image/png)
2008-06-08 17:02 UTC, Alexey Chernov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Chernov 2008-06-08 16:55:24 UTC
Version:            (using KDE 4.0.5)
Installed from:    Compiled From Sources
Compiler:          GCC 4.1.2 Target: x86_64-unknown-linux-gnu Configured with: ../gcc-4.1.2/configure --prefix=/usr --libexecdir=/usr/lib --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --enable-languages=c,c++ --disable-multilib Thread model: posix
OS:                Linux

From time to time when screensaver automatically appears, it shows only on approx. 1/4 of screen (top left corner), while the remaining part is grey. I believe it's not possible to screenshot, so I shot it on my camera (photo will follow). Maybe it's some kind of zoom problem, because the background color seems to be the same and the used part and the corner are the same, too.
Comment 1 Alexey Chernov 2008-06-08 17:02:09 UTC
Created attachment 25207 [details]
Photo of screensaver
Comment 2 Pino Toscano 2008-06-08 17:21:11 UTC
Are you using Compiz?
Comment 3 Jason 'vanRijn' Kasper 2008-06-11 15:31:34 UTC
I'm seeing this too. I'm running the latest from trunk (at least latest as of a week ago). I have an nVidia Quadro NVS 140M graphics card on my Thinkpad T61 laptop. I'm using nVidia's drivers and Twinview with cloned displays, both set at 1680x1050. And like Alexey, I'm using OpenGL screensavers.

I'm think it might have something to do with what window is in focus when kscreensaver starts?? I've seen it go full-screen sometimes, but I've not been able to track down which window I have focused when it works. And like the photo shows, the whole screen does get blanked out white, but only a portion of it gets the screensaver. And the screensaver is scaled down to the corner too, not cropped.

HTH!
Comment 4 Alexey Chernov 2008-06-11 16:20:38 UTC
Pino, no, I actually don't use Compiz, but composite features are enabled for KWin. And I just forgot to mention, I use NVidia GeForce 8600 GT with proprietary drivers version 173.14 and opengl screensaver.

And, like Jason wrote, the screensaver doesn't look cropped, it's seems to be some kind of zoom. I didn't noticed any connection with the active window, but I will try to test it.
Comment 5 Jason 'vanRijn' Kasper 2008-06-11 19:50:49 UTC
Ah, also forgot to mention... I'm using kwin4 with compositing....
Comment 6 Oswald Buddenhagen 2008-07-27 20:59:47 UTC

*** This bug has been marked as a duplicate of 66492 ***