Bug 163459 - panel does not support RTL
Summary: panel does not support RTL
Status: CLOSED UPSTREAM
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-07 15:10 UTC by Zayed Al-Saidi
Modified: 2009-02-15 22:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zayed Al-Saidi 2008-06-07 15:10:24 UTC
Version:            (using Devel)
Installed from:    Compiled sources
OS:                Linux

When I convert from English version of kde to Arabic version, the panel still LTR . I the past kicker support rtl and ltr.
Comment 1 Aaron J. Seigo 2008-06-09 02:03:55 UTC
SVN commit 818610 by aseigo:

prepare ourselves for upstream fixes ;-P
CCBUG:163459


 M  +3 -0      applet.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=818610
Comment 2 Aaron J. Seigo 2008-06-09 02:05:40 UTC
this is an upstream bug in Qt. the layouts in QGraphicsView currently lack LayoutDirection awareness. the documentation says otherwise, but the code obviously doesn't take it into consideration. i will report this upstream, but close the bug here as there's no way to effectively track upstream bugs here.
Comment 3 Diego Iastrubni 2008-06-09 13:07:51 UTC
I actually disagree... please keep it open, to remind users that we are aware 
of this issue.

On Monday 09 June 2008 03:05:41 Aaron J.Seigo wrote:
> ------- Additional Comments From aseigo kde org  2008-06-09 02:05 -------
> this is an upstream bug in Qt. the layouts in QGraphicsView currently lack
> LayoutDirection awareness. the documentation says otherwise, but the code
> obviously doesn't take it into consideration. i will report this upstream,
> but close the bug here as there's no way to effectively track upstream bugs
> here. 

Comment 4 Aaron J. Seigo 2008-06-09 21:53:00 UTC
i understand people like to use the bug tracker as some sort of public forum. i use it as a development tool. 

do you know how many open reports we'd have if i kept every upstream bug reported in qt, x.org, graphics drivers, hal, etc here? it would be even less useful than it is now for us as developers.

if users want a communications medium for these things, that should live elsewhere.
Comment 5 Dotan Cohen 2008-06-30 15:28:21 UTC
@Aaron:
What is the address of the upstream bug? I am not familiar with the Qt bugtracker and I cannot find it. I believe that a bug of mine may be a dupe of this bug, and I'd like to comment on the related blocking Qt bug. Thanks. Here is my (likely) dupe:
http://bugs.kde.org/show_bug.cgi?id=165406

Additionally, I think that this bug should be marked LATER and not INVALID as it certainly is valid, and as you point out it cannot be fixed until LATER. Do you object to me reclassifying the bug?

Thanks.
Comment 6 Diego Iastrubni 2008-06-30 15:34:12 UTC
Dotan,

This is *not* a KDE bug. This is a *Qt*, and thus this will remain closed. However, I am wondering if we can overcome it by writting our our "forked" layout classes for KDE 4.1 until Qt4.5 will come and fix this issue.

About 165406, this is not related to this problem. Please keep on topic.

יא חוליגן :)
Comment 7 Zayed Al-Saidi 2008-08-20 09:29:06 UTC
Does Qt4.1.1 fix this problem or we should wait till Qt4.5 ? I worried about if they are going to fix this problem in Qt 4.5 or not !
Comment 8 Dotan Cohen 2008-11-10 17:47:18 UTC
Now that the issue is fixed in Qt, I am reopening this bug so that it can be fixed in KDE. Here is the Qt bug:
http://trolltech.com/developer/task-tracker/index_html?method=entry&id=181177

If this was not the correct Qt bug then please post the correct bug here. Thanks.
Comment 9 Zayed Al-Saidi 2008-11-10 18:29:47 UTC
@ Datan

That's wrong bug :) the right one is : 
http://trolltech.com/developer/task-tracker/index_html?method=entry&id=233662

Comment 10 Dotan Cohen 2008-11-10 22:31:01 UTC
Shukron, Zayed!
Comment 11 Aaron J. Seigo 2008-11-10 23:16:50 UTC
Dotan, you are officially annoying me now.

This bug is upstream. There is nothing we can do about it in KDE. Whether or not Qt Software fixes it now, yesterday or a year from now .. it's an upstream bug.

Continuing to re-open this bug just wastes my time. Please stop doing it.

If you feel that there is additional information to be offered, just comment on the bug. I (and the rest of the plasma-bugs list) gets CC'd on those comments. Then we can decide to re-open it or whatever other action is appropriate at that point.
Comment 12 Zayed Al-Saidi 2009-02-15 22:44:55 UTC
finally, Qt team fix this problem in Qt4.5. Thank you to everyone participates to solve this problem.