Bug 163395 - digikam and encoding errors in mail attachments
Summary: digikam and encoding errors in mail attachments
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Generic-SendByMail (show other bugs)
Version: 5.6.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-06 21:57 UTC by Anders Lund
Modified: 2017-07-10 10:15 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments
kommentarer.txt (250 bytes, text/plain)
2008-06-07 21:08 UTC, Anders Lund
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Lund 2008-06-06 21:57:29 UTC
Version:           0.9.3 (using 3.5.9, Kubuntu (hardy) 4:3.5.9-0ubuntu7.1)
Compiler:          Target: x86_64-linux-gnu
OS:                Linux (x86_64) release 2.6.24-16-generic

Exporting to flickr, if I elect to use the application tags and they contain danish letters æøå, they are misencoded when arriving at the flickr pages.

I suspect that digikam exports in the local encoding, in my case utf8, but should either convert to http standard (iso8859-1) or set an encoding header, if that is supported by flickr.

Sending images using Image->email, digikam attaches a file with comments, which also contains misencoded text in my case. Again, the danish characters æøå reveals the problem.
Comment 1 x3ri7yz02 2008-06-07 10:00:43 UTC
Hi Anders,

I'd like to test this with the current SVN build. I grabbed a few Danish characters from Wikipedia to use as tags/comments - they appear to me to be preserved correctly during Flickr upload and email export using the SVN build of Digikam. 

To confirm, are you able to attach (or send via email) an appropriately tagged and/or commented image?

thanks in advance,
tauri
Comment 2 Anders Lund 2008-06-07 21:08:04 UTC
Here is a sample image


Created an attachment (id=25197)
kommentarer.txt
Comment 3 Anders Lund 2008-06-07 21:14:47 UTC
> ------- Additional Comments From x3ri7yz02 sneakemail com  2008-06-07 10:00
> ------- Hi Anders,
>
> I'd like to test this with the current SVN build. I grabbed a few Danish
> characters from Wikipedia to use as tags/comments - they appear to me to be
> preserved correctly during Flickr upload and email export using the SVN
> build of Digikam.
>
> To confirm, are you able to attach (or send via email) an appropriately
> tagged and/or commented image?
>
> thanks in advance,
> tauri


Responding to this mail revealed another problem: I used the digikam 
Image->Email to action to send it, and it was given a name including the 
comment, which made kmail give up and name it 'unnamed' and not being able to 
display it.

The comment file attached by digikam was claimed to be is08859-1 encoded in 
the mail, but it is utf8 encoded (i tried opening it in kwrite)

I can upload a image to flickr for you if you'd like me to as well.
Comment 4 caulier.gilles 2008-06-09 09:37:28 UTC
Anders,

About FlickrExport tool, the UTF8 encoding is no properlly supported in current 0.1.6-beta1 tarball of kipi-plugins.

So this report is now only valid for SendImages kipi-plugin, if this bug is not already fixed with this tool into 0.1.6 beta1.

Please, try with the beta release of kipi-plugins and report again. Thanks in advance

Gilles Caulier
Comment 5 caulier.gilles 2008-06-09 10:00:05 UTC
Anders,

Sorry, you must read :

About FlickrExport tool, the UTF8 encoding is _now_ properlly supported in current 0.1.6-beta1 tarball of kipi-plugins.

Gilles
Comment 6 x3ri7yz02 2008-06-09 10:01:36 UTC
Gilles/Anders,

Works for me (using SVN).  Tested using characters provided by Anders as well as from Wikipedia (per above).
Comment 7 caulier.gilles 2008-12-08 09:15:19 UTC
Thanks for the report. I close this file now.

Gilles Caulier
Comment 8 caulier.gilles 2017-07-10 10:15:33 UTC
This problem is not reproducible with new Send By Mail tool from digiKam core
version 5.7.0.

Gilles Caulier