Bug 163355 - Gwenview 4.1 beta1 crashe when opening very large file
Summary: Gwenview 4.1 beta1 crashe when opening very large file
Status: RESOLVED REMIND
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-06 12:20 UTC by Jord
Modified: 2012-10-19 13:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jord 2008-06-06 12:20:31 UTC
Version:            (using Devel)
Installed from:    Compiled sources
OS:                Linux

Using the Ubuntu kde 4.1 beta1 packages. Gwenview crashes when opening a very largen png (23 Mb) or very large Tiff (30 Mb).

Application: Gwenview (gwenview), signal SIGSEGV
(no debugging symbols found)
...
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7f035a900780 (LWP 17522)]
[New Thread 0x425d4950 (LWP 17526)]
(no debugging symbols found)
...
(no debugging symbols found)
[KCrash handler]
#5  0x00007f035841ab14 in ?? () from /usr/lib/libQtGui.so.4
#6  0x00007f0358412c1a in QImage::copy () from /usr/lib/libQtGui.so.4
#7  0x00007f0358412ff5 in QImage::detach () from /usr/lib/libQtGui.so.4
#8  0x00007f0358413c93 in QImage::setNumColors () from /usr/lib/libQtGui.so.4
#9  0x00007f03584439d5 in ?? () from /usr/lib/libQtGui.so.4
#10 0x00007f035844480c in ?? () from /usr/lib/libQtGui.so.4
#11 0x00007f035841e15e in QImageReader::read () from /usr/lib/libQtGui.so.4
#12 0x00007f035a4cf813 in ?? () from /usr/lib/kde4/lib/libgwenviewlib.so.1
#13 0x00007f035a4cefb9 in ?? () from /usr/lib/kde4/lib/libgwenviewlib.so.1
#14 0x00007f0358ffb55d in ?? () from /usr/lib/libQtCore.so.4
#15 0x00007f0359004db5 in ?? () from /usr/lib/libQtCore.so.4
#16 0x00007f035418d3f7 in start_thread () from /lib/libpthread.so.0
#17 0x00007f0357c1cb2d in clone () from /lib/libc.so.6
#18 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f035a900780 (LWP 17522)):
#0  0x00007f0354191b99 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#1  0x00007f0359005835 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#2  0x00007f0358ffb16d in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f0358ffb238 in QThreadPool::~QThreadPool ()
   from /usr/lib/libQtCore.so.4
#4  0x00007f0358ffa319 in ?? () from /usr/lib/libQtCore.so.4
#5  0x00007f0357b7a110 in exit () from /lib/libc.so.6
#6  0x00007f03583cf8d8 in ?? () from /usr/lib/libQtGui.so.4
#7  0x00007f03599f9280 in KApplication::xioErrhandler ()
   from /usr/lib/kde4/lib/libkdeui.so.5
#8  0x00007f0355b70c94 in _XIOError () from /usr/lib/libX11.so.6
#9  0x00007f0355b76f88 in _XPutXCBBuffer () from /usr/lib/libX11.so.6
#10 0x00007f0355b7832f in _XSend () from /usr/lib/libX11.so.6
#11 0x00007f0355b652d0 in ?? () from /usr/lib/libX11.so.6
#12 0x00007f0355b654f1 in XPutImage () from /usr/lib/libX11.so.6
#13 0x00007f035843717f in ?? () from /usr/lib/libQtGui.so.4
#14 0x00007f035842aa1f in QPixmap::fromImage () from /usr/lib/libQtGui.so.4
#15 0x00007f035845e7ce in QPaintEngine::drawImage ()
   from /usr/lib/libQtGui.so.4
#16 0x00007f03584f770e in ?? () from /usr/lib/libQtGui.so.4
#17 0x00007f03584699ea in ?? () from /usr/lib/libQtGui.so.4
#18 0x00007f035846b5ff in QPainter::drawRects () from /usr/lib/libQtGui.so.4
#19 0x00007f035846b6eb in QPainter::fillRect () from /usr/lib/libQtGui.so.4
#20 0x00007f03513da434 in ?? ()
   from /usr/lib/kde4/lib/kde4/plugins/styles/oxygen.so
#21 0x00007f03513dc0c6 in ?? ()
   from /usr/lib/kde4/lib/kde4/plugins/styles/oxygen.so
#22 0x00007f03513e89af in ?? ()
   from /usr/lib/kde4/lib/kde4/plugins/styles/oxygen.so
#23 0x00007f03590e640e in QCoreApplicationPrivate::sendThroughObjectEventFilters () from /usr/lib/libQtCore.so.4
#24 0x00007f035837a520 in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#25 0x00007f035837f125 in QApplication::notify () from /usr/lib/libQtGui.so.4
#26 0x00007f03599fa561 in KApplication::notify ()
   from /usr/lib/kde4/lib/libkdeui.so.5
#27 0x00007f03590e6109 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#28 0x00007f03583d0c3c in ?? () from /usr/lib/libQtGui.so.4
#29 0x00007f03583cb771 in QWidgetPrivate::drawWidget ()
   from /usr/lib/libQtGui.so.4
#30 0x00007f0358514183 in ?? () from /usr/lib/libQtGui.so.4
#31 0x00007f0358514872 in ?? () from /usr/lib/libQtGui.so.4
#32 0x00007f03583c8277 in QWidget::event () from /usr/lib/libQtGui.so.4
#33 0x00007f03586e2361 in QMainWindow::event () from /usr/lib/libQtGui.so.4
#34 0x00007f0359a93d1b in KMainWindow::event ()
   from /usr/lib/kde4/lib/libkdeui.so.5
#35 0x00007f0359ac3b90 in KXmlGuiWindow::event ()
   from /usr/lib/kde4/lib/libkdeui.so.5
#36 0x00007f035837a54f in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#37 0x00007f035837f125 in QApplication::notify () from /usr/lib/libQtGui.so.4
#38 0x00007f03599fa561 in KApplication::notify ()
   from /usr/lib/kde4/lib/libkdeui.so.5
#39 0x00007f03590e6109 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#40 0x00007f03590e742b in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#41 0x00007f035910f0b3 in ?? () from /usr/lib/libQtCore.so.4
#42 0x00007f03543da262 in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#43 0x00007f03543dd516 in ?? () from /usr/lib/libglib-2.0.so.0
#44 0x00007f03543dd9af in g_main_context_iteration ()
   from /usr/lib/libglib-2.0.so.0
#45 0x00007f035910f3af in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#46 0x00007f035840372f in ?? () from /usr/lib/libQtGui.so.4
#47 0x00007f03590e5585 in QEventLoop::processEvents ()
   from /usr/lib/libQtCore.so.4
#48 0x00007f03590e56db in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#49 0x00007f03590e7729 in QCoreApplication::exec ()
   from /usr/lib/libQtCore.so.4
#50 0x0000000000433ead in ?? ()
#51 0x00007f0357b631c4 in __libc_start_main () from /lib/libc.so.6
#52 0x000000000041f829 in _start ()
#0  0x00007f0354191b99 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
Comment 1 Lubos Lunak 2008-07-21 16:23:08 UTC
SVN commit 835987 by lunakl:

Remove emitting of aboutToQuit() from KApplication::xioErrhandler() - the application
is not about to quit, it is about to fall flat on its face. There is really not that
much to do once KDE apps lose their connection to the X server. How that can happen
while the X server still continues to run is a different question and I don't know
the answer. It is quite possible it is caused by careless usage of one X connection
from several threads concurrently without proper locking.

CCBUG: 166685
CCBUG: 166432
CCBUG: 166401
CCBUG: 166179
CCBUG: 165451
CCBUG: 165307
CCBUG: 165059
CCBUG: 164740
CCBUG: 164665
CCBUG: 163751
CCBUG: 163355
CCBUG: 161787
CCBUG: 160692
CCBUG: 160458
CCBUG: 158194
CCBUG: 158088
CCBUG: 157607
CCBUG: 154011
CCBUG: 151293
CCBUG: 146891
CCBUG: 146700
CCBUG: 146562
CCBUG: 144383
CCBUG: 143375
CCBUG: 141871
BUG: 140683
CCBUG: 139162
CCBUG: 134708
CCBUG: 133332
CCBUG: 128588
CCBUG: 112960



 M  +0 -1      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=835987
Comment 2 Dario Andres 2008-12-28 02:09:56 UTC
Have you experienced this bug again with a recent KDE version? (4.1.3 / 4.2beta2 / 4.2svn) ?  Thanks :)
Comment 3 Dario Andres 2009-02-21 14:25:42 UTC
No response from reporter. Closing as REMIND. Reopen if you still experience this. Thanks