Bug 163108 - Ark doesn't create directory when extracting an archive
Summary: Ark doesn't create directory when extracting an archive
Status: RESOLVED FIXED
Alias: None
Product: ark
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Harald Hvaal
URL:
Keywords:
: 202475 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-03 03:11 UTC by Elias Probst
Modified: 2009-08-05 19:40 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2008-06-03 03:11:40 UTC
Version:           SVN r816000 (using Devel)
Installed from:    Compiled sources

How to reproduce:
1. Open an archive file in ark
2. Select 'Extract' from the toolbar
3. Expand the path of 'Destination folder' (default is /home/user, try /home/user/test  for example)
4. Click OK

What happens:
Ark doesn't create the directory specified in the 'Destination folder' path and nothing is extracted

What should happen:
Ark should create the specified directory if it doesn't exist yet and extract all files into it.
Comment 1 Sebastian Turzański 2008-07-26 10:07:36 UTC
I confirm on 4.1 rc1 from opensuse repo
Comment 2 Harald Hvaal 2008-08-03 11:47:39 UTC
The current trunk has a refined extraction dialog that allows creation of subfolder. But the usage defined here is still not possible, so I changed the bug to a wishlist item that I will look into later.
Comment 3 S. Burmeister 2008-09-21 20:45:44 UTC
This is a bug and not a wishlist item, since ark does not warn the user that the folder was not created but just extracts to a path the user did not define. I don't think that notifiying the user about a failure is a feature request.
Comment 4 Harald Hvaal 2008-09-22 00:57:37 UTC
It doesn't matter whether it's classified as a bug or a wishlist item really; it's still one of the things I'm going to fix for 4.2.
Comment 5 Harald Hvaal 2008-10-18 18:32:40 UTC
SVN commit 873050 by metellius:

BUG: 163108
Ark will now prompt to create unexisting directories in extractiondialog.


 M  +33 -5     extractiondialog.cpp  
 M  +1 -0      extractiondialog.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=873050
Comment 6 Bartemius Crouch 2008-11-18 21:42:32 UTC
Does this mean it went only for 4.2? Because I have KDE 4.1.3 (ark 2.10.999) from 3rd of November and the bug persists. I was filing a bug report when I found this one.
Comment 7 Harald Hvaal 2008-11-19 08:23:52 UTC
@Bartemius: yes, the change was only for 4.2 version.
I unfortunately did not have time for a lot of backports for 4.1.3, and since the extraction dialog is entirely redesigned for 4.2, I could not use the patch for 4.2 just like that in 4.1.3.
Comment 8 Raphael Kubo da Costa 2009-08-05 19:40:41 UTC
*** Bug 202475 has been marked as a duplicate of this bug. ***