Bug 163102 - [test-case]Information panel causes dolphin to crash on mouse-over an .avi file
Summary: [test-case]Information panel causes dolphin to crash on mouse-over an .avi file
Status: RESOLVED DUPLICATE of bug 163050
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 163096 163250 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-03 00:19 UTC by Rui G.
Modified: 2009-01-07 01:22 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
backtrace from the crash (4.26 KB, text/plain)
2008-06-03 00:27 UTC, Rui G.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rui G. 2008-06-03 00:19:02 UTC
Version:           revision 815688 (using Devel)
Installed from:    Compiled sources
Compiler:          gcc (GCC) 4.3.0 
OS:                Linux

This bug is only reproducible if the information panel is activated.

1)Download the following file http://pobox.com/~zahl/kde/monty.avi (thanks to blauzhal for hosting).
2)Go to the directory where you downloaded the file with dolphin, and put the mouse over.
3)Dolphin will attempt to gather information and crash in the process.

This happens with a lot of .avi files I have. This test-case what made in a hurry, I believe any smaller test-cases found through google will have the same outcome.
Comment 1 Rui G. 2008-06-03 00:27:59 UTC
Created attachment 25077 [details]
backtrace from the crash
Comment 2 Peter Penz 2008-06-03 07:54:51 UTC
Corresponding to the backtrace this looks like a strigi issue triggered by simply using KFileMetaInfo.
Comment 3 Peter Penz 2008-06-03 07:59:45 UTC
*** Bug 163096 has been marked as a duplicate of this bug. ***
Comment 4 Mikko C. 2008-06-03 18:18:00 UTC
I think my problem is similar, even if I don't get a crash, but instead I get a 30-40 sec hanging of Dolphin, and hard-disk activity, where the file is stored.
If I disable the Information Panel everything is fine.

The first time I put the mouse over the file I get this:

/usr/lib64/strigi/strigila_xpm.so                                                                                            
/usr/lib64/strigi/strigita_gif.so                                                                                            
/usr/lib64/strigi/strigita_xbm.so                                                                                            
/usr/lib64/strigi/strigita_avi.so                                                                                            
/usr/lib64/strigi/strigila_txt.so                                                                                            
/usr/lib64/strigi/strigila_deb.so                                                                                            
/usr/lib64/strigi/strigita_pcx.so                                                                                            
/usr/lib64/strigi/strigita_dds.so                                                                                            
/usr/lib64/strigi/strigila_cpp.so                                                                                            
/usr/lib64/strigi/strigila_namespaceharvester.so                                                                             
/usr/lib64/strigi/strigita_wav.so                                                                                            
/usr/lib64/strigi/strigita_sid.so                                                                                            
/usr/lib64/strigi/strigita_au.so                                                                                             
/usr/lib64/strigi/strigita_ico.so                                                                                            
/usr/lib64/strigi/strigita_rgb.so                                                                                            
WARNING: field 'maxLineLength' is not defined in any rdfs ontology database.                                                 
WARNING: field 'line ending format' is not defined in any rdfs ontology database.                                            
WARNING: field 'dds volume depth' is not defined in any rdfs ontology database.                                              
WARNING: field 'dds mipmap count' is not defined in any rdfs ontology database.                                              
WARNING: field 'dds image type' is not defined in any rdfs ontology database.                                                
WARNING: field 'document.stats.image_count' is not defined in any rdfs ontology database.                                    
WARNING: field 'document.stats.image_name' is not defined in any rdfs ontology database.                                     
WARNING: field 'document.stats.image_shared_rows' is not defined in any rdfs ontology database.                              
dolphin(6382) KFileMetaInfoPrivate::init: KUrl("file:///mnt/mybook/foobar.avi")
resetting is impossible!! pos: 8202 status: 0

<<<HANGS HERE>>>

loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#mediaDuration"                                      
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#verticalResolution"                                 
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#sourceModified"                                     
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#size"                                               
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#frameRate"                                          
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#audioCodec"                                         
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#name"                                               
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#videoCodec"                                         
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#url"                                                
loading writer for key  "http://strigi.sf.net/ontologies/0.9#parentUrl"                                                      
loading writer for key  "http://strigi.sf.net/ontologies/0.9#depth"                                                          
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#fileExtension"



While the second time I put the mouse over it, it only shows the second part:

dolphin(6382) KFileMetaInfoPrivate::init: KUrl("file:///mnt/mybook/foobar.avi")
resetting is impossible!! pos: 8202 status: 0
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#mediaDuration"
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#verticalResolution"
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#sourceModified"
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#size"
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#frameRate"
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#audioCodec"
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#name"
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#videoCodec"
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#url"
loading writer for key  "http://strigi.sf.net/ontologies/0.9#parentUrl"
loading writer for key  "http://strigi.sf.net/ontologies/0.9#depth"
loading writer for key  "http://freedesktop.org/standards/xesam/1.0/core#fileExtension"
Comment 5 Mikko C. 2008-06-03 18:21:24 UTC
Ok, the time of hanging is proportional to the size of the video: 30-40 secs was for a 700mb movie.

For a 150mb video is <10 secs
Comment 6 Peter Penz 2008-06-05 06:31:25 UTC
*** Bug 163250 has been marked as a duplicate of this bug. ***
Comment 7 Rosetzky Cedric 2008-06-05 06:39:58 UTC
Yes my bug seems to be related to this one. Maybe this one too? 163171

I'll try to disable the information panel, and let you know if it becomes better.
Comment 8 Peter Penz 2008-06-05 06:51:36 UTC
I'm losing the oversight, as I got so many "Information Panel freezes" reports the last days... Bug #163050 explains the root cause.

*** This bug has been marked as a duplicate of 163050 ***
Comment 9 Wesley Velroij 2008-06-18 22:53:33 UTC
I had the crash to seems to happen only in dolphin in konqueror this doesnt happen.

Here is my debug output.

Application: Dolphin (dolphin), signal SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb624b720 (LWP 10903)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7fc0410 in __kernel_vsyscall ()
#7  0xb69e5085 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb69e6a01 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb69de10e in __assert_fail () from /lib/tls/i686/cmov/libc.so.6
#10 0xb638d488 in Strigi::DataEventInputStream::DataEventInputStream ()
   from /usr/lib/libstreams.so.0
#11 0xb6593b7e in ?? () from /opt/kde-nightly/lib/libstreamanalyzer.so.0
#12 0xb65bc28d in ?? () from /opt/kde-nightly/lib/libstreamanalyzer.so.0
#13 0xb65bcdc1 in Strigi::StreamAnalyzer::analyze ()
   from /opt/kde-nightly/lib/libstreamanalyzer.so.0
#14 0xb77cedd0 in ?? () from /opt/kde-nightly/lib/libkio.so.5
#15 0xb77cf1a3 in KFileMetaInfo::KFileMetaInfo ()
   from /opt/kde-nightly/lib/libkio.so.5
#16 0x0807d72f in ?? ()
#17 0x0807dd50 in ?? ()
#18 0x0807e7ad in ?? ()
#19 0xb7f291d8 in QMetaObject::activate ()
   from /opt/kde-nightly/lib/libQtCore.so.4
#20 0xb7f29832 in QMetaObject::activate ()
   from /opt/kde-nightly/lib/libQtCore.so.4
#21 0xb7f650f7 in QTimer::timeout () from /opt/kde-nightly/lib/libQtCore.so.4
#22 0xb7f3128e in QTimer::timerEvent ()
   from /opt/kde-nightly/lib/libQtCore.so.4
#23 0xb7f25a84 in QObject::event () from /opt/kde-nightly/lib/libQtCore.so.4
#24 0xb6e765bc in QApplicationPrivate::notify_helper ()
   from /opt/kde-nightly/lib/libQtGui.so.4
#25 0xb6e7d437 in QApplication::notify ()
   from /opt/kde-nightly/lib/libQtGui.so.4
#26 0xb7aa7ce3 in KApplication::notify ()
   from /opt/kde-nightly/lib/libkdeui.so.5
#27 0xb7f14f29 in QCoreApplication::notifyInternal ()
   from /opt/kde-nightly/lib/libQtCore.so.4
#28 0xb7f41a49 in ?? () from /opt/kde-nightly/lib/libQtCore.so.4
#29 0xb7f3eff0 in ?? () from /opt/kde-nightly/lib/libQtCore.so.4
#30 0xb68f2bf8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0xb68f5e5e in ?? () from /usr/lib/libglib-2.0.so.0
#32 0xb68f63ac in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0xb7f3f778 in QEventDispatcherGlib::processEvents ()
   from /opt/kde-nightly/lib/libQtCore.so.4
#34 0xb6f04e65 in ?? () from /opt/kde-nightly/lib/libQtGui.so.4
#35 0xb7f13fad in QEventLoop::processEvents ()
   from /opt/kde-nightly/lib/libQtCore.so.4
#36 0xb7f1414a in QEventLoop::exec () from /opt/kde-nightly/lib/libQtCore.so.4
#37 0xb7f165fa in QCoreApplication::exec ()
   from /opt/kde-nightly/lib/libQtCore.so.4
#38 0xb6e75bb7 in QApplication::exec ()
   from /opt/kde-nightly/lib/libQtGui.so.4
#39 0x080808e9 in ?? ()
#40 0xb69d0450 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#41 0x08061931 in _start ()
#0  0xb7fc0410 in __kernel_vsyscall ()
Comment 10 leonardo 2008-06-29 20:49:14 UTC
hi, first post here, and i have the same problem on mouse over a avi files, here the track:

Application: Dolphin (dolphin), signal SIGABRT
(no debugging symbol...


... debugging symbols found)
[KCrash handler]
#5  0x00007f515566c095 in raise () from /lib/libc.so.6
#6  0x00007f515566daf0 in abort () from /lib/libc.so.6
#7  0x00007f51556652df in __assert_fail () from /lib/libc.so.6
#8  0x00007f5150920ad6 in Strigi::DataEventInputStream::DataEventInputStream
    () from /usr/lib/libstreams.so.0
#9  0x00007f5154a7a4ce in ?? () from /usr/lib/libstreamanalyzer.so.0
#10 0x00007f5154a9f9aa in ?? () from /usr/lib/libstreamanalyzer.so.0
#11 0x00007f5154a9ff8c in Strigi::StreamAnalyzer::analyze ()
   from /usr/lib/libstreamanalyzer.so.0
#12 0x00007f515840aa1a in ?? () from /usr/lib/kde4/lib/libkio.so.5
#13 0x00007f515840addf in KFileMetaInfo::KFileMetaInfo ()
   from /usr/lib/kde4/lib/libkio.so.5
#14 0x0000000000439113 in ?? ()
#15 0x0000000000439734 in ?? ()
#16 0x000000000043a0fa in ?? ()
#17 0x00007f515760f286 in QMetaObject::activate ()
   from /usr/lib/libQtCore.so.4
#18 0x00007f5157609d35 in QObject::event () from /usr/lib/libQtCore.so.4
#19 0x00007f51563a554f in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#20 0x00007f51563aa125 in QApplication::notify () from /usr/lib/libQtGui.so.4
#21 0x00007f5157f133b1 in KApplication::notify ()
   from /usr/lib/kde4/lib/libkdeui.so.5
#22 0x00007f51575fb109 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#23 0x00007f51576263dc in ?? () from /usr/lib/libQtCore.so.4
#24 0x00007f5157623f4d in ?? () from /usr/lib/libQtCore.so.4
#25 0x00007f51526fa262 in g_main_context_dispatch ()
   from /usr/lib/libglib-2.0.so.0
#26 0x00007f51526fd516 in ?? () from /usr/lib/libglib-2.0.so.0
#27 0x00007f51526fd9af in g_main_context_iteration ()
   from /usr/lib/libglib-2.0.so.0
#28 0x00007f51576243c6 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#29 0x00007f515642e72f in ?? () from /usr/lib/libQtGui.so.4
#30 0x00007f51575fa585 in QEventLoop::processEvents ()
   from /usr/lib/libQtCore.so.4
#31 0x00007f51575fa6db in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#32 0x00007f51575fc729 in QCoreApplication::exec ()
   from /usr/lib/libQtCore.so.4
#33 0x000000000043be3e in ?? ()
#34 0x00007f51556581c4 in __libc_start_main () from /lib/libc.so.6
#35 0x0000000000420799 in _start ()
#0  0x00007f51556d7b50 in nanosleep () from /lib/libc.so.6
Comment 11 Dread Knight 2008-07-17 05:39:51 UTC
Have this issue myself.
Comment 12 David J. Knowles 2008-08-11 01:16:59 UTC
Here is another crash dump

Application: Dolphin (dolphin), signal SIGABRT
Using host libthread_db library "/lib/i686/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1244698928 (LWP 2483)]
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb65bb5d5 in raise () from /lib/i686/libc.so.6
#8  0xb65bd021 in abort () from /lib/i686/libc.so.6
#9  0xb65b470e in __assert_fail () from /lib/i686/libc.so.6
#10 0xb5e91f51 in Strigi::DataEventInputStream::DataEventInputStream ()
   from /usr/lib/libstreams.so.0
#11 0xb63c1ac8 in QAbstractItemView::verticalScrollbarAction ()
    at itemviews/qabstractitemview.cpp:2360
#12 0xb63f0f64 in QAbstractItemView::verticalScrollbarAction ()
    at itemviews/qabstractitemview.cpp:2360
#13 0xb63f1823 in Strigi::StreamAnalyzer::analyze ()
   from /usr/lib/libstreamanalyzer.so.0
#14 0xb7d2ba08 in KFileMetaInfoPrivate::init (this=0x8583700, 
    stream=@0xbfe2cdb8, url=@0xbfe2cdb0, mtime=1200818671)
    at /usr/src/debug/kdelibs-4.1.0/kio/kio/kfilemetainfo.cpp:201
#15 0xb7d2c157 in KFileMetaInfo (this=0xbfe2ce78, path=@0xbfe2ce7c)
    at /usr/src/debug/kdelibs-4.1.0/kio/kio/kfilemetainfo.cpp:224
#16 0x0807ef33 in InfoSidebarPage::showMetaInfo (this=0x8272da0)
    at /usr/src/debug/kdebase-4.1.0/apps/dolphin/src/infosidebarpage.cpp:388
#17 0x0807f3a0 in InfoSidebarPage::showItemInfo (this=0x8272da0)
    at /usr/src/debug/kdebase-4.1.0/apps/dolphin/src/infosidebarpage.cpp:223
#18 0x0807fb12 in InfoSidebarPage::qt_metacall (this=0x8272da0, 
    _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfe2cfe8)
    at /usr/src/debug/kdebase-4.1.0/build/apps/dolphin/src/infosidebarpage.moc:93
#19 0xb74fe3dc in QMetaObject::activate (sender=0x82c92b8, 
    from_signal_index=4, to_signal_index=4, argv=0x0)
    at kernel/qobject.cpp:3010
#20 0xb74feb05 in QMetaObject::activate (sender=0x82c92b8, m=0xb75d3ae4, 
    local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3080
#21 0xb753d2d5 in QTimer::timeout (this=0x82c92b8)
    at .moc/release-shared/moc_qtimer.cpp:126
#22 0xb7505a50 in QTimer::timerEvent (this=0x82c92b8, e=0xbfe2d478)
    at kernel/qtimer.cpp:263
#23 0xb74f9eda in QObject::event (this=0x82c92b8, e=0xbfe2d478)
    at kernel/qobject.cpp:1105
#24 0xb6a53651 in QApplicationPrivate::notify_helper (this=0x80c0fa0, 
    receiver=0x82c92b8, e=0xbfe2d478) at kernel/qapplication.cpp:3772
#25 0xb6a573e9 in QApplication::notify (this=0xbfe2d6e4, receiver=0x82c92b8, 
    e=0xbfe2d478) at kernel/qapplication.cpp:3366
#26 0xb7a10011 in KApplication::notify (this=0xbfe2d6e4, receiver=0x82c92b8, 
    event=0xbfe2d478)
    at /usr/src/debug/kdelibs-4.1.0/kdeui/kernel/kapplication.cpp:311
#27 0xb74e8d25 in QCoreApplication::notifyInternal (this=0xbfe2d6e4, 
    receiver=0x82c92b8, event=0xbfe2d478) at kernel/qcoreapplication.cpp:587
#28 0xb7517ebe in QTimerInfoList::activateTimers (this=0x80c3b24)
    at kernel/qcoreapplication.h:215
#29 0xb75156be in timerSourceDispatch (source=0x80c3af0)
    at kernel/qeventdispatcher_glib.cpp:166
#30 0xb6032a30 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#31 0xb6035d05 in QAbstractItemView::verticalScrollbarAction ()
    at itemviews/qabstractitemview.cpp:2360
#32 0xb6036218 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#33 0xb7515c3a in QEventDispatcherGlib::processEvents (this=0x80bb8b8, 
    flags=@0xbfe2d5c8) at kernel/qeventdispatcher_glib.cpp:325
#34 0xb6ae98aa in QGuiEventDispatcherGlib::processEvents (this=0x80bb8b8, 
    flags=@0xbfe2d5fc) at kernel/qguieventdispatcher_glib.cpp:204
#35 0xb74e7fe1 in QEventLoop::processEvents (this=0xbfe2d670, 
    flags=@0xbfe2d634) at kernel/qeventloop.cpp:149
#36 0xb74e8169 in QEventLoop::exec (this=0xbfe2d670, flags=@0xbfe2d678)
    at kernel/qeventloop.cpp:200
#37 0xb74ea21e in QCoreApplication::exec () at kernel/qcoreapplication.cpp:845
#38 0xb6a52d94 in QApplication::exec () at kernel/qapplication.cpp:3304
#39 0x08081509 in main (argc=-1075652460, argv=0x4122e989)
    at /usr/src/debug/kdebase-4.1.0/apps/dolphin/src/main.cpp:94
#40 0xb65a8390 in __libc_start_main () from /lib/i686/libc.so.6
#41 0x0805f2f1 in _start ()
#0  0xffffe410 in __kernel_vsyscall ()
Comment 13 Gianfranco L'Abbate 2009-01-07 01:22:57 UTC
The issue is not only with video, with images is the same (hd continue action, dolphin slow/freeze, many process kio_thumbnails in execution). Ok after closing Info panel.