Bug 162950 - View albums thumbnail in icon-view with a special frame as Dolphin
Summary: View albums thumbnail in icon-view with a special frame as Dolphin
Status: RESOLVED NOT A BUG
Alias: None
Product: digikam
Classification: Unclassified
Component: Thumbs-IconView (show other bugs)
Version: 0.9.3
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-31 17:01 UTC by Tristan Grimaux
Modified: 2017-07-28 20:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0
caulier.gilles: Junior_Jobs+


Attachments
Sub Albums are shown with a different frame (110.66 KB, image/png)
2008-06-01 21:57 UTC, Tristan Grimaux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Grimaux 2008-05-31 17:01:03 UTC
Version:           0.9.3 (using KDE 3.5.9)
Installed from:    Ubuntu Packages
OS:                Linux

Albums are folders, so they could appear with a special frame, (and if you hover the album you could see the different photos in it, like iPhoto 08, but that's too much to ask).

When you are working with a big album tree, the albums who are masters and have only sub-albums inside appears empty when they are as a concept, full of things!
Comment 1 caulier.gilles 2008-05-31 17:17:07 UTC
Tristan,

Please, screenshoots and moc-up are welcome. What do you want exactly?

Gilles Caulier
Comment 2 Andi Clemens 2008-05-31 18:33:45 UTC
Tristan,

I don't really know what you are talking about.
Lets say we have the following folder structure:

2008
|- Holiday
   |- Place A
   |- Place B
|- Whatever

2008 has no images in it, but if you select the folder, you want to display all images in the subfolders, not only the empty folder "2008"?
If so, this feature is already available in digiKam (0.9.3 and higher) and can be found in the menu "View->Include Album-Subtree".

But if you are talking about something else, please provide us with more information, maybe a screenshot or a link to a webpage showing this feature will help.
Comment 3 Tristan Grimaux 2008-06-01 21:34:04 UTC
If you are on folder 2008, you should see 2 icons: Holyday and Whatever. With a special frame to show that they are sub-albums. The icon of those albums may be a folder, or the album icon selected by the user.

Why is this useful? First of all, it makes navigation very similar to what navigation is when you are using konqueror, or dolphin or nautilus.

Second, you can select more than a sub-album, and, for instance, reorganize faster. You can even show a preview of the album contents, just like iPhoto does (but iPhoto messes the idea calling it "events" and erasing the concept of a sub-event)

I am working on a moc-up
Comment 4 Tristan Grimaux 2008-06-01 21:57:13 UTC
Created attachment 25051 [details]
Sub Albums are shown with a different frame
Comment 5 Mikolaj Machowski 2008-06-07 15:49:49 UTC
> Sub Albums are shown with a different frame


Please, no. Containers are in left panel, items are in main area.
Comment 6 Tristan Grimaux 2008-06-07 16:22:23 UTC
Containers ARE items of different type. If you include ALBUMS as items, you can operate over these special items. Left panel is navigational, it is not supposed to allow the selection of two or more albums.

Albums can be exported, printed, deleted, batch processed, converted, and a lot of operations almost like photos. When having lots of photographs, and a good hierarchical tree, showing all the photos of the entire sub-tree takes a long time and too much resources, when there is no reason: people uses the sub-tree structure just to show a limited amount of things. And having no way to select 10 albums over 80 and move them away is really annoying.

Comment 7 Mikolaj Machowski 2008-06-07 17:04:25 UTC
> 16:22 ------- Containers ARE items of different type. If you include
> ALBUMS as items, you can operate over these special items. Left panel is
> navigational, it is not supposed to allow the selection of two or more
> albums.


True. But IMO it is bug of left panel, adding containers to main view is
only workaround of what should be fixed in first place.
Comment 8 Tristan Grimaux 2008-06-07 18:46:42 UTC
what should be fixed in the first place? Allowing multiple selections in the navigational panel? This is not a bug! Navigation is a way to put the user in a place, that's what navigation is for. Selecting many places at the same time could create a breach in the space-continuum and break reality. Or even worse: it certainly will have consequences over the way you manage your collection. It's navigation, don't mess with that.

Adding Albums to the concept of "items" is giving them it's true power: You can assign a big icon to he Album, but you will never see it big because you cannot resize the left panel icons. Imagine what it is to see them the same size you are watching the rest of the items. Cool!

Go further. You have assigned a template to a certain album (nice to have feature), so your pictures look like a book, or a photo-album. You will see this item as a book in 3d, and in the cover, the icon of the main photo. Now place that image in a little icon on the left panel and you will lose the best of it.
Comment 9 caulier.gilles 2008-12-08 12:40:29 UTC
Marcel, 

It will be relevant of Qt4 Model/View i think... but i'm not sure if we want this...

Gilles
Comment 10 caulier.gilles 2015-05-10 14:23:32 UTC
Album view is displayed to left panel (tree-view).
Middle panel is album contents. There is no need of special frame around icon-view item.

Gilles Caulier