Bug 162760 - Transfer file MSN crash
Summary: Transfer file MSN crash
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Applications
Component: MSN Plugin (show other bugs)
Version: 0.50.1
Platform: Fedora RPMs Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 168159 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-05-28 18:49 UTC by Anton Galitch
Modified: 2008-09-22 20:34 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace (4.01 KB, text/plain)
2008-07-20 03:04 UTC, Martin Sandsmark
Details
kopete kcrash (6.82 KB, application/octet-stream)
2008-09-11 03:30 UTC, Arthur Pemberton
Details
Backtrace (4.13 KB, text/plain)
2008-09-18 06:21 UTC, Rubens de Souza Matos Júnior
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Galitch 2008-05-28 18:49:55 UTC
Version:           0.50.1 (using KDE 4.0.4)
Installed from:    Fedora RPMs
OS:                Linux

When I send a file by MSN, the transfer goes well, but at the end of the transfer it crashes.

This is the backtrace:

(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb803e730 (LWP 3136)]
[KCrash handler]
#6  0x0348678d in Kopete::MessageEvent::message ()
   from /usr/lib/libkopete.so.4
#7  0x0806889b in _start ()
Comment 1 Matt Rogers 2008-07-07 05:36:34 UTC
There was a fix committed to subversion today that might address this and it should be in the KDE 4.1 RC 1 release. When that comes out (in a few weeks, i think) could you retest this to verify whether or not the bug is still a problem?

Thanks!
Comment 2 Martin Sandsmark 2008-07-20 03:04:09 UTC
Created attachment 26276 [details]
Backtrace

Backtrace after trying to reproduce (under same circumstances, so we guess it's
related, at least).
Comment 3 Martin Sandsmark 2008-07-20 03:06:31 UTC
Kopete Version 0.50.80 from 4.0.99 (4.1 branch).
Comment 4 George Kiagiadakis 2008-07-22 23:05:24 UTC
I tried to reproduce this too, the transfer goes up to 100% and the transfer window doesn't close, I have to close it manually. The problem is that the file is corrupted (missing some bytes from the header). Quite strange because that *was* the "expected" behaviour in kopete from kde3 but using kopete from kde 4.1 beta, it used to work. Now it doesn't work again... No crash, though.
Comment 5 George Kiagiadakis 2008-08-04 00:09:01 UTC
*** Bug 168159 has been marked as a duplicate of this bug. ***
Comment 6 Arthur Pemberton 2008-09-11 03:30:15 UTC
Created attachment 27363 [details]
kopete kcrash

Kopete 0.50.80 in Fedora 9 KDE 4.1

I get a crash attempting to send a file to a contact via the MSN protocol (through a router/firewall to internet).

Attempt 1 : Crash (no gdb)
          : install gdb for future crash
Attempt 2 : Transfer completes
Attempt 3 : Crash (captured .krash) (sent wrong file first time)
Attempt 4 : Transfer completes
Comment 7 manolis 2008-09-17 16:05:05 UTC
Same here with 4.1.1
kopete crashes immediately on transfer's end.
Notice that if I transfer more than one files simultaneously, the crash happens only if the last transfer window ends.

Comment 8 Rubens de Souza Matos Júnior 2008-09-18 06:21:12 UTC
Created attachment 27464 [details]
Backtrace
Comment 9 Rubens de Souza Matos Júnior 2008-09-18 06:25:31 UTC
Comment on attachment 27464 [details]
Backtrace

I had the same problem when a person has sent a file to me. He tried 2 times and in both trials kopete crashed when the transfer reached 100%. I am using kopete in Debian Lenny, with KDE 4.1.1. Although, both files were received without corruption.
Comment 10 Roman Jarosz 2008-09-22 20:34:32 UTC
SVN commit 863633 and 863634 (4.1 backport) by rjarosz:

Don't show notification if from() is 0.
Fixes bug 162760: Transfer file MSN crash.

M  +1 -1      kopeteviewmanager.cpp