Bug 162571 - Folder View applet needs scroll bar for folders with large number of items
Summary: Folder View applet needs scroll bar for folders with large number of items
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-folderview (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 21 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-24 19:04 UTC by Joe Kowalski
Modified: 2008-06-28 18:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Kowalski 2008-05-24 19:04:16 UTC
Version:            (using Devel)
Installed from:    Compiled sources
Compiler:          gcc-4.2 
OS:                Linux

It would be helpful for folder view applets to have a scrollbar for folders that have more items than can fit in the applet. It would probably look best for the scrollbar to appear and disappear on mouse hover. Forgive me if this feature is already planned, but the usefulness of the folder view is really cut back without it.
Comment 1 Michael Braun 2008-06-06 15:48:44 UTC
I would agree with this wish. If you add e.g. a documents folder to the folder view you need the possibility to scroll through the folders and files. So hopefully you can add the possibility.
Comment 2 FiNeX 2008-06-09 12:50:56 UTC
I agree with this feature.
Comment 3 Clovis Gladstone 2008-06-13 07:50:52 UTC
Yes, this definitely seems like a restriction that makes it unusable for me at the moment. I see two solutions to the problem of having a folder with many items to display : either add a scroll bar or scale down all the files contained in the folder to make it fit the assigned space.
Comment 4 S. Burmeister 2008-06-13 08:26:40 UTC
Following plasma's motto the content should adjust itself to the restrictions set by the user. Hence, if a user thinks that a folderview is more important and hence deserves more space icons should become bigger. If the space is only small, icons should adjust to it.

Only if the smalles icon-size does not fit a scroll-bar should be used as a last resort.

This would not need any new strings and hence could still be added before the 4.1 release.

BTW, adjusting the icon-size for desktop/filemanagement ins ystemsettings does not have any effect either with yesterday's trunk.
Comment 5 FiNeX 2008-06-13 09:16:26 UTC
Icons should adjust? Even labels (file names)? If you add/remove a file, will all icons be resized?
Comment 6 S. Burmeister 2008-06-13 10:11:39 UTC
Yes, content has to fit the size not the other way around, including text, which can be decreased until "smallesReadableFont" is reached, spaces inbetween the icons etc.

Don't forget, if the user thinks the icons are too small, he will increase the size of the plasmoid and the other way around. So the user will never get too small icons if he does not want to.

Currently the user is forced to stick to one size and has no possibility to see/work with icons that do not fit into the folderview, i.e. it is not the user's choice how the folderview looks like.
Comment 7 FiNeX 2008-06-13 10:40:06 UTC
I don't fully agree to resize the font size too.
Anyway, maybe in future it should be added the "minimum icon size"

Personally I'd like something like "force scroll bar" and let the user choose the icon size.
Comment 8 Clovis Gladstone 2008-06-13 18:21:11 UTC
With the strings freeze adding options like "force scroll bar" is impossible. I really think it is more logical to follow the plasma style by adjusting the size of the icons. Adding a scrollbar is like having dolphin embedded into the desktop , which is not, it seems to me, in the spirit of plasma. Dynamic resizing of icons is the way to go, which means making the folderview act like a widget and not like a filebrowser (dolphin is around for that)
Comment 9 FiNeX 2008-06-13 18:50:36 UTC
I know we're in string freeze, don't worry. It could be added later.
Anyway, what does it mean "the spirit of plasma"? Even with the scrollbar the folderview will continue to act like a widget which is exactly a file browser, his own purpose.

The purpose of the folder view is to allow the user to browse a specific directory. We have two possibility:
1) show all it's contents without interesting if it is readable (small icons could equals less readability for a lot of users)
2) show even partially the content, but with a size that will be readable by users.

I understand that "usually" plasmoid resize themself and their contents, but this should be done conscientiously.

Now, waiting for the 4.1, we can even keep the folder view as it is. For next release I suggest to let users choose they prefer.
Comment 10 Clovis Gladstone 2008-06-13 21:00:29 UTC
I'm sorry if what I said sounded offensive in any way. I was just thinking of a solution that would make folderview usable (for me anyway) in 4.1. And the scrollbar idea could still fit with "the spirit of plasma" (why in the world did I use this expression in the first place ?). It could be an interesting feature, but I just think it has the problem of not making everything visible at once if enabled, which I believe to be the idea behind the dashboard view (unless I'm mistaken). 
Comment 11 FiNeX 2008-06-13 22:57:03 UTC
You've said nothing offensive. I want only take a hard look to the question :-)
Comment 12 S. Burmeister 2008-06-14 11:10:09 UTC
> I know we're in string freeze, don't worry. It could be added later.
> Anyway, what does it mean "the spirit of plasma"? Even with the scrollbar
> the folderview will continue to act like a widget which is exactly a file
> browser, his own purpose.


If it was a filebrowser, i.e. compareable to dolphin or konqueror, the user 
could adjust the size of the icons and/or switch to e.g. a list-view to make 
best use of the space he wants to use for the folderview.

Actually it sounds interesting to be able to have a dolphin-part on the 
desktop, but that is another matter.

> The purpose of the folder view is to allow the user to browse a specific
> directory. We have two possibility: 1) show all it's contents without
> interesting if it is readable (small icons could equals less readability
> for a lot of users)


This is not true. If the icons get too small, they only do so because the user 
did resize the plasmoid to a size that demands the small icon size, so the 
user wants it that way. It is the same as if a user would add the analogue 
clock and is not able to read its numbers - he would just increase the size of 
it to be able to read it. Yet those that leave it small do it on purpose.

The only case where the user does not want small icons but cannot influence 
their size anymore is when the folderview is as big as the whole screen, i.e. 
its size cannot be increased. That case needs a scrollbar that kicks in, if 
not all icons fit into the view, even if resized to the smalles readable font. 
All other usecases fit the "adjust content to size" motto and provide the user 
with a choice, which he would not have otherwise.

If string-freeze is over one could also add a setting to "never resize icons" 
for those that prefer to scroll, even if they could increase the size of the 
plasmoid instead.

Not showing the content of a folder is not an option. Just providing a 
scrollbar would be the minimal solution.
Comment 13 FiNeX 2008-06-14 11:33:23 UTC
You're right. This "option" will allow users to do what they want :-)
Comment 14 Fredrik Höglund 2008-06-18 00:33:25 UTC
SVN commit 821595 by fredrik:

Show a vertical scrollbar when there are more icons than will fit in
the view, and add support for scrolling the view.

BUG: 162571


 M  +393 -78   folderview.cpp  
 M  +27 -6     folderview.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=821595
Comment 15 Pino Toscano 2008-06-28 18:01:33 UTC
*** Bug 165147 has been marked as a duplicate of this bug. ***