Bug 162546 - crash (assert failure) doing undo+redo
Summary: crash (assert failure) doing undo+redo
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: kwrite (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: VHI crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-24 02:55 UTC by Matthew Woehlke
Modified: 2009-05-14 12:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kate-undo-redo-fix.patch (8.45 KB, text/x-diff)
2008-07-13 14:49 UTC, Dominik Haumann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Woehlke 2008-05-24 02:55:51 UTC
Version:            (using Devel)
Installed from:    Compiled sources
Compiler:          gcc (GCC) 4.1.2 20070925 (Red Hat 4.1.2-33) 
OS:                Linux

I've seen this twice where kwrite crashes when hitting undo and then redo (where the redo is the last possible redo). This one is especially nasty as I tend to do this just before saving to remind myself what changes I made.

Hopefully the backtrace is helpful, as I cannot provide the file this was happening with, nor does it happen every time.

Application: KWrite (kwrite), signal SIGABRT
Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912558843872 (LWP 26453)]
[KCrash handler]
#5  0x0000003133830ec5 in raise () from /lib64/libc.so.6
#6  0x0000003133832970 in abort () from /lib64/libc.so.6
#7  0x00002aaaacfdc73c in qt_message_output (msgType=QtFatalMsg, 
    buf=0x7fffc75f1ae0 "ASSERT: \"d\" in file /usr/local/src/kde/svn/trunk/kdelibs/kdecore/util/ksharedptr.h, line 116")
    at /usr/local/src/kde/svn/trunk/qt-copy/src/corelib/global/qglobal.cpp:2058
#8  0x00002aaaacfdc84b in qFatal (
    msg=0x2aaaad1234a8 "ASSERT: \"%s\" in file %s, line %d")
    at /usr/local/src/kde/svn/trunk/qt-copy/src/corelib/global/qglobal.cpp:2260
#9  0x00002aaaacfdcc7d in qt_assert (assertion=0x2aaab3840b4f "d", 
    file=0x2aaab3840b10 "/usr/local/src/kde/svn/trunk/kdelibs/kdecore/util/ksharedptr.h", line=116)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/corelib/global/qglobal.cpp:1828
#10 0x00002aaab378c378 in QTextLine::cursorToX (this=0x7fffc75f3c30, 
    cursorPos=32767, edge=3344907600)
    at /usr/local/qt4-copy/include/QtGui/qtextlayout.h:216
#11 0x00002aaab3790e08 in KateLayoutCache::displayViewLine (
    this=0x2aaaaccea320, virtualCursor=@0x42d, limitToVisible=false)
    at /usr/local/src/kde/svn/trunk/kdelibs/kate/render/katelayoutcache.cpp:253
#12 0x00002aaab37911da in KateLayoutCache::textLayout (this=0xa39be0, 
    realCursor=@0xa37588)
    at /usr/local/src/kde/svn/trunk/kdelibs/kate/render/katelayoutcache.cpp:193
#13 0x00002aaab37d8cc0 in KateViewInternal::updateCursor (this=0xa37500, 
    newCursor=@0xa37588, force=true, center=false, calledExternally=false)
    at /usr/local/src/kde/svn/trunk/kdelibs/kate/view/kateviewinternal.cpp:1787
#14 0x00002aaab37d9ae6 in KateViewInternal::inputMethodEvent (
    this=0x2aaaaccea320, e=0x42d)
    at /usr/local/src/kde/svn/trunk/kdelibs/kate/view/kateviewinternal.cpp:3596
#15 0x00002aaab37c6445 in KateView::setSelection (this=0x6d, 
    selection=@0x6dc75f3df0)
    at /usr/local/src/kde/svn/trunk/kdelibs/kate/view/kateview.cpp:1464
#16 0x00002aaab375861d in KateDocument::editEnd (this=0x717190)
    at /usr/local/src/kde/svn/trunk/kdelibs/kate/document/katedocument.cpp:1097
#17 0x00002aaab3776b66 in KateUndo::undo (this=0xa35090, doc=0x7fffc75f3e70)
    at /usr/local/src/kde/svn/trunk/kdelibs/kate/document/kateundo.cpp:186
#18 0x00002aaab37581a2 in KateDocument::undo (this=0x717190)
    at /usr/local/src/kde/svn/trunk/kdelibs/kate/document/katedocument.cpp:1633
#19 0x00002aaab3761e3b in KateDocument::qt_metacall (this=0x717190, 
    _c=QMetaObject::InvokeMetaMethod, _id=35, _a=0x7fffc75f40d0)
    at /var/local/build/kde/svn/trunk/kdelibs/kate/katedocument.moc:289
#20 0x00002aaaad0e565b in QMetaObject::activate (sender=0xae23f0, 
    from_signal_index=5, to_signal_index=6, argv=0x7fffc75f40d0)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/corelib/kernel/qobject.cpp:3007
#21 0x00002aaaad0e586d in QMetaObject::activate (sender=0xae23f0, 
    m=0x2aaaae42b140, from_local_signal_index=1, to_local_signal_index=2, 
    argv=0x7fffc75f40d0)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/corelib/kernel/qobject.cpp:3100
#22 0x00002aaaada52e53 in QAction::triggered (this=0xae23f0, _t1=false)
    at .moc/debug-shared/moc_qaction.cpp:216
#23 0x00002aaaada54b2e in QAction::activate (this=0xae23f0, 
    event=QAction::Trigger)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/kernel/qaction.cpp:1119
#24 0x00002aaaada58586 in QAction::trigger (this=0xae23f0)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/kernel/qaction.h:201
#25 0x00002aaaade86d8e in QToolButton::nextCheckState (this=0xbb86c0)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/widgets/qtoolbutton.cpp:1099
#26 0x00002aaaaddb3289 in QAbstractButtonPrivate::click (this=0xb305b0)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/widgets/qabstractbutton.cpp:525
#27 0x00002aaaaddb3564 in QAbstractButton::mouseReleaseEvent (this=0xbb86c0, 
    e=0x7fffc75f4c40)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/widgets/qabstractbutton.cpp:1112
#28 0x00002aaaade87f60 in QToolButton::mouseReleaseEvent (this=0xbb86c0, 
    e=0x7fffc75f4c40)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/widgets/qtoolbutton.cpp:675
#29 0x00002aaaadab34fc in QWidget::event (this=0xbb86c0, event=0x7fffc75f4c40)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/kernel/qwidget.cpp:6927
#30 0x00002aaaaddb21d9 in QAbstractButton::event (this=0xbb86c0, 
    e=0x7fffc75f4c40)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/widgets/qabstractbutton.cpp:1074
#31 0x00002aaaade86d45 in QToolButton::event (this=0xbb86c0, e=0x7fffc75f4c40)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/widgets/qtoolbutton.cpp:1105
#32 0x00002aaaada5a469 in QApplicationPrivate::notify_helper (this=0x6164c0, 
    receiver=0xbb86c0, e=0x7fffc75f4c40)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/kernel/qapplication.cpp:3772
#33 0x00002aaaada5b05e in QApplication::notify (this=0x7fffc75f5b60, 
    receiver=0xbb86c0, e=0x7fffc75f4c40)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/kernel/qapplication.cpp:3501
#34 0x00002aaaabc74be6 in KApplication::notify (this=0x7fffc75f5b60, 
    receiver=0xbb86c0, event=0x7fffc75f4c40)
    at /usr/local/src/kde/svn/trunk/kdelibs/kdeui/kernel/kapplication.cpp:311
#35 0x00002aaaad0d193e in QCoreApplication::notifyInternal (
    this=0x7fffc75f5b60, receiver=0xbb86c0, event=0x7fffc75f4c40)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/corelib/kernel/qcoreapplication.cpp:583
#36 0x00002aaaada665dd in QCoreApplication::sendSpontaneousEvent (
    receiver=0xbb86c0, event=0x7fffc75f4c40)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/corelib/kernel/qcoreapplication.h:218
#37 0x00002aaaada60f77 in QApplicationPrivate::sendMouseEvent (
    receiver=0xbb86c0, event=0x7fffc75f4c40, alienWidget=0xbb86c0, 
    nativeWidget=0x6d6ca0, buttonDown=0x2aaaae467288, 
    lastMouseReceiver=@0x2aaaae467290)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/kernel/qapplication.cpp:2766
#38 0x00002aaaadacd751 in QETWidget::translateMouseEvent (this=0x6d6ca0, 
    event=0x7fffc75f56f0)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/kernel/qapplication_x11.cpp:4133
#39 0x00002aaaadacb157 in QApplication::x11ProcessEvent (this=0x7fffc75f5b60, 
    event=0x7fffc75f56f0)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/kernel/qapplication_x11.cpp:3133
#40 0x00002aaaadaf9837 in x11EventSourceDispatch (s=0x619a60, callback=0, 
    user_data=0x0)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:148
#41 0x0000003798a2ef53 in g_main_context_dispatch ()
   from /lib64/libglib-2.0.so.0
#42 0x0000003798a3224d in ?? () from /lib64/libglib-2.0.so.0
#43 0x0000003798a3277e in g_main_context_iteration ()
   from /lib64/libglib-2.0.so.0
#44 0x00002aaaad0fe8f0 in QEventDispatcherGlib::processEvents (this=0x612a80, 
    flags=@0x7fffc75f5970)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:325
#45 0x00002aaaadaf9087 in QGuiEventDispatcherGlib::processEvents (
    this=0x612a80, flags=@0x7fffc75f59d0)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#46 0x00002aaaad0ce8bc in QEventLoop::processEvents (this=0x7fffc75f5a80, 
    flags=@0x7fffc75f5a30)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/corelib/kernel/qeventloop.cpp:149
#47 0x00002aaaad0ceab8 in QEventLoop::exec (this=0x7fffc75f5a80, 
    flags=@0x7fffc75f5a90)
    at /usr/local/src/kde/svn/trunk/qt-copy/src/corelib/kernel/qeventloop.cpp:196
#48 0x00002aaaad0d21ca in QCoreApplication::exec ()
    at /usr/local/src/kde/svn/trunk/qt-copy/src/corelib/kernel/qcoreapplication.cpp:845
#49 0x00002aaaada5a1ca in QApplication::exec ()
    at /usr/local/src/kde/svn/trunk/qt-copy/src/gui/kernel/qapplication.cpp:3304
#50 0x00002aaaaaabcd21 in kdemain (argc=1, argv=0x7fffc75f6868)
    at /usr/local/src/kde/svn/trunk/kdebase/apps/kwrite/kwritemain.cpp:781
#51 0x0000000000400913 in main (argc=1, argv=0x7fffc75f6868)
    at /var/local/build/kde/svn/trunk/kdebase/apps/kwrite/kwrite_dummy.cpp:3
#0  0x000000313389ac30 in __nanosleep_nocancel () from /lib64/libc.so.6
Comment 1 Dominik Haumann 2008-06-29 15:41:30 UTC
Yes, this one is a very urgent bug.
The current solution still does not always set the cursor correctly. Would really be goot to have a fix for 4.1, at least for the crashes.
Comment 2 Hamish Rodda 2008-06-30 13:29:17 UTC
Agree, this is something that needs to be fixed asap, I hoped someone else was interested in debugging it...?
Comment 3 Matthew Woehlke 2008-07-11 02:14:09 UTC
I guess people might be looking in my direction, but to be honest, I can't think that I've been bit by this in a while. Not sure about the cursor, but maybe the crashing got fixed somewhere along the line?
Comment 4 Dominik Haumann 2008-07-11 21:36:03 UTC
no, it has nothing to do with your commits. It's about trying to make undo/redo always set the cursor position correct. But I don't see a solution right now. At least a fix to not make it crash should be committed, I'll try to look into this, hm...
Comment 5 Dominik Haumann 2008-07-13 14:49:09 UTC
Can you try the attached patch please?
Changes include
- the undo cursor and undo selection are saved with the first
  KateDocument::editStart()
- the redo cursor and redo selection are saved with the last
  KateDocument::editEnd()

For this to work, the following parts needed to be fixed
- wrap doDeleteWordLeft/Right with editStart() and editEnd(),
  otherwise wordLeft() and wordRight() change the cursor position
- drag & drop: while moving the cursor position is changed. To
  make it work, we need to fix the cursor position before we really
  do the drop operation. The undo selection is only set in the case
  of a move, otherwise it does not make sense (it feels really strange)

Please test the patch, as it should go into KDE 4.1 if it works. Right now, 
the KDE 4.1 branch crashes sometimes when doing undo/redo.

Thanks! -Dominik


Created an attachment (id=26084)
kate-undo-redo-fix.patch
Comment 6 Matthew Woehlke 2008-07-14 21:00:45 UTC
I could apply it, but I'm not able to reproduce the crash reliably (actually, haven't seen it for a while), so I can't really tell you if it works :-). Any pointers how to tickle the bug?
Comment 7 Dominik Haumann 2008-07-14 22:53:10 UTC
I used to reproduce it with inserting several lines, select all, join lines, type text, undo, undo, undo, redo, ... play around with it, ... and then at some point: crash :)

This patch is of course about fixing the crash. But it's even more about getting the cursor position right for undo, for redo. and also for selection. for copy&paste, etc... if it works good enough (i.e. no crash and sane positions, it should be committed).
Comment 8 Hamish Rodda 2008-07-15 01:45:27 UTC
For me it was paste text on one line so the cursor is at the end of the line, then undo the paste, cursor stays -> crash.
Comment 9 Matthew Woehlke 2008-07-15 02:01:35 UTC
Ok, I can reliably produce a crash (same assert, but different bt) as follows (based on Dominik's method):

- open my .bashrc (probably any file ~30-100 lines will do)
- paste a few lines somewhere
- select all, join
- type a few things randomly (this step may be unnecessary)
- undo to on-disk state, i.e. as much as possible
- redo x2 -> BANG!

I'll try to test the patch tomorrow.
Comment 10 Dominik Haumann 2008-07-16 08:02:42 UTC
(yes, the mail on kwrite-devel is about this bug http://permalink.gmane.org/gmane.comp.kde.devel.kwrite/16946)
Comment 11 Matthew Woehlke 2008-07-16 18:35:15 UTC
In that case I'll repost here for the record: with the patch, the procedure in comment #9 no longer results in a crash.
Comment 12 Dominik Haumann 2008-07-16 23:33:55 UTC
SVN commit 833482 by dhaumann:

Changes include
- the undo cursor and undo selection are saved with the first
  KateDocument::editStart()
- the redo cursor and redo selection are saved with the last
  KateDocument::editEnd()

For this to work, the following parts needed to be fixed
- wrap doDeleteWordLeft/Right with editStart() and editEnd(),
  otherwise wordLeft() and wordRight() change the cursor position
- drag & drop: while moving the cursor position is changed. To
  make it work, we need to fix the cursor position before we really
  do the drop operation. The undo selection is only set in the case
  of a move, otherwise it does not make sense (it feels really strange)

Please test the patch, as it should go into KDE 4.1 if it works. Right now, 
the KDE 4.1 branch crashes sometimes when doing undo/redo.

Port to KDE 4.1.0? Wait for KDE 4.1.1? dunno...

CCBUG: 162546


 M  +9 -5      document/katedocument.cpp  
 M  +34 -16    document/kateundo.cpp  
 M  +28 -6     document/kateundo.h  
 M  +27 -14    view/kateviewinternal.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=833482
Comment 13 Dario Andres 2008-12-20 17:12:35 UTC
Here using:

Qt: 4.4.3                 
KDE: 4.1.85 (KDE 4.1.85 (KDE 4.2 Beta2))
kdelibs svn rev. 899135 / kdebase svn rev. 899135
kdesdk svn rev.897359
on ArchLinux x86_64 - Kernel 2.6.27.8

I can't reproduce the crash even following the steps described in comment 9. Any news on this? Have anyone experienced this again ? 
Comment 14 UltimateSephiroth 2009-01-25 20:10:40 UTC
I think I just happened to come across this crash, though I used Kate and when I tried to redo, it wasn't the most recent one. Kate version: 3.1.3, bundled with KDE 4.1 installed from the Intrepid Ibex Kubuntu CD.

My backtrace (I think I can't reproduce it to get the required dbg packages):
Ohjelma: Kate (kate), signaali SIGABRT
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb5c82920 (LWP 9424)]
[KCrash handler]
#6  0xb7f09430 in __kernel_vsyscall ()
#7  0xb7d9a880 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb7d9c248 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb6ff3795 in qt_message_output () from /usr/lib/libQtCore.so.4
#10 0xb6ff3872 in qFatal () from /usr/lib/libQtCore.so.4
#11 0xb6ff3915 in qt_assert () from /usr/lib/libQtCore.so.4
#12 0xb430ddea in KateLayoutCache::viewLine (this=0xabbdca0, 
    realCursor=@0xabc16e4)
    at /build/buildd/kde4libs-4.1.3/kdecore/util/ksharedptr.h:116
#13 0xb430e34c in KateLayoutCache::textLayout (this=0xabbdca0, 
    realCursor=@0xabc16e4)
    at /build/buildd/kde4libs-4.1.3/kate/render/katelayoutcache.cpp:312
#14 0xb436b7c7 in KateViewInternal::updateCursor (this=0xabc1690, 
    newCursor=@0xabc16e4, force=true, center=false, calledExternally=false)
    at /build/buildd/kde4libs-4.1.3/kate/view/kateviewinternal.cpp:1808
#15 0xb4371fc3 in KateViewInternal::editEnd (this=0xabc1690, 
    editTagLineStart=8, editTagLineEnd=8, tagFrom=true)
    at /build/buildd/kde4libs-4.1.3/kate/view/kateviewinternal.cpp:3190
#16 0xb434edd9 in KateView::editEnd (this=0xabb7710, editTagLineStart=8, 
    editTagLineEnd=8, tagFrom=<value optimized out>)
    at /build/buildd/kde4libs-4.1.3/kate/view/kateview.cpp:1333
#17 0xb42d3e09 in KateDocument::editEnd (this=0xabc4620)
    at /build/buildd/kde4libs-4.1.3/kate/document/katedocument.cpp:1102
#18 0xb42ee37c in KateUndoGroup::redo (this=0xac7ae68)
    at /build/buildd/kde4libs-4.1.3/kate/document/kateundo.cpp:292
#19 0xb42d0eb0 in KateDocument::redo (this=0xabc4620)
    at /build/buildd/kde4libs-4.1.3/kate/document/katedocument.cpp:1659
#20 0xb42d1676 in KateDocument::qt_metacall (this=0xabc4620, 
    _c=QMetaObject::InvokeMetaMethod, _id=35, _a=0xbfb0740c)
    at /build/buildd/kde4libs-4.1.3/obj-i486-linux-gnu/kate/katedocument.moc:286
#21 0xb7100a60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#22 0xb7100e60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#23 0xb75205f1 in QAction::triggered () from /usr/lib/libQtGui.so.4
#24 0xb7520f5f in QAction::activate () from /usr/lib/libQtGui.so.4
#25 0xb75244bb in QAction::event () from /usr/lib/libQtGui.so.4
#26 0xb75839d9 in QWidgetAction::event () from /usr/lib/libQtGui.so.4
#27 0xb75268ec in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#28 0xb752e72e in QApplication::notify () from /usr/lib/libQtGui.so.4
#29 0xb66bdb2d in KApplication::notify (this=0xbfb0870c, receiver=0xabd78c8, 
    event=0xbfb07814)
    at /build/buildd/kde4libs-4.1.3/kdeui/kernel/kapplication.cpp:311
#30 0xb70ebe61 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#31 0xb755f8e8 in ?? () from /usr/lib/libQtGui.so.4
#32 0xb75612bf in ?? () from /usr/lib/libQtGui.so.4
#33 0xb752f9f0 in QApplication::notify () from /usr/lib/libQtGui.so.4
#34 0xb66bdb2d in KApplication::notify (this=0xbfb0870c, receiver=0xabc1690, 
    event=0xbfb07bac)
    at /build/buildd/kde4libs-4.1.3/kdeui/kernel/kapplication.cpp:311
#35 0xb70ebe61 in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#36 0xb75873de in ?? () from /usr/lib/libQtGui.so.4
#37 0xb75bdbb0 in ?? () from /usr/lib/libQtGui.so.4
#38 0xb75bfd26 in ?? () from /usr/lib/libQtGui.so.4
#39 0xb7596af5 in QApplication::x11ProcessEvent () from /usr/lib/libQtGui.so.4
#40 0xb75c17aa in ?? () from /usr/lib/libQtGui.so.4
#41 0xb63b66f8 in IA__g_main_context_dispatch (context=0x91edc98)
    at /build/buildd/glib2.0-2.18.2/glib/gmain.c:2144
#42 0xb63b9da3 in g_main_context_iterate (context=0x91edc98, block=1, 
    dispatch=1, self=0x91eb610)
    at /build/buildd/glib2.0-2.18.2/glib/gmain.c:2778
#43 0xb63b9f61 in IA__g_main_context_iteration (context=0x91edc98, 
    may_block=1) at /build/buildd/glib2.0-2.18.2/glib/gmain.c:2841
#44 0xb7116478 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#45 0xb75c0ea5 in ?? () from /usr/lib/libQtGui.so.4
#46 0xb70ea52a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#47 0xb70ea6ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#48 0xb70ecda5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#49 0xb7526767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#50 0xb7ed17cd in kdemain () from /usr/lib/libkdeinit4_kate.so
#51 0x080485a2 in _start ()
#0  0xb7f09430 in __kernel_vsyscall ()
Comment 15 Dominik Haumann 2009-01-26 10:41:11 UTC
I'm pretty sure I've fixed that for KDE 4.2. Please update as soon as possible to confirm this. Thanks.
Comment 16 Dominik Haumann 2009-05-14 12:06:16 UTC
Close as fixed as the main problem in comment #1 doesn't appear anymore. If there is still a similar crash, please open a new report.