Bug 162497 - krunner doesn't show all applications
Summary: krunner doesn't show all applications
Status: RESOLVED FIXED
Alias: None
Product: krunner
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-23 03:56 UTC by Elias Probst
Modified: 2009-06-30 04:35 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2008-05-23 03:56:05 UTC
Version:           (SVN rev. 811436) (using Devel)
Installed from:    Compiled sources

krunner doesn't show all applications while they're shown in kickoff as search result.
The only idea I had what could cause this are the desktop files, but I couldn't see any differences between the working and not-working ones.
I've picked 2 desktop files of each (working/not-working) from /usr/share/applications/:

Working:
#dvdisaster.desktop
[Desktop Entry]
Name=dvdisaster
GenericName=data archival
GenericName[de]=Daten-Archivierung
Comment=Additional error protection for CD/DVD media
Comment[cs]=Přídavná ochrana pro média CD/DVD
Comment[de]=Zusätzliche Fehlerkorrektur für CD/DVD
Exec=dvdisaster
Icon=dvdisaster.png
Terminal=false
Type=Application
Categories=Application;System;
Encoding=UTF-8

#opera-opera.desktop
[Desktop Entry]
Version=1.0
Name=Opera
Type=Application
Comment=Opera web browser
Exec=opera
TryExec=opera
Icon=/usr/share/pixmaps/opera.xpm
Categories=Network;WebBrowser;Email;FileTransfer;IRCClient;


Not working:
#nxclient-nxclient.desktop
[Desktop Entry]
Version=1.0
Name=NX Client
Type=Application
Comment=X11/VNC/NXServer client (remote desktops over low-bandwidth links)
Exec=nxclient
TryExec=nxclient
Icon=nxclient-icon
Categories=Network;;
 
#skype-skype.desktop
[Desktop Entry]
Version=1.0
Name=Skype VoIP
Type=Application
Comment=A P2P-VoiceIP client.
Exec=skype
TryExec=skype
Icon=skype
Categories=Network;InstantMessaging;Telephony;

As the desktop files are all in the same directory (/usr/share/applications) the reason can't be wrong set PATH or another variable.

What could cause this then? And how could it be fixed?
Comment 1 Aaron J. Seigo 2008-10-15 18:11:06 UTC
*** Bug 172849 has been marked as a duplicate of this bug. ***
Comment 2 Syam 2008-11-24 15:43:09 UTC
I get the same problem with KDE v4.1.2 (Fedora 9).
thunderbird, gthumb etc. work fine, but pidgin, gimp etc. don't.
Comment 3 Elias Probst 2008-11-29 23:40:58 UTC
Happens on 4.1.3 too.
Comment 4 Dominik Tritscher 2009-01-25 10:32:39 UTC
Works fine here, at least for gimp and skype using 4.2RC1. Don't have the other apps reported as not working installed.
Comment 5 Chri 2009-01-26 00:40:14 UTC
just installed netbeans and I have the same behaviour. Works fine in kickoff, however doesn't show up in krunner.
Comment 6 Elias Probst 2009-06-23 05:10:35 UTC
This problem doesn't occur here anymore since using 4.2.
I'm currently on 4.2.4 where everything is fine.

Is anyone else still suffering from this bug? So please reopen it - I'm closing it now.
Comment 7 Syam 2009-06-29 07:27:42 UTC
(In reply to comment #6)
> This problem doesn't occur here anymore since using 4.2.
> I'm currently on 4.2.4 where everything is fine.

I'm using KDE 4.2.3 on Fedora 11. The problem *still exists*. 'pidgi' or 'gim' doesn't bring up 'pidgin' or 'gimp' (both bring up nothing). If I type the full name, then 'Run pidgin' is suggested, but that's quite not the point.

I'll upgrade to KDE 4.2.4 tomorrow and see if it's fixed.
Comment 8 Syam 2009-06-29 07:31:04 UTC
(In reply to comment #6)
> This problem doesn't occur here anymore since using 4.2.
> I'm currently on 4.2.4 where everything is fine.

I'm using KDE 4.2.3 on Fedora 11. The problem *still exists*. 'pidgi' or 'gim' doesn't bring up 'pidgin' or 'gimp' (both bring up nothing). If I type the full name, then 'Run pidgin' is suggested, but that's quite not the point.

I'll upgrade to KDE 4.2.4 tomorrow and see if it's fixed.
Comment 9 Syam 2009-06-29 07:35:18 UTC
Just noticed that in Kickoff, "pid" brings up Pidgin as "Internet Messenger". And searching for "Int" in KRunner does list Pidgin (among other things) as "Internet Messenger". I now get a feeling that this can be fixed quite easily.
Comment 10 Aaron J. Seigo 2009-06-29 08:26:40 UTC
"I now get a feeling that this can be fixed quite easily."

yes, by fixing the .desktop files for those applications. :)
Comment 11 Syam 2009-06-29 09:50:02 UTC
(In reply to comment #10)
LOL.. Can you tell me what exactly is wrong with those .desktop files. Is it that the 'Name' attribute doesn't have 'pidgin' in it? But Kickoff doesn't seem to mind. If KRunner can do the same, it'd be nice.

Anyway, if this is something the distros need to fix, then I can probably report this in Fedora Bugzilla or notify the Fedora KDE SIG.
Comment 12 Aaron J. Seigo 2009-06-29 18:57:04 UTC
the applications search looks at the Name=, Keywords= and GenericName= entries in the .desktop file. what are those entries in the .desktop file?
Comment 13 Syam 2009-06-30 03:26:56 UTC
You are right. Neither Name= or GenericName= entries in pidgin/gimp desktop files have their names mentioned. They both have the generic name like 'Internet messenger'.
Comment 14 Rex Dieter 2009-06-30 04:35:39 UTC
pidgin not showing is a downstream fedora problem,
https://bugzilla.redhat.com/show_bug.cgi?id=293781
(I'll escalate this to get it fixed properly this time)