Bug 162285 - click on add network folder crashs dolphin
Summary: click on add network folder crashs dolphin
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 162635 163023 163137 163379 163800 164504 188387 193570 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-05-18 23:53 UTC by sts
Modified: 2009-12-16 17:16 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
crash report (5.27 KB, text/plain)
2008-05-18 23:54 UTC, sts
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sts 2008-05-18 23:53:48 UTC
Version:           1.0.99 (using 4.00.74 (KDE 4.0.73 >= 20080515 "release 1.5", compiled sources)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.25.3-2-default

If I click on "Add network folder" dolphin crashs
Comment 1 sts 2008-05-18 23:54:20 UTC
Created attachment 24838 [details]
crash report
Comment 2 FiNeX 2008-05-20 22:21:49 UTC
crash confirmed on revision 809608.


Application: Dolphin (dolphin), signal SIGSEGV
 [?1034hUsing host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0xb62376d0 (LWP 27995)]
[KCrash handler]
#6  0x09f792c7 in ?? ()
#7  0xbfc70073 in ?? ()
#8  0xb7d0fade in ~KCompositeJobPrivate (this=0xa0d6b28)
    at /home/test/KDE4/qt4/include/QtCore/qalgorithms.h:352
#9  0xb7732e33 in ~FileCopyJobPrivate (this=0xa0d6b28)
    at /home/test/KDE4/kdesvn/kdelibs/kio/kio/job_p.h:35
#10 0xb7d10a64 in ~KJob (this=0xa06e3e8)
    at /home/test/KDE4/kdesvn/kdelibs/kdecore/jobs/kjob.cpp:69
#11 0xb7d0f898 in ~KCompositeJob (this=0xa06e3e8)
    at /home/test/KDE4/kdesvn/kdelibs/kdecore/jobs/kcompositejob.cpp:44
#12 0xb7722508 in ~Job (this=0xa06e3e8)
    at /home/test/KDE4/kdesvn/kdelibs/kio/kio/job.cpp:97
#13 0xb772253d in ~FileCopyJob (this=0xa06e3e8)
    at /home/test/KDE4/kdesvn/kdelibs/kio/kio/job.cpp:1791
#14 0xb7fc6a0c in qDeleteInEventHandler (o=0x9f792c0)
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qobject.cpp:3595
#15 0xb7fc8403 in QObject::event (this=0xa06e3e8, e=0xa073588)
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qobject.cpp:1124
#16 0xb6b885dc in QApplicationPrivate::notify_helper (this=0x9df21f8, 
    receiver=0xa06e3e8, e=0xa073588)
    at /home/test/KDE4/kdesvn/qt-copy/src/gui/kernel/qapplication.cpp:3772
#17 0xb6b8f5ce in QApplication::notify (this=0xbfc77914, receiver=0xa06e3e8, 
    e=0xa073588)
    at /home/test/KDE4/kdesvn/qt-copy/src/gui/kernel/qapplication.cpp:3366
#18 0xb7aae2bd in KApplication::notify (this=0xbfc77914, receiver=0xa06e3e8, 
    event=0xa073588)
    at /home/test/KDE4/kdesvn/kdelibs/kdeui/kernel/kapplication.cpp:311
#19 0xb7fba0a1 in QCoreApplication::notifyInternal (this=0xbfc77914, 
    receiver=0xa06e3e8, event=0xa073588)
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:583
#20 0xb7fba9f3 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, 
    event_type=0, data=0x9dca288)
    at ../../include/QtCore/../../../../qt-copy/src/corelib/kernel/qcoreapplication.h:215
#21 0xb7fbab8d in QCoreApplication::sendPostedEvents (receiver=0x0, 
    event_type=0)
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:1091
#22 0xb7fe0a1f in postEventSourceDispatch (s=0x9df4120)
    at ../../include/QtCore/../../../../qt-copy/src/corelib/kernel/qcoreapplication.h:220
#23 0xb6527f88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#24 0xb652b4eb in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#25 0xb652b668 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#26 0xb7fe0678 in QEventDispatcherGlib::processEvents (this=0x9dd15e8, flags=
      {i = -1077446648})
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qeventdispatcher_glib.cpp:325
#27 0xb6c112a5 in QGuiEventDispatcherGlib::processEvents (this=0x9dd15e8, 
    flags={i = -1077446600})
    at /home/test/KDE4/kdesvn/qt-copy/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#28 0xb7fb882a in QEventLoop::processEvents (this=0xbfc778a0, flags=
      {i = -1077446536})
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qeventloop.cpp:149
#29 0xb7fb89ea in QEventLoop::exec (this=0xbfc778a0, flags={i = -1077446488})
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qeventloop.cpp:196
#30 0xb7fbac4d in QCoreApplication::exec ()
    at /home/test/KDE4/kdesvn/qt-copy/src/corelib/kernel/qcoreapplication.cpp:845
#31 0xb6b88457 in QApplication::exec ()
    at /home/test/KDE4/kdesvn/qt-copy/src/gui/kernel/qapplication.cpp:3304
#32 0x0808709f in main (argc=1, argv=0xbfc77ac4)
    at /home/test/KDE4/kdesvn/kdebase/apps/dolphin/src/main.cpp:94
#0  0xb805b424 in __kernel_vsyscall ()
Comment 3 Oliver Putz 2008-05-26 12:41:05 UTC
*** Bug 162635 has been marked as a duplicate of this bug. ***
Comment 4 Oliver Putz 2008-05-26 12:42:51 UTC
I think bug #162635 contains a slightly more verbose backtrace for this crash.
Comment 5 Johannes Frings 2008-05-28 08:55:56 UTC
Only sliding the mouse over "Add Network Folders" crashes dolphin for me.
dolphin 1.0.99
Comment 6 Peter Penz 2008-05-28 22:56:06 UTC
> Only sliding the mouse over "Add Network Folders"
> crashes dolphin for me.

Confirmed. I've reassigned this to kdelibs (crash in KCompositeJob), seems to be a quite tricky issue...
Comment 7 Jakub Stachowski 2008-05-29 21:54:46 UTC
SVN commit 814271 by qbast:

Remove subjob after killing it to prevent double deletion.
BUG: 162285



 M  +8 -2      job.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=814271
Comment 8 David Faure 2008-06-02 12:30:14 UTC
*** Bug 163023 has been marked as a duplicate of this bug. ***
Comment 9 Jakub Stachowski 2008-06-04 19:19:24 UTC
*** Bug 163137 has been marked as a duplicate of this bug. ***
Comment 10 Jakub Stachowski 2008-06-06 21:26:58 UTC
*** Bug 163379 has been marked as a duplicate of this bug. ***
Comment 11 Jakub Stachowski 2008-06-20 13:38:28 UTC
*** Bug 164504 has been marked as a duplicate of this bug. ***
Comment 12 Dario Andres 2008-12-04 16:40:23 UTC
Bug 163800 seems to be related/duplicate of this :)
Comment 13 Peter Penz 2008-12-04 17:51:14 UTC
*** Bug 163800 has been marked as a duplicate of this bug. ***
Comment 14 Jonathan Thomas 2009-04-17 22:10:19 UTC
This still seems to be an issue in KDE 4.2: https://launchpad.net/bugs/346232

#0  0x00000001 in ?? ()
#1  0xb7ca7603 in ~FileCopyJobPrivate (this=0x8c915ec)
    at /build/buildd/kde4libs-4.2.1a/kio/kio/job_p.h:35
No locals.
#2  0xb7569114 in ~KJob (this=0x94dc4d8)
    at /build/buildd/kde4libs-4.2.1a/kdecore/jobs/kjob.cpp:69
No locals.
#3  0xb7567f58 in ~KCompositeJob (this=0x94dc4d8)
    at /build/buildd/kde4libs-4.2.1a/kdecore/jobs/kcompositejob.cpp:44
No locals.
#4  0xb7c970f8 in ~Job (this=0x94dc4d8)
    at /build/buildd/kde4libs-4.2.1a/kio/kio/job.cpp:97
No locals.
#5  0xb7c9712d in ~FileCopyJob (this=0x94dc4d8)
    at /build/buildd/kde4libs-4.2.1a/kio/kio/job.cpp:1828
No locals.
#6  0xb733eb35 in qDeleteInEventHandler () from /usr/lib/libQtCore.so.4
#7  0xb73403db in QObject::event () from /usr/lib/libQtCore.so.4
#8  0xb6936f5c in QApplicationPrivate::notify_helper ()
   from /usr/lib/libQtGui.so.4
#9  0xb693f25e in QApplication::notify () from /usr/lib/libQtGui.so.4
#10 0xb78d170d in KApplication::notify (this=0xbfc21ac8, receiver=0x94dc4d8, 
    event=0x87fb9c0)
    at /build/buildd/kde4libs-4.2.1a/kdeui/kernel/kapplication.cpp:307
No locals.
#11 0xb732fa4b in QCoreApplication::notifyInternal ()
   from /usr/lib/libQtCore.so.4
#12 0xb73306a5 in QCoreApplicationPrivate::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#13 0xb733089d in QCoreApplication::sendPostedEvents ()
   from /usr/lib/libQtCore.so.4
#14 0xb735b7ff in ?? () from /usr/lib/libQtCore.so.4
#15 0xb6208a58 in IA__g_main_context_dispatch (context=0x87050f8)
    at /build/buildd/glib2.0-2.20.0/glib/gmain.c:1814
No locals.
#16 0xb620bfbb in g_main_context_iterate (context=0x87050f8, block=1, 
    dispatch=1, self=0x8703100)
    at /build/buildd/glib2.0-2.20.0/glib/gmain.c:2448
	max_priority = 0
	timeout = 0
	some_ready = 1
	nfds = 11
	allocated_nfds = <value optimized out>
	fds = (GPollFD *) 0x89e5588
	__PRETTY_FUNCTION__ = "g_main_context_iterate"
#17 0xb620c138 in IA__g_main_context_iteration (context=0x87050f8, 
    may_block=1) at /build/buildd/glib2.0-2.20.0/glib/gmain.c:2511
	retval = <value optimized out>
#18 0xb735b448 in QEventDispatcherGlib::processEvents ()
   from /usr/lib/libQtCore.so.4
#19 0xb69d8425 in ?? () from /usr/lib/libQtGui.so.4
#20 0xb732e07a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#21 0xb732e4ba in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#22 0xb7330969 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#23 0xb6936dd7 in QApplication::exec () from /usr/lib/libQtGui.so.4
#24 0xb7fd604f in kdemain (argc=2, argv=0xbfc21e44)
    at /build/buildd/kdebase-4.2.1/apps/konqueror/src/konqmain.cpp:257
	options = {d = 0x87021d8}
	app = {<KApplication> = {<> = {<No data fields>}, 
    static staticMetaObject = {d = {superdata = 0xb71c4108, 
        stringdata = 0xb7a4b0e0 "KApplication", data = 0xb7a4b280, 
        extradata = 0x0}}, static loadedByKdeinit = false, 
    static KApp = 0xbfc21ac8, d = 0x8769088}, static staticMetaObject = {d = {
      superdata = 0xb7a72ca0, stringdata = 0xb7fd85c0 "KonquerorApplication", 
      data = 0xb7fd86a0, extradata = 0x0}}, closed_by_sm = false}
	args = (KCmdLineArgs *) 0x8702858
	crashlog_file = {<> = {<No data fields>}, d = 0x87dadf0}
	__PRETTY_FUNCTION__ = "int kdemain(int, char**)"
#25 0x080486f2 in main (argc=)
    at /build/buildd/kdebase-4.2.1/obj-i486-linux-gnu/apps/konqueror/src/konqueror_dummy.cpp:3
No locals.
Comment 15 Dario Andres 2009-05-07 01:38:50 UTC
Here using:

Qt: 4.5.1 (qt-copy  960517)
KDE: 4.2.71 (KDE 4.2.71 (KDE 4.3 >= 20090428))
kdelibs svn rev. 963904 / kdebase svn rev. 963904
on ArchLinux i686 - Kernel 2.6.29.1

I can't reproduce the crash.
Can anyone using KDE4.3x confirm this? Thanks
Comment 16 FiNeX 2009-05-07 09:49:57 UTC
@Dario: I can't reproduce it too.
Comment 17 Dario Andres 2009-05-07 14:05:16 UTC
Marking as WORKSFORME. Please reopen if you experience again.
Thanks
Comment 18 Jonathan Thomas 2009-05-24 00:54:42 UTC
*** Bug 193570 has been marked as a duplicate of this bug. ***
Comment 19 Dario Andres 2009-06-21 00:35:41 UTC
Bug 197289 seems to be related to this.
Comment 20 Jonathan Thomas 2009-12-14 23:04:11 UTC
*** Bug 188387 has been marked as a duplicate of this bug. ***
Comment 21 David Faure 2009-12-16 17:16:23 UTC
SVN commit 1062999 by dfaure:

Fix crash in ~KCompositeJobPrivate after an error happens in a TransferJob.
Fixed for: 4.4
BUG: 214100
BUG: 202091
BUG: 197289
BUG: 180791
CCBUG: 218719
CCBUG: 162285


 M  +9 -2      job.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1062999