Bug 162090 - kopete crashes if yahoo account loged-in sgnes from another location
Summary: kopete crashes if yahoo account loged-in sgnes from another location
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Applications
Component: Yahoo Plugin (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 167102 168554 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-05-14 15:10 UTC by Cristi
Modified: 2008-09-10 17:10 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristi 2008-05-14 15:10:11 UTC
Version:           0.50.50 (using 4.00.73 (KDE 4.0.73 >= 20080507, Gentoo)
Compiler:          x86_64-pc-linux-gnu-gcc
OS:                Linux (x86_64) release 2.6.24-gentoo-r3

I was loged in with my yahoo account and when I started the VirtualBox windows and yahoo messanger logged me in kopete crashed.
Application: Kopete (kopete), signal SIGSEGV
[Thread debugging using libthread_db enabled]
[New Thread 0x2af80359ed90 (LWP 4346)]       
[KCrash handler]                             
#5  KNetworkConnector::errorCode (this=0x0)  
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete/kopete/protocols/yahoo/libkyahoo/yahooconnector.cpp:83                                                  
#6  0x00002af80936b108 in Client::streamError (this=0x6e9680, error=10)         
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete/kopete/protocols/yahoo/libkyahoo/client.cpp:226                                                         
#7  0x00002af80936b7f4 in Client::qt_metacall (this=0x6e9680,                   
    _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>,                
    _a=0x7fffb3bba4f0)                                                          
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete_build/kopete/protocols/yahoo/libkyahoo/client.moc:235                                                   
#8  0x00002af7f726c632 in QMetaObject::activate (sender=0xce8800,               
    from_signal_index=<value optimized out>, to_signal_index=7, argv=0x41)      
    at kernel/qobject.cpp:3001                                                  
#9  0x00002af8093743f1 in Stream::error (this=0x0, _t1=10)                      
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete_build/kopete/protocols/yahoo/libkyahoo/stream.moc:102                                                   
#10 0x00002af809372807 in ClientStream::cr_error (this=0xce8800)                
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete/kopete/protocols/yahoo/libkyahoo/yahooclientstream.cpp:345                                              
#11 0x00002af8093728ed in ClientStream::qt_metacall (this=0xce8800,             
    _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>,                
    _a=0x7fffb3bba620)                                                          
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete_build/kopete/protocols/yahoo/libkyahoo/yahooclientstream.moc:98                                         
#12 0x00002af7f726c632 in QMetaObject::activate (sender=0xcd8e10,               
    from_signal_index=<value optimized out>, to_signal_index=5, argv=0x41)      
    at kernel/qobject.cpp:3001                                                  
#13 0x00002af8093736de in KNetworkConnector::slotError (this=0xcd8e10,          
    code=17)                                                                    
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete/kopete/protocols/yahoo/libkyahoo/yahooconnector.cpp:80                                                  
#14 0x00002af8093737d8 in KNetworkConnector::qt_metacall (this=0xcd8e10,        
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0x7fffb3bba7f0)                 
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete_build/kopete/protocols/yahoo/libkyahoo/yahooconnector.moc:68                                            
#15 0x00002af7f726c632 in QMetaObject::activate (sender=0xce8620,               
    from_signal_index=<value optimized out>, to_signal_index=8, argv=0x41)      
    at kernel/qobject.cpp:3001                                                  
#16 0x00002af8093717a1 in ByteStream::error (this=0x0, _t1=17)                  
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete_build/kopete/protocols/yahoo/libkyahoo/bytestream.moc:111                                               
#17 0x00002af809370c5d in KNetworkByteStream::slotError (this=0xce8620,         
    code=17)                                                                    
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete/kopete/protocols/yahoo/libkyahoo/yahoobytestream.cpp:136                                                
#18 0x00002af8093711e1 in KNetworkByteStream::qt_metacall (this=0xce8620,       
    _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>,                
    _a=0x7fffb3bba990)                                                          
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete_build/kopete/protocols/yahoo/libkyahoo/yahoobytestream.moc:80                                           
#19 0x00002af7f726c632 in QMetaObject::activate (sender=0x9a4500,               
    from_signal_index=<value optimized out>, to_signal_index=9, argv=0x41)      
    at kernel/qobject.cpp:3001                                                  
#20 0x00002af7f7896ea1 in KNetwork::KClientSocketBase::gotError (this=0x0,      
    _t1=17)                                                                     
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs_build/kdecore/k3clientsocketbase.moc:111                                                              
#21 0x00002af7f78960f5 in KNetwork::KBufferedSocket::slotReadActivity (         
    this=0x9a4500)                                                              
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/kdecore/network/k3bufferedsocket.cpp:320                                                          
#22 0x00002af7f7895ce6 in KNetwork::KBufferedSocket::qt_metacall (              
    this=0x9a4500, _c=QMetaObject::InvokeMetaMethod, _id=0,                     
    _a=<value optimized out>)                                                   
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs_build/kdecore/k3bufferedsocket.moc:67                                                                 
#23 0x00002af7f726c632 in QMetaObject::activate (sender=0xcf7e10,               
    from_signal_index=<value optimized out>, to_signal_index=4, argv=0x41)      
    at kernel/qobject.cpp:3001                                                  
#24 0x00002af7f72a9f4e in QSocketNotifier::activated (this=0x0, _t1=30)         
    at .moc/debug-shared/moc_qsocketnotifier.cpp:81                             
#25 0x00002af7f72747af in QSocketNotifier::event (this=0xcf7e10,                
    e=0x7fffb3bbb080) at kernel/qsocketnotifier.cpp:326                         
#26 0x00002af7f8e075ff in QApplicationPrivate::notify_helper (this=0x698010,    
    receiver=0xcf7e10, e=0x7fffb3bbb080) at kernel/qapplication.cpp:3766        
#27 0x00002af7f8e0c1c5 in QApplication::notify (this=0x7fffb3bbc0a0,            
    receiver=0xcf7e10, e=0x7fffb3bbb080) at kernel/qapplication.cpp:3733        
#28 0x00002af7f844f92e in KApplication::notify (this=0x7fffb3bbc0a0,            
    receiver=0xcf7e10, event=0x7fffb3bbb080)                                    
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/kdeui/kernel/kapplication.cpp:311                                                                 
#29 0x00002af7f7256d38 in QCoreApplication::notifyInternal (                    
    this=0x7fffb3bbc0a0, receiver=0xcf7e10, event=0x7fffb3bbb080)               
    at kernel/qcoreapplication.cpp:587                                          
#30 0x00002af7f7285643 in QEventDispatcherUNIX::activateSocketNotifiers (       
    this=<value optimized out>)                                                 
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215     
#31 0x00002af7f7285bd3 in QEventDispatcherUNIXPrivate::doSelect (               
    this=0x6981d0, flags=@0x7fffb3bbb260, timeout=0x6981d0)                     
    at kernel/qeventdispatcher_unix.cpp:252                                     
#32 0x00002af7f7285d3e in QEventDispatcherUNIX::processEvents (this=0x696c10,   
    flags=@0x7fffb3bbb450) at kernel/qeventdispatcher_unix.cpp:895              
#33 0x00002af7f8e9540a in QEventDispatcherX11::processEvents (this=0x696c10,    
    flags=@0x7fffb3bbb4a0) at kernel/qeventdispatcher_x11.cpp:154               
#34 0x00002af7f7256135 in QEventLoop::processEvents (                           
    this=<value optimized out>, flags=@0x7fffb3bbb4e0)                          
    at kernel/qeventloop.cpp:149                                                
#35 0x00002af7f725628e in QEventLoop::exec (this=0x7fffb3bbb530,                
    flags=@0x7fffb3bbb550) at kernel/qeventloop.cpp:200                         
#36 0x00002af7f925731c in QDialog::exec (this=0xb36840)                         
    at dialogs/qdialog.cpp:453                                                  
#37 0x00002af7f83ddfdb in KDialogQueue::Private::slotShowQueuedDialog (         
    this=0x704950)                                                              
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/kdeui/dialogs/kdialog.cpp:1098                                                                    
#38 0x00002af7f83de055 in KDialogQueue::qt_metacall (this=0x704920,             
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=<value optimized out>)          
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs_build/kdeui/kdialogqueue_p.moc:65                                                                     
#39 0x00002af7f726c632 in QMetaObject::activate (sender=0xdea550,
    from_signal_index=<value optimized out>, to_signal_index=4, argv=0x41)
    at kernel/qobject.cpp:3001
#40 0x00002af7f7274c4f in QSingleShotTimer::timerEvent (this=0xdea550)
    at kernel/qtimer.cpp:300
#41 0x00002af7f7268285 in QObject::event (this=0xdea550, e=0x2af800794278)
    at kernel/qobject.cpp:1096
#42 0x00002af7f8e075ff in QApplicationPrivate::notify_helper (this=0x698010,
    receiver=0xdea550, e=0x7fffb3bbbcd0) at kernel/qapplication.cpp:3766
#43 0x00002af7f8e0c1c5 in QApplication::notify (this=0x7fffb3bbc0a0,
    receiver=0xdea550, e=0x7fffb3bbbcd0) at kernel/qapplication.cpp:3733
#44 0x00002af7f844f92e in KApplication::notify (this=0x7fffb3bbc0a0,
    receiver=0xdea550, event=0x7fffb3bbbcd0)
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/kdeui/kernel/kapplication.cpp:311
#45 0x00002af7f7256d38 in QCoreApplication::notifyInternal (
    this=0x7fffb3bbc0a0, receiver=0xdea550, event=0x7fffb3bbbcd0)
    at kernel/qcoreapplication.cpp:587
#46 0x00002af7f7285279 in QTimerInfoList::activateTimers (this=0x698a30)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#47 0x00002af7f7285d88 in QEventDispatcherUNIX::processEvents (this=0x696c10,
    flags=@0x7fffb3bbbf40) at kernel/qeventdispatcher_unix.cpp:899
#48 0x00002af7f8e9540a in QEventDispatcherX11::processEvents (this=0x696c10,
    flags=@0x7fffb3bbbf90) at kernel/qeventdispatcher_x11.cpp:154
#49 0x00002af7f7256135 in QEventLoop::processEvents (
    this=<value optimized out>, flags=@0x7fffb3bbbfd0)
    at kernel/qeventloop.cpp:149
#50 0x00002af7f725628e in QEventLoop::exec (this=0x7fffb3bbc010,
    flags=@0x7fffb3bbc020) at kernel/qeventloop.cpp:200
#51 0x00002af7f72582e9 in QCoreApplication::exec ()
    at kernel/qcoreapplication.cpp:845
#52 0x0000000000443fd1 in main (argc=3, argv=0x7fffb3bbce78)
    at /var/tmp/paludis/kde-base-kopete-scm/work/kopete/kopete/kopete/main.cpp:102
#0  0x00002af80071ac21 in nanosleep () from /lib64/libc.so.6
Comment 1 Matt Rogers 2008-07-07 05:25:57 UTC
I was unable to reproduce this with a newer snapshot of Kopete. Please reopen if you can reproduce with a KDE 4.1 Beta version. It's possible that it's x86_64 specific.
Comment 2 Cristi 2008-07-07 09:59:04 UTC
Everything is ok now: kopete reports a duplicate login.
Comment 3 Christophe Giboudeaux 2008-08-06 22:32:23 UTC
*** Bug 167102 has been marked as a duplicate of this bug. ***
Comment 4 Christophe Giboudeaux 2008-08-06 22:33:29 UTC
*** Bug 168554 has been marked as a duplicate of this bug. ***
Comment 5 Christophe Giboudeaux 2008-08-06 22:33:58 UTC
Reopen. It seems this crash is still present.