Bug 161845 - [testcase] Crash when unmounting partitions
Summary: [testcase] Crash when unmounting partitions
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-devicenotifier (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Alexis MENARD
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-09 13:54 UTC by Christophe Giboudeaux
Modified: 2008-06-14 02:49 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christophe Giboudeaux 2008-05-09 13:54:04 UTC
Version:            (using 4.00.73 (KDE 4.0.73 >= 20080507, compiled sources)
Compiler:          gcc 
OS:                Linux

KDEBASE rev: 805836

Testcase : 
- Unmount partitions using gparted (I guess the result would be the same w/ qtparted or even parted)
-> Plasma crashes.

I could reproduce this crash several times w/ different partitions.

Trace: 

Application: Espace de travail Plasma (<unknown>), signal SIGABRT
[Thread debugging using libthread_db enabled]
[New Thread 0xb4b59740 (LWP 8368)]
[New Thread 0xb0b08b90 (LWP 8435)]
[New Thread 0xb2e03b90 (LWP 8431)]
[KCrash handler]
#6  0xb8009424 in __kernel_vsyscall ()
#7  0xb5c54ef5 in raise () from /lib/i686/cmov/libc.so.6
#8  0xb5c56871 in abort () from /lib/i686/cmov/libc.so.6
#9  0xb6813855 in qt_message_output (msgType=QtFatalMsg, 
    buf=0xbf9217f0 "ASSERT: \"index.isValid()\" in file /media/kde/src/KDE/kdebase/workspace/plasma/applets/devicenotifier/devicenotifier.cpp, line 337")
    at global/qglobal.cpp:2058
#10 0xb68138b9 in qFatal (msg=0xb6968fb8 "ASSERT: \"%s\" in file %s, line %d")
    at global/qglobal.cpp:2260
#11 0xb6813cff in qt_assert (assertion=0xb128e237 "index.isValid()", 
    file=0xb128dd90 "/media/kde/src/KDE/kdebase/workspace/plasma/applets/devicenotifier/devicenotifier.cpp", line=337) at global/qglobal.cpp:1828
#12 0xb12871ee in DeviceNotifier::onSourceRemoved (this=0x813aaa8, 
    name=@0x81f4488)
    at /media/kde/src/KDE/kdebase/workspace/plasma/applets/devicenotifier/devicenotifier.cpp:337
#13 0xb1288330 in DeviceNotifier::qt_metacall (this=0x813aaa8, 
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf9239ac)
    at /media/kde/build/KDE/kdebase/workspace/plasma/applets/devicenotifier/devicenotifier.moc:83
#14 0xb69264df in QMetaObject::activate (sender=0x818c108, 
    from_signal_index=5, to_signal_index=5, argv=0xbf9239ac)
    at kernel/qobject.cpp:3007
#15 0xb6926961 in QMetaObject::activate (sender=0x818c108, m=0xb7fdfc70, 
    local_signal_index=1, argv=0xbf9239ac) at kernel/qobject.cpp:3080
#16 0xb7f46313 in Plasma::DataEngine::sourceRemoved (this=0x818c108, 
    _t1=@0x81f4488)
    at /media/kde/build/KDE/kdebase/workspace/libs/plasma/dataengine.moc:168
#17 0xb7f47a2f in Plasma::DataEngine::removeSource (this=0x818c108, 
    source=@0x81f4488)
    at /media/kde/src/KDE/kdebase/workspace/libs/plasma/dataengine.cpp:295
#18 0xb1e9c982 in HotplugEngine::onDeviceRemoved (this=0x818c108, 
    udi=@0x81f4488)
    at /media/kde/src/KDE/kdebase/workspace/plasma/dataengines/hotplug/hotplugengine.cpp:98
#19 0xb1e9d12a in HotplugEngine::qt_metacall (this=0x818c108, 
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf923b8c)
    at /media/kde/build/KDE/kdebase/workspace/plasma/dataengines/hotplug/hotplugengine.moc:70
#20 0xb69264df in QMetaObject::activate (sender=0x8192368, 
    from_signal_index=5, to_signal_index=5, argv=0xbf923b8c)
    at kernel/qobject.cpp:3007
#21 0xb6926961 in QMetaObject::activate (sender=0x8192368, m=0xb6a1c2e8, 
    local_signal_index=1, argv=0xbf923b8c) at kernel/qobject.cpp:3080
#22 0xb69dc083 in Solid::DeviceNotifier::deviceRemoved (this=0x8192368, 
    _t1=@0x81f4488)
    at /media/kde/build/KDE/kdelibs/solid/solid/devicenotifier.moc:86
#23 0xb69dc4c4 in Solid::DeviceManagerPrivate::_k_deviceRemoved (
    this=0x8192368, udi=@0x81f4488)
    at /media/kde/src/KDE/kdelibs/solid/solid/devicemanager.cpp:185
#24 0xb69dc6a5 in Solid::DeviceManagerPrivate::qt_metacall (this=0x8192368, 
    _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf923ccc)
    at /media/kde/build/KDE/kdelibs/solid/solid/devicemanager_p.moc:73
#25 0xb69264df in QMetaObject::activate (sender=0x81374e8, 
    from_signal_index=5, to_signal_index=5, argv=0xbf923ccc)
    at kernel/qobject.cpp:3007
#26 0xb6926961 in QMetaObject::activate (sender=0x81374e8, m=0xb6a1d298, 
    local_signal_index=1, argv=0xbf923ccc) at kernel/qobject.cpp:3080
#27 0xb69ee693 in Solid::Ifaces::DeviceManager::deviceRemoved (
    this=0x81374e8, _t1=@0x81f4488)
    at /media/kde/build/KDE/kdelibs/solid/solid/ifaces/devicemanager.moc:86
#28 0xb6a0907e in Solid::Backends::Hal::HalManager::slotDeviceRemoved (
    this=0x81374e8, udi=@0x81f4488)
    at /media/kde/src/KDE/kdelibs/solid/solid/backends/hal/halmanager.cpp:220
#29 0xb6a0915a in Solid::Backends::Hal::HalManager::qt_metacall (
    this=0x81374e8, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbf923d60)
    at /media/kde/build/KDE/kdelibs/solid/solid/backends/hal/halmanager.moc:71
#30 0xb6771642 in QDBusConnectionPrivate::deliverCall (this=0x819ae80, 
    object=0x81374e8, msg=@0x8343214, metaTypes=@0x8343218, slotIdx=7)
    at qdbusintegrator.cpp:865
#31 0xb677b9e8 in QDBusCallDeliveryEvent::placeMetaCall (this=0x83431e8, 
    object=0x81374e8) at qdbusintegrator_p.h:136
#32 0xb6924828 in QObject::event (this=0x81374e8, e=0x83431e8)
    at kernel/qobject.cpp:1137
#33 0xb60084d9 in QApplicationPrivate::notify_helper (this=0x8077e28, 
    receiver=0x81374e8, e=0x83431e8) at kernel/qapplication.cpp:3772
#34 0xb60087f2 in QApplication::notify (this=0x8071db0, receiver=0x81374e8, 
    e=0x83431e8) at kernel/qapplication.cpp:3366
#35 0xb6fb5093 in KApplication::notify (this=0x8071db0, receiver=0x81374e8, 
    event=0x83431e8)
    at /media/kde/src/KDE/kdelibs/kdeui/kernel/kapplication.cpp:311
#36 0xb6911826 in QCoreApplication::notifyInternal (this=0x8071db0, 
    receiver=0x81374e8, event=0x83431e8) at kernel/qcoreapplication.cpp:583
#37 0xb789c723 in QCoreApplication::sendEvent (receiver=0x81374e8, 
    event=0x83431e8)
    at ../../../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#38 0xb6911d3e in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, 
    event_type=0, data=0x804b760) at kernel/qcoreapplication.cpp:1195
#39 0xb6911eef in QCoreApplication::sendPostedEvents (receiver=0x0, 
    event_type=0) at kernel/qcoreapplication.cpp:1091
#40 0xb69425da in QCoreApplication::sendPostedEvents ()
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#41 0xb69417eb in postEventSourceDispatch (s=0x8079ea8)
    at kernel/qeventdispatcher_glib.cpp:211
#42 0xb5ada978 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#43 0xb5addbce in ?? () from /usr/lib/libglib-2.0.so.0
#44 0x08079e20 in ?? ()
#45 0x00000000 in ?? ()
#0  0xb8009424 in __kernel_vsyscall ()
Comment 1 FiNeX 2008-05-12 10:46:33 UTC
Did you try to umount with the "umount" command from the shell?
Comment 2 Christophe Giboudeaux 2008-05-21 17:46:05 UTC
I can't reproduce it anymore with a fresh svn rev. Closing with WORKSFORME.
Comment 3 Christophe Giboudeaux 2008-05-22 10:54:55 UTC
kdebase rev. 811072

I closed this too early, I can finally reproduce it when unplugging my GSM from USB. (same backtrace)

Reopen. 
Comment 4 Sebastian Sauer 2008-06-03 20:08:08 UTC
Probably related to bug #162634
Comment 5 Aaron J. Seigo 2008-06-14 02:49:40 UTC
SVN commit 820380 by aseigo:

since Solid may throw stuff at us that we aren't prep'd for, let's just handle it gracefully rather than take down all of plasma, m'kay?
BUG:161845


 M  +40 -35    devicenotifier.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=820380