Bug 161425 - Crashing in Summary View when clicking on events.
Summary: Crashing in Summary View when clicking on events.
Status: RESOLVED DUPLICATE of bug 156019
Alias: None
Product: kontact
Classification: Applications
Component: summary (show other bugs)
Version: 1.2.9
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-30 00:42 UTC by Dotan Cohen
Modified: 2008-06-26 19:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2008-04-30 00:42:46 UTC
Version:           1.2.9 (using KDE 3.5.9)
Installed from:    Ubuntu Packages
OS:                Linux

Opening Kontact (opens in Summary View), then clicking on the link for a contact who has a birthday. Crashes with SIGSEGV 11 and this in the konsole:
hardy2@hardy2-laptop:~$ kontact -v
Qt: 3.3.8b
KDE: 3.5.9
Kontact: 1.2.9
hardy2@hardy2-laptop:~$ kontact
hardy2@hardy2-laptop:~$ KCrash: Application 'kontact' crashing...

hardy2@hardy2-laptop:~$
Comment 1 Thomas McGuire 2008-05-02 23:41:43 UTC
Please provide a backtrace, see http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports
Comment 2 Dotan Cohen 2008-05-05 11:55:32 UTC
This backtrace was when clicking on an event that was not a birthday. It seems that Kontact crashes on _any_ event, not just birthdays (I did not realize that at the time I filed the bug). I'm updating the bug summary to reflect that.

[Thread debugging using libthread_db enabled]
[New Thread 0xb5ec1920 (LWP 10804)]
[KCrash handler]
#6  0xb6710c25 in QApplication::internalNotify (this=0xbfe51b9c, 
    receiver=0x8a4adf0, e=0xbfe512e0) at kernel/qapplication.cpp:2638
#7  0xb6713564 in QApplication::notify (this=0xbfe51b9c, receiver=0x8a4adf0, 
    e=0xbfe512e0) at kernel/qapplication.cpp:2526
#8  0xb6ed1672 in KApplication::notify (this=0xbfe51b9c, receiver=0x8a4adf0, 
    event=0xbfe512e0)
    at /build/buildd/kdelibs-3.5.9/./kdecore/kapplication.cpp:550
#9  0xb66a128d in QApplication::sendEvent (receiver=0x8a4adf0, 
    event=0xbfe512e0) at ../include/qapplication.h:523
#10 0xb67b75e1 in QWidget::setFocus (this=0x8a4adf0)
    at kernel/qwidget.cpp:3336
#11 0xb6712cf8 in QApplication::notify (this=0xbfe51b9c, receiver=0x8a4adf0, 
    e=0xbfe515d0) at kernel/qapplication.cpp:2409
#12 0xb6ed1672 in KApplication::notify (this=0xbfe51b9c, receiver=0x8a4adf0, 
    event=0xbfe515d0)
    at /build/buildd/kdelibs-3.5.9/./kdecore/kapplication.cpp:550
#13 0xb66a1301 in QApplication::sendSpontaneousEvent (receiver=0x8a4adf0, 
    event=0xbfe515d0) at kernel/qapplication.h:526
#14 0xb669ff8d in QETWidget::translateMouseEvent (this=0x8a4adf0, 
    event=0xbfe51a18) at kernel/qapplication_x11.cpp:4306
#15 0xb669e12f in QApplication::x11ProcessEvent (this=0xbfe51b9c, 
    event=0xbfe51a18) at kernel/qapplication_x11.cpp:3483
#16 0xb66b5943 in QEventLoop::processEvents (this=0x80b55f0, flags=4)
    at kernel/qeventloop_x11.cpp:195
#17 0xb672bf90 in QEventLoop::enterLoop (this=0x80b55f0)
    at kernel/qeventloop.cpp:201
#18 0xb672bc8e in QEventLoop::exec (this=0x80b55f0)
    at kernel/qeventloop.cpp:148
#19 0xb67127df in QApplication::exec (this=0xbfe51b9c)
    at kernel/qapplication.cpp:2761
#20 0x0805c113 in main (argc=2, argv=0x10000)
    at /build/buildd/kdepim-3.5.9/./kontact/src/main.cpp:163
Comment 3 Karl Ferdinand Ebert 2008-05-26 09:58:21 UTC
same here on Debian Lenny;
this is my backtrace, seems a little bit different:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0x2ac5e7e41870 (LWP 6973)]
[New Thread 0x42003950 (LWP 6977)]
[New Thread 0x41802950 (LWP 6976)]
[New Thread 0x41001950 (LWP 6975)]
[New Thread 0x40800950 (LWP 6974)]
[KCrash handler]
#5  0x0000000000000004 in ?? ()
#6  0x00002ac5e13b5953 in QApplication::internalNotify (
    this=<value optimized out>, receiver=0x14a8550, e=0x7fffcc15bd80)
    at kernel/qapplication.cpp:2638
#7  0x00002ac5e13b662e in QApplication::notify (this=0x7fffcc15c710, 
    receiver=0x14a8550, e=0x7fffcc15bd80) at kernel/qapplication.cpp:2526
#8  0x00002ac5e0b97ead in KApplication::notify (this=0x7fffcc15c710, 
    receiver=0x14a8550, event=0x7fffcc15bd80)
    at /tmp/buildd/kdelibs-3.5.9.dfsg.1/./kdecore/kapplication.cpp:550
#9  0x00002ac5e143c737 in QWidget::setFocus (this=<value optimized out>)
    at kernel/qapplication.h:523
#10 0x00002ac5e13b676e in QApplication::notify (this=0x7fffcc15c710, 
    receiver=0x14a8550, e=0x7fffcc15c260) at kernel/qapplication.cpp:2409
#11 0x00002ac5e0b97ead in KApplication::notify (this=0x7fffcc15c710, 
    receiver=0x14a8550, event=0x7fffcc15c260)
    at /tmp/buildd/kdelibs-3.5.9.dfsg.1/./kdecore/kapplication.cpp:550
#12 0x00002ac5e135da83 in QETWidget::translateMouseEvent (
    this=<value optimized out>, event=<value optimized out>)
    at kernel/qapplication.h:526
#13 0x00002ac5e135cb63 in QApplication::x11ProcessEvent (this=0x7fffcc15c710, 
    event=0x7fffcc15c530) at kernel/qapplication_x11.cpp:3611
#14 0x00002ac5e136ba59 in QEventLoop::processEvents (this=0x692b90, flags=4)
    at kernel/qeventloop_x11.cpp:195
#15 0x00002ac5e13ca001 in QEventLoop::enterLoop (this=0x14a8550)
    at kernel/qeventloop.cpp:201
#16 0x00002ac5e13c9eb2 in QEventLoop::exec (this=0x14a8550)
    at kernel/qeventloop.cpp:148
#17 0x0000000000418fba in main (argc=<value optimized out>, 
    argv=<value optimized out>)
    at /build/buildd/kdepim-3.5.9/./kontact/src/main.cpp:163
#18 0x00002ac5e067e1c4 in __libc_start_main () from /lib/libc.so.6
#19 0x00000000004187a9 in _start ()
Comment 4 Christophe Giboudeaux 2008-06-26 19:57:11 UTC

*** This bug has been marked as a duplicate of 156019 ***