Bug 161289 - [testcase] konqueror crashes on exit
Summary: [testcase] konqueror crashes on exit
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml (show other bugs)
Version: 4.0.3
Platform: Ubuntu Packages Linux
: NOR crash with 21 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 161296 164195 164497 164528 164932 165349 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-26 07:49 UTC by Jonas Vejlin
Modified: 2008-08-11 23:54 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Vejlin 2008-04-26 07:49:58 UTC
Version:           4.0.3 64 bit (using KDE 4.0.3)
Installed from:    Ubuntu Packages
OS:                Linux

I was closing Konq (using the X in the right corner) from my GMail accout when I got this:
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7fcf3a5ca7a0 (LWP 6291)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0x00007fcf39dbc095 in raise () from /lib/libc.so.6
#6  0x00007fcf39dbdaf0 in abort () from /lib/libc.so.6
#7  0x00007fcf39db52df in __assert_fail () from /lib/libc.so.6
#8  0x00007fcf273def59 in KHTMLGlobal::finalCheck ()
   from /usr/lib/kde4/lib/libkhtml.so.5
#9  0x00007fcf2795c4aa in ?? () from /usr/lib/kde4/lib/kde4/libkhtmlpart.so
#10 0x00007fcf392f8d91 in ?? () from /usr/lib/kde4/lib/libkdecore.so.5
#11 0x00007fcf392f9109 in ?? () from /usr/lib/kde4/lib/libkdecore.so.5
#12 0x00007fcf392f8052 in ?? () from /usr/lib/kde4/lib/libkdecore.so.5
#13 0x00007fcf39dbf110 in exit () from /lib/libc.so.6
#14 0x00007fcf39da81cb in __libc_start_main () from /lib/libc.so.6
#15 0x0000000000400649 in _start ()
#0  0x00007fcf39e27b81 in nanosleep () from /lib/libc.so.6
Comment 1 George Goldberg 2008-04-29 03:18:06 UTC
Reproducable on trunk r801873. 

Application: Konqueror (konqueror), signal SIGABRT
Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 47166416996240 (LWP 6425)]
[New Thread 1082132816 (LWP 6434)]
[KCrash handler]
#5  0x00002ae5c7822a55 in raise () from /lib64/libc.so.6
#6  0x00002ae5c78241e0 in abort () from /lib64/libc.so.6
#7  0x00002ae5c781bd6f in __assert_fail () from /lib64/libc.so.6
#8  0x00002ae5cfab056f in KHTMLGlobal::finalCheck ()
    at /home/george/kde/src/KDE/kdelibs/khtml/khtml_global.cpp:247
#9  0x00002ae5d20e4615 in ~KHTMLFactory (this=0x8ec280)
    at /home/george/kde/src/KDE/kdelibs/khtml/khtml_factory.cpp:35
#10 0x00002ae5c221a5da in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x8db020}, end={i = 0x8e30d0})
    at /opt/qt-copy/include/QtCore/qalgorithms.h:352
#11 0x00002ae5c221a623 in qDeleteAll<FactoryHash> (c=@0x8e9150)
    at /opt/qt-copy/include/QtCore/qalgorithms.h:360
#12 0x00002ae5c221a83b in ~FactoryHash (this=0x8e9150)
    at /home/george/kde/src/KDE/kdelibs/kdecore/util/klibrary.cpp:93
#13 0x00002ae5c221977e in destroy ()
    at /home/george/kde/src/KDE/kdelibs/kdecore/util/klibrary.cpp:97
#14 0x00002ae5c210df6d in ~KCleanUpGlobalStatic (this=0x2ae5c24b5248)
    at /home/george/kde/src/KDE/kdelibs/kdecore/kernel/kglobal.h:67
#15 0x00002ae5c221936c in __tcf_0 ()
    at /home/george/kde/src/KDE/kdelibs/kdecore/util/klibrary.cpp:97
#16 0x00002ae5c78257d0 in exit () from /lib64/libc.so.6
#17 0x00002ae5c781007b in __libc_start_main () from /lib64/libc.so.6
#18 0x00000000004007f9 in _start ()
#0  0x00002ae5c788c091 in nanosleep () from /lib64/libc.so.6
Comment 2 George Goldberg 2008-04-29 03:18:13 UTC
*** Bug 161296 has been marked as a duplicate of this bug. ***
Comment 3 Casey Link 2008-06-01 09:02:22 UTC
I do not experience this bug with trunk rev. 814918
Comment 4 FiNeX 2008-06-16 09:47:30 UTC
*** Bug 164195 has been marked as a duplicate of this bug. ***
Comment 5 Christophe Giboudeaux 2008-06-20 16:50:25 UTC
*** Bug 164528 has been marked as a duplicate of this bug. ***
Comment 6 Elias Probst 2008-06-27 01:20:12 UTC
The same here. It happens especially on a lot of the Google Pages like http://maps.google.com
Just open it and close Konqueror when it has finished loading.

I'm running latest trunk (SVN r824808) on Gentoo.

The backtrace looks like this:

Application: Konqueror (konqueror), signal SIGABRT
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 0xb601b6d0 (LWP 6039)]
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb6391101 in raise () from /lib/libc.so.6
#8  0xb63928e8 in abort () from /lib/libc.so.6
#9  0xb638a7a5 in __assert_fail () from /lib/libc.so.6
#10 0xb4120ccb in KHTMLGlobal::finalCheck ()
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/khtml/khtml_global.cpp:247
#11 0xb3fd4415 in ~KHTMLFactory (this=0x83efbe8)
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/khtml/khtml_factory.cpp:35
#12 0xb7b6adfa in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x83efc00}, end={i = 0x83eb600})
    at /usr/include/qt4/QtCore/qalgorithms.h:352
#13 0xb7b6ae6f in qDeleteAll<FactoryHash> (c=@0x83ef220)
    at /usr/include/qt4/QtCore/qalgorithms.h:360
#14 0xb7b6b1b6 in ~FactoryHash (this=0x83ef220)
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/kdecore/util/klibrary.cpp:93
#15 0xb7b69f02 in destroy ()
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/kdecore/util/klibrary.cpp:97
#16 0xb7a69001 in ~KCleanUpGlobalStatic (this=0xb7ba35f0)
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/kdecore/kernel/kglobal.h:67
#17 0xb7b69c31 in __tcf_0 ()
    at /var/tmp/paludis/kde-base-kdelibs-scm/work/kdelibs-scm/kdecore/util/klibrary.cpp:97
#18 0xb6393d0c in exit () from /lib/libc.so.6
#19 0xb637dfe4 in __libc_start_main () from /lib/libc.so.6
#20 0x08048741 in _start ()
#0  0xffffe410 in __kernel_vsyscall ()
Comment 7 Elias Probst 2008-06-27 01:32:18 UTC
*** Bug 164932 has been marked as a duplicate of this bug. ***
Comment 8 FiNeX 2008-06-27 16:53:33 UTC
*** Bug 164497 has been marked as a duplicate of this bug. ***
Comment 9 Maksim Orlovich 2008-06-29 18:58:46 UTC
*** Bug 165349 has been marked as a duplicate of this bug. ***
Comment 10 Frederik Himpe 2008-07-04 23:45:05 UTC
Visiting http://www.kelkoo.co.uk is enough to trigger a similar backtrace. No need to close the browser.
Comment 11 Jaime Torres 2008-07-13 12:05:50 UTC
Confirmed in svn trunk r828814. In my case it died by excessive memory usage visiting kelkoo.
Comment 12 Maksim Orlovich 2008-08-01 19:04:09 UTC
re: comment #10: unrelated. Please file a separate report. 
Comment 13 Maksim Orlovich 2008-08-07 01:20:18 UTC
SVN commit 843323 by orlovich:

Fix the deterministic leak on websites such as google maps (and some other ones)
which also causes an assertion failure on exit.

There is still a more subtle one where the conservative collection keeps an object alive for 
a while. Happens e.g. for #164126. That one needs more thought...

CCBUG:156172
CCBUG:161289
CCBUG:151453
BUG:167354



 M  +7 -0      khtml/ecma/kjs_window.cpp  
 M  +1 -4      kjs/interpreter.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=843323
Comment 14 Maksim Orlovich 2008-08-07 01:21:48 UTC
SVN commit 843325 by orlovich:

Merged revision 843323:
Fix the deterministic leak on websites such as google maps (and some other ones)
which also causes an assertion failure on exit.

There is still a more subtle one where the conservative collection keeps an object alive for 
a while. Happens e.g. for #164126. That one needs more thought...

CCBUG:156172
CCBUG:161289
CCBUG:151453
BUG:167354

 M  +7 -0      khtml/ecma/kjs_window.cpp  
 M  +1 -4      kjs/interpreter.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=843325
Comment 15 Maksim Orlovich 2008-08-11 23:54:21 UTC
Consolidating since can't always be sure of exact cause anyway...

*** This bug has been marked as a duplicate of 151453 ***