Bug 161263 - Kmail crashes and renders maildirs inaccessible (possibly NFS related)
Summary: Kmail crashes and renders maildirs inaccessible (possibly NFS related)
Status: RESOLVED NOT A BUG
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 161259 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-25 14:31 UTC by Alexander Borghgraef
Modified: 2009-04-05 13:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Borghgraef 2008-04-25 14:31:35 UTC
Version:            (using KDE 3.5.9)
Installed from:    Fedora RPMs
Compiler:          gcc version 4.1.2 20070925 (Red Hat 4.1.2-33) Using built-in specs.
Target: i386-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-1.5.0.0/jre --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --with-cpu=generic --host=i386-redhat-linux
Thread model: posix
OS:                Linux

Ever since upgrading from Fedora 6 to Fedora 8, kmail has been crashing a lot. It runs fine for some time, but after a while when opening a folder or subfolder, I get an error popup of the type:

  Error opening /home/myhome/Mail/sent-mail/cur; either this is not a valid maildir folder, or you do not have   
  sufficient access permissions.

Followed by this popup window: 

  KMail encountered a fatal error and will terminate now. The error was: Could not sync maildir folder.

And then KMail crashes. The sent-mail directory is an example, it happens with other directories too. The nasty thing is that the directory involved in the crash is rendered inaccessible. This is for instance what I get in konsole when running ls on an offending directory:

  myloginname@mycomputer:~$ ls -l Mail/Conferences/
  ls: cannot access Mail/Conferences/cur: No such file or directory
  total 8
  d????????? ? ?        ?          ?                ? cur
  drwx------ 2 myloginname slocate 4096 2005-08-16 15:36 new
  drwx------ 2 myloginname slocate 4096 2008-04-25 12:13 tmp

In some cases, I can cd into the directory and then it's back to normal again, in several recent cases the damage was permanent, and I needed to restore it from backup. One possible cause for this could be that my home directory is located on a remote NFS server, though I have no idea why this should be. I'm using kmail 1.9.9 in kontact 1.2.9, with kde 3.5.9-5.fc8 on Fedora 8, with kernel 2.6.24.4-64.fc8 . This is pretty bad for me, luckily I've backed up Mail/
Comment 1 Alexander Borghgraef 2008-04-25 14:58:05 UTC
Update: last time I had an inaccessible directory I couldn't cd into, the problem was resolved without taking any action after about 1h. Could be some sort of sync problem between the file server and my client pc, but the only program affected by it is kmail, so it's still a kmail bug as far as I'm concerned. 
Comment 2 Urs Wolfer 2008-04-25 22:27:10 UTC
*** Bug 161259 has been marked as a duplicate of this bug. ***
Comment 3 FiNeX 2009-04-04 11:30:23 UTC
This looks like a problem on the file system, not a kmail.

  d????????? ? ?        ?          ?                ? cur

it means that the file system is corrupted but probably it is related to an hardware problem.

Can you set up a new hard drive on the NFS server and be sure that your connection is good?
Comment 4 Alexander Borghgraef 2009-04-05 10:41:15 UTC
Yes, I've been looking around, and it was most likely an NFS synchronization problem (asked about it on the NFS mailing list). I'm not the sysadmin on this system, so I can't test it, but the problem has disappeared the past months, so I think this bug can safely be closed.
Comment 5 FiNeX 2009-04-05 13:22:19 UTC
Thanks for your feedback Alexander! :-)