Bug 161241 - worksheets multiply when system monitor opend
Summary: worksheets multiply when system monitor opend
Status: RESOLVED FIXED
Alias: None
Product: ksysguard
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
: 161399 164372 166229 168699 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-24 20:01 UTC by Leon Maurer
Modified: 2008-08-08 08:41 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leon Maurer 2008-04-24 20:01:25 UTC
Version:           4 (using 4.0.3 (KDE 4.0.3), Kubuntu packages)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.24-16-generic

I started out with three different worksheets. When I started the computer the next day, I had 6 -- each worksheet had duplicated. The next day, I had 9. You get the idea. I now have so many that I can't count them and it takes forever to open. Perhaps they have stopped multiplying -- this problem first showed up a month or two ago (presumably) with an older version of the program. Either way, they're still there. Moreover, I can't configure the toolbar to add the "remove worksheet" button! I can use the "configure toolbars" windows, but I can't change the icons that actually show up in the toolbar. Help!
Comment 1 John Tapsell 2008-04-24 22:56:31 UTC
SVN commit 800792 by johnflux:

* Disable session restoring code - it's just broken
* Don't load the same file twice.  This should fix ksysguard for whom it's currently broken.

BUG:161241


 M  +5 -0      Workspace.cc  
 M  +3 -2      ksysguard.cc  


WebSVN link: http://websvn.kde.org/?view=rev&revision=800792
Comment 2 Greg Martyn 2008-04-24 23:00:35 UTC
As a workaround, you can delete $KDEHOME/share/config/ksysguardrc

We know about this bug, and it will be fixed, but not for another
month or so. I'm just too busy to look into it right now. Sorry.
Comment 3 Greg Martyn 2008-04-29 06:41:40 UTC
*** Bug 161399 has been marked as a duplicate of this bug. ***
Comment 4 iCE 2008-06-11 16:37:11 UTC
Hy all, i have the same 'problem'! 

Thanks the help!
Comment 5 Greg Martyn 2008-08-08 08:38:22 UTC
*** Bug 164372 has been marked as a duplicate of this bug. ***
Comment 6 Greg Martyn 2008-08-08 08:39:23 UTC
*** Bug 166229 has been marked as a duplicate of this bug. ***
Comment 7 Greg Martyn 2008-08-08 08:41:55 UTC
*** Bug 168699 has been marked as a duplicate of this bug. ***