Bug 161239 - Clicking email folder in Kontact summary causes crash (sigsegv)
Summary: Clicking email folder in Kontact summary causes crash (sigsegv)
Status: RESOLVED DUPLICATE of bug 156019
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: SVN (3.5 branch)
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-24 19:55 UTC by Jouni Karlsson
Modified: 2008-05-02 23:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jouni Karlsson 2008-04-24 19:55:29 UTC
Version:           1.1 (using 3.5.9, Kubuntu (gutsy) 4:3.5.9-0ubuntu1~gutsy1~ppa1)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.22-14-generic

Right after opening Kontact and clicking on a email folder in summary view Kontact crashes. This happens somewhat randomly, but very often. Reproduced in several systems with similar backtrace.

kontact                            4:3.5.9-0ubuntu1~gutsy1~ppa3
kdepim-dbg                         4:3.5.9-0ubuntu1~gutsy1~ppa3
kdepim-kio-plugins                 4:3.5.9-0ubuntu1~gutsy1~ppa3

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1243350544 (LWP 13577)]
[New Thread -1287050352 (LWP 13581)]
[New Thread -1278657648 (LWP 13580)]
[New Thread -1270264944 (LWP 13579)]
[New Thread -1261872240 (LWP 13578)]
[KCrash handler]
#6  0xffffffff in ?? ()
#7  0xb6676af0 in QApplication::internalNotify (this=0xbfc9d6bc, 
    receiver=0x885d6b0, e=0xbfc9cd90) at kernel/qapplication.cpp:2635
#8  0xb66794ba in QApplication::notify (this=0xbfc9d6bc, receiver=0x885d6b0, 
    e=0xbfc9cd90) at kernel/qapplication.cpp:2523
#9  0xb6e23a32 in KApplication::notify (this=0xbfc9d6bc, receiver=0x885d6b0, 
    event=0xbfc9cd90)
    at /build/buildd/kdelibs-3.5.9/./kdecore/kapplication.cpp:550
#10 0xb6609209 in QApplication::sendEvent (receiver=0x885d6b0, 
    event=0xbfc9cd90) at ../include/qapplication.h:520
#11 0xb671ae4b in QWidget::setFocus (this=0x885d6b0)
    at kernel/qwidget.cpp:3333
#12 0xb6678bb8 in QApplication::notify (this=0xbfc9d6bc, receiver=0x885d6b0, 
    e=0xbfc9d0e0) at kernel/qapplication.cpp:2406
#13 0xb6e23a32 in KApplication::notify (this=0xbfc9d6bc, receiver=0x885d6b0, 
    event=0xbfc9d0e0)
    at /build/buildd/kdelibs-3.5.9/./kdecore/kapplication.cpp:550
#14 0xb660927d in QApplication::sendSpontaneousEvent (receiver=0x885d6b0, 
    event=0xbfc9d0e0) at kernel/qapplication.h:523
#15 0xb6607ee2 in QETWidget::translateMouseEvent (this=0x885d6b0, 
    event=0xbfc9d538) at kernel/qapplication_x11.cpp:4304
#16 0xb6605fcc in QApplication::x11ProcessEvent (this=0xbfc9d6bc, 
    event=0xbfc9d538) at kernel/qapplication_x11.cpp:3481
#17 0xb661d1a4 in QEventLoop::processEvents (this=0x80b22a8, flags=4)
    at kernel/qeventloop_x11.cpp:192
#18 0xb66911ce in QEventLoop::enterLoop (this=0x80b22a8)
    at kernel/qeventloop.cpp:198
#19 0xb6690fde in QEventLoop::exec (this=0x80b22a8)
    at kernel/qeventloop.cpp:145
#20 0xb6678699 in QApplication::exec (this=0xbfc9d6bc)
    at kernel/qapplication.cpp:2758
#21 0x0805c025 in main (argc=1, argv=0x80e6148)
    at /build/buildd/kdepim-3.5.9/./kontact/src/main.cpp:163
#22 0xb5e87050 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#23 0x0805b741 in _start ()
Comment 1 Jussi Kekkonen 2008-04-25 00:32:10 UTC
There's hints that this could be Kmail bug mostly, more in below...
I can reproduce this, with Kubuntu gutsy and current svn 3.5/enterprise branch with following traces:

kmail: slotCheckNamespace -
kmail: delimiterForNamespace #ftp
kmail: slotCheckNamespace -
kmail: delimiterForNamespace #news.
kmail: slotCheckNamespace -
kmail: delimiterForNamespace #public
kmail: slotCheckNamespace -
kmail: delimiterForNamespace #shared
kmail: capabilities:(imap4rev1,literal+,idle,namespace,mailbox-referrals,binary,unselect,scan,sort,thread=references,thread=orderedsubject,multiappend,sasl-ir,login-referrals,auth=plain,auth=login)
*** KMail got signal 11 (Crashing)
KCrash: Application 'kontact' crashing...

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1243851072 (LWP 12552)]
[New Thread -1290040432 (LWP 12579)]
[New Thread -1281647728 (LWP 12578)]
[New Thread -1273255024 (LWP 12577)]
[New Thread -1264862320 (LWP 12576)]
[KCrash handler]
#6  0xb65fdadf in QApplication::internalNotify (this=0xbfc12c94,
    receiver=0x89eadb8, e=0xbfc123a0) at kernel/qapplication.cpp:2635
#7  0xb66004ba in QApplication::notify (this=0xbfc12c94, receiver=0x89eadb8,
    e=0xbfc123a0) at kernel/qapplication.cpp:2523
#8  0xb6da9a32 in KApplication::notify (this=0xbfc12c94, receiver=0x89eadb8,
    event=0xbfc123a0)
    at /build/buildd/kdelibs-3.5.9/./kdecore/kapplication.cpp:550
#9  0xb6590209 in QApplication::sendEvent (receiver=0x89eadb8,
    event=0xbfc123a0) at ../include/qapplication.h:520
#10 0xb66a1e4b in QWidget::setFocus (this=0x89eadb8) at kernel/qwidget.cpp:3333
#11 0xb65ffbb8 in QApplication::notify (this=0xbfc12c94, receiver=0x89eadb8,
    e=0xbfc126f0) at kernel/qapplication.cpp:2406
#12 0xb6da9a32 in KApplication::notify (this=0xbfc12c94, receiver=0x89eadb8,
    event=0xbfc126f0)
    at /build/buildd/kdelibs-3.5.9/./kdecore/kapplication.cpp:550
#13 0xb659027d in QApplication::sendSpontaneousEvent (receiver=0x89eadb8,
    event=0xbfc126f0) at kernel/qapplication.h:523
#14 0xb658eee2 in QETWidget::translateMouseEvent (this=0x89eadb8,
    event=0xbfc12b48) at kernel/qapplication_x11.cpp:4304
#15 0xb658cfcc in QApplication::x11ProcessEvent (this=0xbfc12c94,
    event=0xbfc12b48) at kernel/qapplication_x11.cpp:3481
#16 0xb65a41a4 in QEventLoop::processEvents (this=0x80c1900, flags=4)
    at kernel/qeventloop_x11.cpp:192
#17 0xb66181ce in QEventLoop::enterLoop (this=0x80c1900)
    at kernel/qeventloop.cpp:198
#18 0xb6617fde in QEventLoop::exec (this=0x80c1900)
    at kernel/qeventloop.cpp:145
#19 0xb65ff699 in QApplication::exec (this=0xbfc12c94)
    at kernel/qapplication.cpp:2758
#20 0x0805c0b7 in main (argc=1, argv=0xbfc12e24)
    at /home/media/kdesvn/branches/work/enterprise/kdepim/kontact/src/main.cpp:163

NOTE: this is with local mailfolders, not imap
Comment 2 Thomas McGuire 2008-05-02 23:47:57 UTC

*** This bug has been marked as a duplicate of 156019 ***