Bug 160873 - Feature request multicore support
Summary: Feature request multicore support
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ImageEditor-Core (show other bugs)
Version: 0.9.3
Platform: Debian testing Linux
: NOR wishlist with 50 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-15 19:24 UTC by Barcos
Modified: 2022-01-08 11:38 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Barcos 2008-04-15 19:24:54 UTC
Version:           0.9.3 (using KDE 3.5.9)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Is there the possibility to add multicore support in the image manipulation or enhance plugins. Most common cpus ourtimes have dual or more cores ? I saw if there are computing intensiv plugins, only one core is used.
Comment 1 Luka Renko 2009-10-11 20:28:39 UTC
There is also wish in Ubuntu about thumbnail generation with multiple core/CPU:
https://launchpad.net/bugs/417819
Comment 2 caulier.gilles 2010-01-14 15:41:51 UTC
To be clear here, we need to use OpenMP API everywhere when it's possible...

Gilles Caulier
Comment 3 Johannes Wienke 2010-01-14 18:03:34 UTC
I'm not convinced that OpenMP is the one and only solution for generating multi-threaded code. For pre-existing algorithms it is a nice way but for other stuff that needs more control over the number of threads, synchronization etc. it's not a good way.

For the thumbnail generation a thread pool wit a user defined size sounds like a more appropriate solution to my mind.
Comment 4 caulier.gilles 2011-11-22 14:53:29 UTC
Please tests and report. My patch is against git/master. Let's me hear if this solution is suitable for you. It's not configurable.

Gilles Caulier
Comment 5 caulier.gilles 2011-11-22 14:54:32 UTC
sorry for the noise. wrong report 

Gilles Caulier
Comment 6 caulier.gilles 2011-12-17 16:07:10 UTC

*** This bug has been marked as a duplicate of bug 289204 ***
Comment 7 caulier.gilles 2022-01-08 11:38:31 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=289204