Bug 160662 - application crashed when adding spam icons to toolbar; won't launch anymore
Summary: application crashed when adding spam icons to toolbar; won't launch anymore
Status: RESOLVED DUPLICATE of bug 102470
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-10 17:52 UTC by Monica Hayden
Modified: 2008-04-10 18:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Monica Hayden 2008-04-10 17:52:13 UTC
Version:           part of KDE package (using KDE 3.5.8)
Installed from:    Ubuntu Packages
OS:                Linux

Backtrace info below:

“The application Kontact (kontact) crashed and caused the signal 11 (SIGSEGV)”
Backtrace info:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1243408704 (LWP 10681)]
[New Thread -1285706864 (LWP 10687)]
[New Thread -1277314160 (LWP 10686)]
[New Thread -1268921456 (LWP 10685)]
[New Thread -1260528752 (LWP 10684)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x00000000 in ?? ()
#7  0xb7045780 in KXMLGUI::ActionList::unplug () from /usr/lib/libkdeui.so.4
#8  0xb70e76b5 in KXMLGUI::ContainerNode::unplugClient ()
   from /usr/lib/libkdeui.so.4
#9  0xb70e793c in KXMLGUI::ContainerNode::unplugActions ()
   from /usr/lib/libkdeui.so.4
#10 0xb70e799f in KXMLGUI::ContainerNode::destruct ()
   from /usr/lib/libkdeui.so.4
#11 0xb70e7b9a in KXMLGUI::ContainerNode::destructChildren ()
   from /usr/lib/libkdeui.so.4
#12 0xb70e798d in KXMLGUI::ContainerNode::destruct ()
   from /usr/lib/libkdeui.so.4
#13 0xb70f38d1 in KXMLGUIFactory::removeClient () from /usr/lib/libkdeui.so.4
#14 0xb75c557a in KParts::MainWindow::createGUI ()
   from /usr/lib/libkparts.so.2
#15 0x0806056b in ?? ()
#16 0x080c2840 in ?? ()
#17 0x082a31e0 in ?? ()
#18 0xb7f4d166 in ?? () from /lib/ld-linux.so.2
#19 0x08062815 in ?? ()
#20 0x080c2840 in ?? ()
#21 0x085b2668 in ?? ()
#22 0xbf8b00d8 in ?? ()
#23 0xb6b9a8d0 in ?? () from /usr/lib/libqt-mt.so.3
#24 0x08062690 in ?? ()
#25 0xbf8b02ac in ?? ()
#26 0xbf8b0118 in ?? ()
#27 0xb66d2893 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
Backtrace stopped: frame did not save the PC
Comment 1 Monica Hayden 2008-04-10 17:55:04 UTC
I was trying to add spam buttons to the toolbar, when it crashed, and now it will not launch. When I try to launch it, I get the "crash handler" dialog box with the information above.
Comment 2 Monica Hayden 2008-04-10 18:09:32 UTC
here is the rest of the truncated info from the above backtrace:
#27 0xb609a6a7 in operator new () from /usr/lib/libstdc++.so.6
#28 0x08061073 in ?? ()
#29 0x080c2848 in ?? ()
#30 0x082538c0 in ?? ()
#31 0x080c2848 in ?? ()
#32 0x0829b478 in ?? ()
#33 0x080770d8 in typeinfo for Kontact::Core ()
#34 0x0000000a in ?? ()
#35 0xb73f6e80 in KFileMetaInfo::KFileMetaInfo () from /usr/lib/libkio.so.4
#36 0x08061216 in ?? ()
#37 0x080c2848 in ?? ()
#38 0xbf969304 in ?? ()
#39 0x00000000 in ?? ()
Comment 3 Bram Schoenmakers 2008-04-10 18:38:40 UTC

*** This bug has been marked as a duplicate of 102470 ***