Bug 160628 - Constant resizing loop
Summary: Constant resizing loop
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: 0.6.3
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
: 162602 174793 174841 175499 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-09 22:14 UTC by Michael Owen
Modified: 2014-11-09 15:09 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Owen 2008-04-09 22:14:21 UTC
Version:           0.6.3 (using 4.0.3 (KDE 4.0.3), Gentoo)
Compiler:          x86_64-pc-linux-gnu-gcc
OS:                Linux (x86_64) release 2.6.24-gentoo-r3

If the window size is set to just the wrong size, okular will constantly adjust the size in an infinite loop, consuming lots of cpu at the time. 

What happens is it adjusts the pdf to fit the window size, which then makes it add scrollbars. The scrollbars then make the pdf smaller, so it fits in the window. Because the pdf now fits in the window, the scollbars go away, so the pdf is resized larger to fit in the now slightly larger window. This makes the scrollbars come back, and this repeats in an endless cycle. 

I took some screenshots showing this, links are below. 

http://img257.imageshack.us/img257/9392/snapshot1xj9.png
http://img518.imageshack.us/img518/7269/snapshot3xg4.png
Comment 1 Albert Astals Cid 2008-04-09 22:59:49 UTC
I can reproduce it using the noncontinous view, but not when using the continuous view, do you have the problem using the continuous view?
Comment 2 Michael Owen 2008-04-09 23:12:46 UTC
Yes, it works in continuous mode, but only with 1 page documents (which is basically the same as non-continuous). It seems to trigger with anything slightly wider than the window size when in "Fit Width" mode. 
Comment 3 Albert Astals Cid 2008-04-11 20:50:53 UTC
SVN commit 795883 by aacid:

Save us from infinite resizing loops, we can afford to lose 1 pixel precision to fix that

BUGS: 160628


 M  +10 -0     pageview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=795883
Comment 4 Pino Toscano 2008-11-12 01:07:26 UTC
It seems the fix was not enough, reopening.
Comment 5 Pino Toscano 2008-11-12 01:07:30 UTC
*** Bug 162602 has been marked as a duplicate of this bug. ***
Comment 6 Pino Toscano 2008-11-12 01:09:24 UTC
*** Bug 174841 has been marked as a duplicate of this bug. ***
Comment 7 Pino Toscano 2008-11-12 01:11:48 UTC
*** Bug 174793 has been marked as a duplicate of this bug. ***
Comment 8 Pino Toscano 2008-11-18 16:15:42 UTC
*** Bug 175499 has been marked as a duplicate of this bug. ***
Comment 9 Albert Astals Cid 2008-12-08 17:09:18 UTC
SVN commit 894427 by aacid:

Try to fix again the inifite scroolbar loop
It's still to be improved because it gives you a uncentered page, but better a bit ugly than unusable
This fix will be in KDE 4.1.4
BUGS: 160628


 M  +16 -8     pageview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=894427
Comment 10 Jeffery MacEachern 2010-03-24 03:23:17 UTC
I'm experiencing exactly this in Okular 0.10.1, from KDE SC 4.4.1 (Chakra Builds), although I've never noticed it before in previous versions.  Maybe a regression?  I'm not reopening this myself because I'm unsure of policy in this case, but the issue definitely still exists, under the same circumstances.
Comment 11 Albert Astals Cid 2010-03-24 20:48:00 UTC
Yeah it seems to be happening again, it would be bug 227153 so no need to reopen this again.
Comment 12 Herli Menezes 2014-11-09 12:38:37 UTC
The reported issues is present in KDE 4.14.2, if I try to open or browse a document, Okular freezes, and last long time to recover. I am using Linux, Fedora 20 distro, in a Dell Vostro notebook.
Comment 13 Albert Astals Cid 2014-11-09 15:09:35 UTC
Herli, your description has really nothing to do with the original bug.