Bug 160476 - Crashed when clicked message in IMAP folder
Summary: Crashed when clicked message in IMAP folder
Status: RESOLVED DUPLICATE of bug 150667
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-06 17:40 UTC by David Jarvie
Modified: 2008-08-05 13:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Jarvie 2008-04-06 17:40:16 UTC
Version:            (using KDE 3.5.9)
Installed from:    Debian testing/unstable Packages
OS:                Linux

I single clicked on an item in the message list, in an IMAP folder, at which point kmail promptly crashed. I had been deleting some mails in that folder just before, but there was a gap of a few seconds between my last deletion and selecting the message, suggesting that it probably wasn't due to doing things too fast.

(no debugging symbols found)
Using host libthread_db library "/lib/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
....
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb57f76c0 (LWP 28544)]
[New Thread 0xb3a24b90 (LWP 28551)]
[New Thread 0xb4225b90 (LWP 28550)]
[New Thread 0xb4a26b90 (LWP 28549)]
[New Thread 0xb5227b90 (LWP 28548)]
(no debugging symbols found)
....
(no debugging symbols found)
[KCrash handler]
#6  0x00000001 in ?? ()
#7  0xb7d7370e in KMail::ImapJob::slotGetNextMessage ()
   from /usr/lib/libkmailprivate.so
#8  0xb7d74479 in KMail::ImapJob::init () from /usr/lib/libkmailprivate.so
#9  0xb7d7591c in KMail::ImapJob::execute () from /usr/lib/libkmailprivate.so
#10 0xb7d67abd in KMail::FolderJob::start () from /usr/lib/libkmailprivate.so
#11 0xb7c789de in KMFolderImap::doCreateJob ()
   from /usr/lib/libkmailprivate.so
#12 0xb7beb2af in FolderStorage::createJob () from /usr/lib/libkmailprivate.so
#13 0xb7bccb96 in KMFolder::createJob () from /usr/lib/libkmailprivate.so
#14 0xb7d4ce37 in KMMainWidget::slotMsgSelected ()
   from /usr/lib/libkmailprivate.so
#15 0xb7d5d8dd in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#16 0xb7021f6d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb7b85b5e in KMHeaders::selected () from /usr/lib/libkmailprivate.so
#18 0xb7b8cf8b in KMHeaders::highlightMessage ()
   from /usr/lib/libkmailprivate.so
#19 0xb7b8d3cc in KMHeaders::highlightMessage ()
   from /usr/lib/libkmailprivate.so
#20 0xb7b96a7a in KMHeaders::qt_invoke () from /usr/lib/libkmailprivate.so
#21 0xb7021f6d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#22 0xb735f4d1 in QListView::currentChanged () from /usr/lib/libqt-mt.so.3
#23 0xb70ff88e in QListView::setCurrentItem () from /usr/lib/libqt-mt.so.3
#24 0xb71027d7 in QListView::contentsMousePressEventEx ()
   from /usr/lib/libqt-mt.so.3
#25 0xb71031b4 in QListView::contentsMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#26 0xb5ff99fd in KListView::contentsMousePressEvent ()
   from /usr/lib/libkdeui.so.4
#27 0xb7b8d4f5 in KMHeaders::contentsMousePressEvent ()
   from /usr/lib/libkmailprivate.so
#28 0xb7134341 in QScrollView::viewportMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#29 0xb7132072 in QScrollView::eventFilter () from /usr/lib/libqt-mt.so.3
#30 0xb7100666 in QListView::eventFilter () from /usr/lib/libqt-mt.so.3
#31 0xb7b87b59 in KMHeaders::eventFilter () from /usr/lib/libkmailprivate.so
#32 0xb702178c in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#33 0xb70217fb in QObject::event () from /usr/lib/libqt-mt.so.3
#34 0xb705a43c in QWidget::event () from /usr/lib/libqt-mt.so.3
#35 0xb6fc418a in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#36 0xb6fc50ba in QApplication::notify () from /usr/lib/libqt-mt.so.3
#37 0xb7674ec2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#38 0xb6f63a52 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#39 0xb6f62afd in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#40 0xb6f72fe6 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#41 0xb6fdab80 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#42 0xb6fdaa16 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#43 0xb6fc3cff in QApplication::exec () from /usr/lib/libqt-mt.so.3
#44 0x0804a2ed in ?? ()
#45 0xbfa3d270 in ?? ()
#46 0xbfa3d460 in ?? ()
#47 0x00000000 in ?? ()
Comment 1 Christophe Giboudeaux 2008-08-05 13:47:29 UTC

*** This bug has been marked as a duplicate of 150667 ***