Bug 160294 - Sending mail with IPv6 crashes the slave
Summary: Sending mail with IPv6 crashes the slave
Status: RESOLVED WORKSFORME
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: smtp (show other bugs)
Version: 3.5
Platform: OpenBSD OpenBSD
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2008-04-03 06:58 UTC by Brad Smith
Modified: 2018-10-27 03:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Smith 2008-04-03 06:58:45 UTC
Version:            (using KDE 3.5.9)
Installed from:    OpenBSD Packages
Compiler:          GCC 3.3.5 
OS:                OpenBSD

Configuring an SMTP transport to use a FQDN which has an AAAA DNS record results in KMail attempting to connect to the SMTP server and immediately disconnecting with a   dialog box popping up saying "Sending failed: The process for the smtp://[server name] protocol died unexpectedly" and the message is not sent. If I configure the SMTP transport with the IPv6 address KMail does not even attempt to connect to the server and fails immediately with an error message of "Sending failed: Could not connect to host [IPv6 address]".

The server side shows the following for the initial connection described above...

Apr  3 00:31:06 speedy postfix/smtpd[8090]: connect from booyah.home.comstyle.com[2001:470:8802:3:216:41ff:fe17:6933]
Apr  3 00:31:06 speedy postfix/smtpd[8090]: lost connection after CONNECT from booyah.home.comstyle.com[2001:470:8802:3:216:41ff:fe17:6933]
Apr  3 00:31:06 speedy postfix/smtpd[8090]: disconnect from booyah.home.comstyle.com[2001:470:8802:3:216:41ff:fe17:6933]

POP3 and IMAP work fine for retrieving e-mail from the server. Other MUAs with IPv6 support are able to send mail via this server and with IPv6 in general.
Comment 1 Christoph Feck 2013-09-12 21:40:51 UTC
This crash report is at least 3 years old and there were no further comments or status updates since then.

Therefore we believe that this crash is already fixed in recent KDE 4 versions or the backtrace is no longer applicable to the current KDE 4 sources.

If the crash still happens with a recent KDE version (4.10.5 or 4.11), please add an updated backtrace or provide steps to reproduce. For more information, see http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports

(To prevent automatic closing of this bug in the future, please set the bug status to ASSIGNED or CONFIRMED)
Comment 2 Andrew Crouthamel 2018-09-24 01:57:46 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Andrew Crouthamel 2018-10-27 03:56:26 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!