Bug 160254 - Crash during DIMAP sync, caused by Signal 8 SIGFPE in libkmailprivate
Summary: Crash during DIMAP sync, caused by Signal 8 SIGFPE in libkmailprivate
Status: RESOLVED DUPLICATE of bug 158689
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-02 10:58 UTC by Gunter Ohrner
Modified: 2008-04-02 15:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gunter Ohrner 2008-04-02 10:58:38 UTC
Version:            (using KDE 3.5.9)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Trying to sync my IMAP inbox with a dimap account currently causes the following crash caused by Signal 8 (SIGFPE).

My inbox's view is not threaded, so I do not think this problem is related to #94043 .
I also do not have any filters defined.

Rebuilding this folder's index from the folder menu did not change anything, while rebuilding the dimap cache using the same menu entry caused an SIGSEGV (I'll open a separate bug for that.) and left me with a local inbox containing only a single message.

Accessing the inbox using a normal imap account works fine.

#6  0x4ae0d0ad in KMFolderCachedImap::slotProgress ()
   from /usr/lib/libkmailprivate.so
#7  0x4ae1b993 in KMFolderCachedImap::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#8  0x48c474cd in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#9  0x4aee8136 in KMail::FolderJob::progress ()
   from /usr/lib/libkmailprivate.so
#10 0x4aeec94f in KMail::CachedImapJob::slotGetNextMessage ()
   from /usr/lib/libkmailprivate.so
#11 0x4aeedc7f in KMail::CachedImapJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#12 0x48c474cd in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0x498779ee in KIO::Job::result () from /usr/lib/libkio.so.4
#14 0x498bd99d in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#15 0x498bdb0e in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#16 0x498be1f8 in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#17 0x498bd5fd in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#18 0x48c474cd in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#19 0x48c4804d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#20 0x4986ffdc in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.4
#21 0x498bc969 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#22 0x498dedba in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#23 0x49885e7c in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#24 0x498b4238 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#25 0x48c474cd in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#26 0x48c47f50 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#27 0x48f723b0 in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#28 0x48c64f60 in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#29 0x48be96ea in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#30 0x48bea4d6 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#31 0x492f4062 in KApplication::notify () from /usr/lib/libkdecore.so.4
#32 0x48bddfa7 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#33 0x48b98730 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#34 0x48c000e0 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#35 0x48bfff76 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#36 0x48be925f in QApplication::exec () from /usr/lib/libqt-mt.so.3
#37 0x0804a2ed in ?? ()
#38 0xbff29e20 in ?? ()
#39 0xbff2a010 in ?? ()
#40 0x00000000 in ?? ()
Comment 1 Thomas McGuire 2008-04-02 15:09:30 UTC

*** This bug has been marked as a duplicate of 158689 ***