Bug 160242 - Kontact crashes when closing - network problem ?
Summary: Kontact crashes when closing - network problem ?
Status: RESOLVED WORKSFORME
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 143005 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-02 04:15 UTC by Raphaël Barrois
Modified: 2011-09-24 21:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raphaël Barrois 2008-04-02 04:15:29 UTC
Version:           Version 1.2.4 (enterprise 0.20070907.709405) (using KDE 3.5.8)
Installed from:    Ubuntu Packages
OS:                Linux

Kontact often crashes after having been up a "long" time (a few hours).

Sometimes it crashes without me doing anything, and often when I close it.

This may be linked to networking problems : it used to crash much more when I checked my newsgroups every minute (around 100 groups on a local leafnode server).

Sometimes, KCrash cannot get a backtrace, but today I got one, so I'm posting it here...

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1242900800 (LWP 24162)]
[KCrash handler]
#6  0xb5f470b4 in ?? () from /lib/tls/i686/cmov/libc.so.6
#7  0xb6026148 in ?? () from /lib/tls/i686/cmov/libc.so.6
#8  0xb6024ff4 in ?? () from /lib/tls/i686/cmov/libc.so.6
#9  0xb600b13c in ?? () from /lib/tls/i686/cmov/libc.so.6
#10 0xb5f486c1 in ?? () from /lib/tls/i686/cmov/libc.so.6
#11 0xb602615c in ?? () from /lib/tls/i686/cmov/libc.so.6
#12 0xb6007fd5 in ?? () from /lib/tls/i686/cmov/libc.so.6
#13 0xb600b13c in ?? () from /lib/tls/i686/cmov/libc.so.6
#14 0xb6026140 in ?? () from /lib/tls/i686/cmov/libc.so.6
#15 0x61700852 in ?? ()
#16 0xb602614c in ?? () from /lib/tls/i686/cmov/libc.so.6
#17 0xb602616c in ?? () from /lib/tls/i686/cmov/libc.so.6
#18 0xc2200000 in ?? ()
#19 0xb6026170 in ?? () from /lib/tls/i686/cmov/libc.so.6
#20 0x00180000 in ?? ()
#21 0xb600b13c in ?? () from /lib/tls/i686/cmov/libc.so.6
#22 0x080ba868 in ?? ()
#23 0xb6026148 in ?? () from /lib/tls/i686/cmov/libc.so.6
#24 0x00000070 in ?? ()
#25 0xb5f48b6e in ?? () from /lib/tls/i686/cmov/libc.so.6
#26 0xb602614c in ?? () from /lib/tls/i686/cmov/libc.so.6
#27 0x09265510 in ?? ()
#28 0xb600b13c in ?? () from /lib/tls/i686/cmov/libc.so.6
#29 0xb5f486c1 in ?? () from /lib/tls/i686/cmov/libc.so.6
#30 0xb6026150 in ?? () from /lib/tls/i686/cmov/libc.so.6
#31 0x0871d838 in ?? ()
#32 0xb600b13c in ?? () from /lib/tls/i686/cmov/libc.so.6
#33 0x081b78d8 in ?? ()
#34 0xb6026148 in ?? () from /lib/tls/i686/cmov/libc.so.6
#35 0x00000270 in ?? ()
#36 0xb600b1a0 in ?? () from /lib/tls/i686/cmov/libc.so.6
#37 0x0860b968 in ?? ()
#38 0xbfb30ad8 in ?? ()
#39 0xb6024ff4 in ?? () from /lib/tls/i686/cmov/libc.so.6
#40 0xb6026140 in ?? () from /lib/tls/i686/cmov/libc.so.6
#41 0x0860b958 in ?? ()
#42 0xbfb30ae8 in ?? ()
#43 0xb5f4c800 in free () from /lib/tls/i686/cmov/libc.so.6
#44 0xb5f4c800 in free () from /lib/tls/i686/cmov/libc.so.6
#45 0xb6111d81 in operator delete () from /usr/lib/libstdc++.so.6
#46 0xb6111ddd in operator delete[] () from /usr/lib/libstdc++.so.6
#47 0xb6a474eb in ~QGDict (this=0x819e96c) at tools/qgdict.cpp:269
#48 0xb6dd9118 in ~KCharsets (this=0x819baf8)
    at /usr/share/qt3/include/qasciidict.h:57
#49 0xb6e353b0 in kglobal_freeAll ()
    at /build/buildd/kdelibs-3.5.8/./kdecore/kglobal.cpp:224
#50 0xb6da4d40 in __do_global_dtors_aux () from /usr/lib/libkdecore.so.4
#51 0xb6f0db5c in _fini () from /usr/lib/libkdecore.so.4
#52 0xb7fd1a1f in ?? () from /lib/ld-linux.so.2
#53 0xb7fdf260 in _rtld_global () from /lib/ld-linux.so.2
#54 0x00000000 in ?? ()
Comment 1 Raphaël Barrois 2008-04-03 13:12:01 UTC
Another one today :
I wasn't doing anything special. I did just quit with Ctrl+q, and it crashed...

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1242810688 (LWP 11148)]
[KCrash handler]
#6  0xb6a81c25 in replaceArgEscapes (s=@0xbfb19a64, d=@0xbfb19a20, 
    field_width=0, arg=@0x8981544, larg=@0x8981544) at tools/qstring.cpp:1941
#7  0xb6a81d91 in QString::arg (this=0xbfb19a64, a=@0x8981544, fieldWidth=0)
    at tools/qstring.cpp:2001
#8  0xb6e3ea61 in KCatalogue (this=0xbfb19ab4, name=@0x80babd8, 
    language=@0x80c7f38)
    at /build/buildd/kdelibs-3.5.8/./kdecore/kcatalogue.cpp:67
#9  0xb6e49ab4 in KLocale::updateCatalogues (this=0x80c9a60)
    at /build/buildd/kdelibs-3.5.8/./kdecore/klocale.cpp:676
#10 0xb6e4b480 in KLocale::removeCatalogue (this=0x80c9a60, 
    catalog=@0xbfb19b28)
    at /build/buildd/kdelibs-3.5.8/./kdecore/klocale.cpp:691
#11 0xb543470a in ~KGenericFactory (this=0x82dbc48)
    at /usr/include/kde/kgenericfactory.h:52
#12 0xb6e1cf21 in ~KLibrary (this=0x82da3a0)
    at /build/buildd/kdelibs-3.5.8/./kdecore/klibloader.cpp:131
#13 0xb6e1c64f in KLibLoader::close_pending (this=0x822cef0, wrap=0x0)
    at /build/buildd/kdelibs-3.5.8/./kdecore/klibloader.cpp:516
#14 0xb6e1cab5 in ~KLibLoader (this=0x822cef0)
    at /build/buildd/kdelibs-3.5.8/./kdecore/klibloader.cpp:328
#15 0xb6dbec3b in KLibLoader::cleanUp ()
    at /build/buildd/kdelibs-3.5.8/./kdecore/klibloader.cpp:298
#16 0xb6e4a777 in ~KApplication (this=0xbfb19d1c)
    at /build/buildd/kdelibs-3.5.8/./kdecore/kapplication.cpp:1609
#17 0xb6e4ab6f in ~KUniqueApplication (this=0xbfb19d1c)
    at /build/buildd/kdelibs-3.5.8/./kdecore/kuniqueapplication.cpp:351
#18 0x0805c09a in main (argc=1, argv=)
    at /build/buildd/kdepim-3.5.7enterprise20070926/./kontact/src/main.cpp:54
#19 0xb5f0b050 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#20 0x0805b701 in _start ()
Comment 2 Christophe Giboudeaux 2008-07-24 12:43:40 UTC
*** Bug 143005 has been marked as a duplicate of this bug. ***
Comment 3 Christophe Giboudeaux 2011-09-24 21:09:48 UTC
I cannot reproduce this crash with the given steps and recent KDE and kdepim versions. Closing this report