Bug 160212 - Kontact crashes when starting up
Summary: Kontact crashes when starting up
Status: RESOLVED DUPLICATE of bug 159247
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-01 14:38 UTC by Manuel Gaus
Modified: 2008-07-09 20:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Gaus 2008-04-01 14:38:16 UTC
Version:            (using KDE 3.5.8)
Installed from:    Ubuntu Packages

After having created an extensive list auf tasks with repetitions and so on... kontact refuses to launch and exits with a sigsev. On my last kontact session i have seen korgac failing with a sigsev as well. 

Here is a Backtrace of the crash:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1243158848 (LWP 7278)]
[New Thread -1287414896 (LWP 7282)]
[New Thread -1279022192 (LWP 7281)]
[New Thread -1270629488 (LWP 7280)]
[New Thread -1262236784 (LWP 7279)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb6a2bcc2 in QString::fromUtf8 () from /usr/lib/libqt-mt.so.3
#7  0xb7d325cd in KCal::Attachment::Attachment () from /usr/lib/libkcal.so.2
#8  0xb7d5c4e0 in KCal::ICalFormatImpl::readAttachment ()
   from /usr/lib/libkcal.so.2
#9  0xb7d621bf in KCal::ICalFormatImpl::readIncidence ()
   from /usr/lib/libkcal.so.2
#10 0xb7d6344e in KCal::ICalFormatImpl::readTodo () from /usr/lib/libkcal.so.2
#11 0xb7d63b9f in KCal::ICalFormatImpl::populate () from /usr/lib/libkcal.so.2
#12 0xb7d5890a in KCal::ICalFormat::fromRawString ()
   from /usr/lib/libkcal.so.2
#13 0xb7d58f70 in KCal::ICalFormat::load () from /usr/lib/libkcal.so.2
#14 0xb7d82de3 in KCal::FileStorage::load () from /usr/lib/libkcal.so.2
#15 0xb7d4a4e4 in KCal::CalendarLocal::load () from /usr/lib/libkcal.so.2
#16 0xb7d86722 in KCal::ResourceLocal::doLoad () from /usr/lib/libkcal.so.2
#17 0xb7d85ada in KCal::ResourceCalendar::load () from /usr/lib/libkcal.so.2
#18 0xb7d91b2e in KCal::CalendarResources::load () from /usr/lib/libkcal.so.2
#19 0xb2b3dace in KOrganizerPart::KOrganizerPart ()
   from /usr/lib/kde3/libkorganizerpart.so
#20 0xb2b3e988 in KParts::GenericFactory<KOrganizerPart>::createPartObject ()
   from /usr/lib/kde3/libkorganizerpart.so
#21 0xb75ee75f in KParts::Factory::createPart () from /usr/lib/libkparts.so.2
#22 0xb7e002ed in Kontact::Core::createPart ()
   from /usr/lib/libkpinterfaces.so.1
#23 0xb7e01aa7 in Kontact::Plugin::loadPart ()
   from /usr/lib/libkpinterfaces.so.1
#24 0xb584d3a5 in TodoPlugin::createPart ()
   from /usr/lib/kde3/libkontact_todoplugin.so
#25 0xb7e01a12 in Kontact::Plugin::part () from /usr/lib/libkpinterfaces.so.1
#26 0x08062920 in ?? ()
#27 0x08254a20 in ?? ()
#28 0x00000000 in ?? ()


The parts of Kontact seem to start well independently, except korganizer and korgac wich produce sigsevs when launched from konsole

backtrace for koragnizer
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1243268736 (LWP 7410)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb6a1ccc2 in QString::fromUtf8 () from /usr/lib/libqt-mt.so.3
#7  0xb78c95cd in KCal::Attachment::Attachment () from /usr/lib/libkcal.so.2
#8  0xb78f34e0 in KCal::ICalFormatImpl::readAttachment ()
   from /usr/lib/libkcal.so.2
#9  0xb78f91bf in KCal::ICalFormatImpl::readIncidence ()
   from /usr/lib/libkcal.so.2
#10 0xb78fa44e in KCal::ICalFormatImpl::readTodo () from /usr/lib/libkcal.so.2
#11 0xb78fab9f in KCal::ICalFormatImpl::populate () from /usr/lib/libkcal.so.2
#12 0xb78ef90a in KCal::ICalFormat::fromRawString ()
   from /usr/lib/libkcal.so.2
#13 0xb78eff70 in KCal::ICalFormat::load () from /usr/lib/libkcal.so.2
#14 0xb7919de3 in KCal::FileStorage::load () from /usr/lib/libkcal.so.2
#15 0xb78e14e4 in KCal::CalendarLocal::load () from /usr/lib/libkcal.so.2
#16 0xb791d722 in KCal::ResourceLocal::doLoad () from /usr/lib/libkcal.so.2
#17 0xb791cada in KCal::ResourceCalendar::load () from /usr/lib/libkcal.so.2
#18 0xb7928b2e in KCal::CalendarResources::load () from /usr/lib/libkcal.so.2
#19 0x0805264c in ?? ()
#20 0x08266110 in ?? ()
#21 0xbf9ecfc8 in ?? ()
#22 0x00000000 in ?? ()

backtrace for korgac
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1235679552 (LWP 7412)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7158cc2 in QString::fromUtf8 () from /usr/lib/libqt-mt.so.3
#7  0xb7dfa5cd in KCal::Attachment::Attachment () from /usr/lib/libkcal.so.2
#8  0xb7e244e0 in KCal::ICalFormatImpl::readAttachment ()
   from /usr/lib/libkcal.so.2
#9  0xb7e2a1bf in KCal::ICalFormatImpl::readIncidence ()
   from /usr/lib/libkcal.so.2
#10 0xb7e2b44e in KCal::ICalFormatImpl::readTodo () from /usr/lib/libkcal.so.2
#11 0xb7e2bb9f in KCal::ICalFormatImpl::populate () from /usr/lib/libkcal.so.2
#12 0xb7e2090a in KCal::ICalFormat::fromRawString ()
   from /usr/lib/libkcal.so.2
#13 0xb7e20f70 in KCal::ICalFormat::load () from /usr/lib/libkcal.so.2
#14 0xb7e4ade3 in KCal::FileStorage::load () from /usr/lib/libkcal.so.2
#15 0xb7e124e4 in KCal::CalendarLocal::load () from /usr/lib/libkcal.so.2
#16 0xb7e4e722 in KCal::ResourceLocal::doLoad () from /usr/lib/libkcal.so.2
#17 0xb7e4dada in KCal::ResourceCalendar::load () from /usr/lib/libkcal.so.2
#18 0xb7e59b2e in KCal::CalendarResources::load () from /usr/lib/libkcal.so.2
#19 0x08055f74 in ?? ()
#20 0x0812dd30 in ?? ()
#21 0x00000000 in ?? ()


when korganizer is started first korgac crashes then korganizer crashes
Comment 1 Allen Winter 2008-04-01 15:09:00 UTC
this is a well known bug about binary attachments.
the bug is deep in the 3rd party libical library.

try starting korganizer by itself first, find 
calendar events and to-dos with binary attachments
and remove the attachments from them.

then restart.

Comment 2 Manuel Gaus 2008-04-02 04:41:57 UTC
> this is a well known bug about binary attachments.
> the bug is deep in the 3rd party libical library.


i am absolutely certain to have no binary attachments for callendar events or 
to-dos.

> try starting korganizer by itself first


that does not work as the traceback of korganizer indicates, which i added to 
the bugreport.

> find calendar events and to-dos with binary attachments
> and remove the attachments from them.
> then restart.


I would like to do so, but without a running korganizer i can hardly access 
those events and to-dos.

Is there another way to deal with the problem?

regards, and thanks for your patience :-)

Manuel
Comment 3 Manuel Gaus 2008-04-02 05:56:48 UTC
> > this is a well known bug about binary attachments.
> > the bug is deep in the 3rd party libical library.
>
> i am absolutely certain to have no binary attachments for callendar events
> or to-dos.


erm... not so certain actually... I created a to-do entry from an email, this 
added a binary attachment to the to-do entry.

> > try starting korganizer by itself first
>
> that does not work as the traceback of korganizer indicates, which i added
> to the bugreport.
>
> > find calendar events and to-dos with binary attachments
> > and remove the attachments from them.
> > then restart.


luckily the .ics files i found under /home/$user/.kde/share/apps/korganizer 
are human readable. So I found the violating entry, and deleted it. 
Everything is fine again.

Thanks a lot for taking care of this nonetheless...

regards, 

Manuel
Comment 4 Thomas McGuire 2008-07-09 20:20:08 UTC

*** This bug has been marked as a duplicate of 159247 ***