Bug 159610 - processor threading on fetch and filter
Summary: processor threading on fetch and filter
Status: RESOLVED DUPLICATE of bug 41514
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.9.9
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-20 18:50 UTC by Caleb Cushing
Modified: 2008-03-31 01:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caleb Cushing 2008-03-20 18:50:32 UTC
Version:           1.9.9 (using KDE 3.5.9)
Installed from:    SuSE RPMs
OS:                Linux

although this is wishlist, it's something pretty important.

I'm pretty sure this is the same nomatter what but whenever my system is fetching mails (disconnected imap) kmail is slow, because it doesn't seem to be able to handle doing multiple things at once so well.

For clarity I'm running an athlon64 with a 5200 rpm hard drive and 1G plus ram,  laptop, x86 install arch, the other machine is running a Centrino Duo, 1G ram, x86 install.

last night I  put my friends computer on kmail she had 8000+ emails in her inbox many from a huge mailing list. It took half the night ~4hours (it was half way done after 2 when we went to bed, downloading mail 12MB of mail had been downloaded then) now I'm trying to filter then inbox of that mailing list that she just unsubscribed from. it's on 4620 mails after an hour. and kmail/kontact has been completely unusable during all of this.

6+ hours of usability after system install is unacceptable. kmail needs to fork these processes into the background so that the front-end of the app is still usable under any load. I'm also not sure but should it really take 2 hours to download 12MB of gmail imap?
Comment 1 Caleb Cushing 2008-03-20 18:55:29 UTC
note on download time. I can download a 600MB linux ISO in the same amount of time it took to download 12MB of mail. This is a high speed connection.
Comment 2 Thomas McGuire 2008-03-31 01:00:39 UTC

*** This bug has been marked as a duplicate of 41514 ***