Bug 159223 - RSS Feed for the announcements page
Summary: RSS Feed for the announcements page
Status: RESOLVED NOT A BUG
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-13 02:23 UTC by Leonardo Andrés Gallego
Modified: 2016-05-29 18:05 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leonardo Andrés Gallego 2008-03-13 02:23:11 UTC
Version:            (using KDE 3.5.9)
Installed from:    Unlisted Binary Package

There is no RSS Feed in the announcements page: http://www.kde.org/announcements/
I would like to syndicate the releases.
I cant find any other page that lists them in any kind of feed that i can filter.
Is there any reason not to have RSS feeds in the announcements page?

Regards and thanks!
Comment 1 Juha Tuomala 2009-02-27 16:26:18 UTC
Yes please, and it also lowers the bw consumption as RSS xml is much smaller than all images on website.
Comment 2 Vikram Dhillon 2010-01-23 02:52:19 UTC
IMHO RSS takes the same amount of memory as e-mail. There's a link for the mailing list: kde-announce [1] in the top-right corner of the page.

[1] https://mail.kde.org/mailman/listinfo/kde-announce
Comment 3 Leonardo Andrés Gallego 2012-08-22 01:23:36 UTC
I'm back to this issue. 

When I received the answer (two years after I posted the issue by the way) I was quite upset about it, so I left it there. Now I'm back, hoping someone can give this a second thought.

RSS is NOT the same as email, I really can't understand why one would exclude the other. RSS is automatic, you set it up, and everytime you post an announcement we (who subscribe) would get it. 

If RSS feeds where the same as email notifications via mailing lists, there would be no need for them anywhere. 

There are some people out there (like me) who like to read about announcements in their Feed Reader, not in ther email client. Most of the people who use a feed reader use it as a newspaper, to read interesting news or stay up to date with several sources.

I don't think memory is an issue for the KDE servers nor that a mailing list invalidates a need for an RSS in the page, where the announcements are posted. Please reconsider this, as it would make it much easier to follow announcements for those who use them for something (websites, magazines,  blogs and such).

Thanks.
Comment 4 Filipe Saraiva 2016-05-28 14:51:34 UTC
A RSS feed would be nice to automatize posts of the announcements in the social media. :'(
Comment 5 Albert Astals Cid 2016-05-28 22:42:49 UTC
If somebody has time I propose a way to have the information of the announcements page in a single place from which we can autogenerate the main pag, the announcements page and an rss.

Otherwise it because more of a burden for people that manually do the releases, talk to me in private if you want to take on that job.
Comment 6 Ingo Malchow 2016-05-29 17:39:35 UTC
Just out of curiousity, the dot serves as the main news hub. It even already shows release news, though stripped down. 
Why not use this as the main release news site, and instead of putting another source into svn, just show the dot release feed. This would probably involve adding another category to the dot, so the main site can just fetch the release news, instead of all news the dot has to offer. And on top of that provide the dot release feed on the main site as well (as rss).

This could simplify things, as a dot story needs to be written there anyway. 

Just wondering.
Comment 7 Albert Astals Cid 2016-05-29 18:05:02 UTC
We for sure do not write dot stories for all the release we do, go and check it.

Also dot stories are not translatable and our announcements are, so that would be a severe regression.