Bug 159159 - "Unknown key" banner in encrypted and signed message
Summary: "Unknown key" banner in encrypted and signed message
Status: CLOSED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: encryption (show other bugs)
Version: 1.9.9
Platform: Mandriva RPMs Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-11 21:49 UTC by Anne Wilson
Modified: 2011-03-31 12:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anne Wilson 2008-03-11 21:49:25 UTC
Version:           3.5.9 (using KDE 3.5.7)
Installed from:    Mandriva RPMs
OS:                Linux

A signed and encrypted message is displayed correctly decrypted.  However, the banner does not display the key information, saying that it is an unknown key.  This can be seen at http://www.lydgate.org/images/encryptNew.png
Comment 1 Thomas McGuire 2008-03-13 18:07:22 UTC
I just sent myself a encrypted and signed message, it was shown correctly.

Probably the key for signing is not in your key ring or it is not ultimately trusted. Please check that.
Comment 2 Anne Wilson 2008-03-13 19:57:01 UTC
I have been communicating with this person since mid-2005, almost always using encryption.  The message de-crypted correctly.  His key used on that message has been on my keyring since 2006, and is ultimately trusted.

The key is functioning correctly.  It is just not being reported correctly in the banner.  I don't have any other correspondent who uses encryption.  Perhaps you could send me a test one?
Comment 3 Petr Kopecký 2008-04-02 18:58:21 UTC
I can confirm this behaviour when the message is signed from Mozilla Thunderbird using Enigmail. It is behaving as described when "Use PGP/mime" option is chosen in Enigmail. This problem was not present in older version of Kmail. I am using encription when sending something from work computer to my home address and it was working fine before.
Comment 4 Anne Wilson 2008-04-02 20:54:43 UTC
Thank you Petr.  I can confirm that the friend I spoke of uses Thunderbird/2.0.0.12 with Enigma 0.95.6.  Like you, I had no problem with these messages under earlier versions of kmail.
Comment 5 Anne Wilson 2008-07-18 10:32:50 UTC
Is there any progress on this?  It's still occurring in 4.0.4 (Mandriva).
Comment 6 Anne Wilson 2008-11-09 17:36:50 UTC
Somewhere around 4.1. this bug disappeared.  I have not seen it for some months.  I think this bug should now be marked Resolved.
Comment 7 Allen Winter 2008-11-14 02:44:31 UTC
as you wish.  closing.
Comment 8 Tuomas Suutari 2011-03-31 12:55:57 UTC
Seems that this bug is still present in KMail 1.13.5 (of KDE 4.5.1 from Ubuntu 10.10 packages.)

Sender end had Thunderbird 3.1.7 and Enigmail 1.1.1 with "Use PGP/mime" turned on.