Bug 159119 - kopete kde4 msn/jabber/ login fails
Summary: kopete kde4 msn/jabber/ login fails
Status: RESOLVED DUPLICATE of bug 155564
Alias: None
Product: kopete
Classification: Unclassified
Component: general (show other bugs)
Version: 0.50.1
Platform: unspecified Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-11 04:00 UTC by Gerald Cox
Modified: 2008-04-02 15:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Cox 2008-03-11 04:00:25 UTC
Version:           0.50.1 (using 4.0.2 (KDE 4.0.2), 4.0.2-9.fc9 Fedora)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.25-0.101.rc4.git3.fc9

Running kopete .50.1 under KDE4

AIM/ICQ/Yahoo connect

MSN login fails - no error message received

Jabber fails with:
SSL support could not be initialized for account. This is most likely because the QCA TLS plugin is not installed on your system.  This option does not show up in the plugin list.
Comment 1 Pino Toscano 2008-03-11 09:04:46 UTC
> SSL support could not be initialized for account. This is most likely
> because the QCA TLS plugin is not installed on your system.

The error message is pretty clear: you miss QCA (version 2.0.0 and more) installed on your system.
Comment 2 Gerald Cox 2008-03-11 14:28:53 UTC
The following are applied to my system:

qca-tls-1.0-13.fc9.x86_64
qca2-2.0.0-2.fc9.x86

Jabber doesn't work with this configuration.  

MSN doesn't work and shows no error message.
Comment 3 Pino Toscano 2008-03-11 14:47:33 UTC
Please install the openssl plugin for qca2.
Comment 4 Gerald Cox 2008-03-11 15:04:09 UTC
Installed:
qca-ossl-2.0.0-0.4.beta3.fc9.x86_64
tcltls-1.5.0-16.fc9.x86_64

That allowed me to SSL connect to my jabber.org account; however
googletalk (also a jabber session) still does not connect.  I receive a 
"connecting" message, and then it just disconnects.

MSN still does not work.
Comment 5 Dongju Lee 2008-03-12 02:41:53 UTC
Same here...

I'm using gentoo but, exactly same.

MSN/jabber does not works.


I'm installed:
kopete-0.50.1
kde-4.0.2

qca-2.0.0-r2
qca-cyrus-sasl-2.0.0_beta3
qca-gnupg-2.0.0_beta2
qca-logger-2.0.0_beta2
qca-ossl-2.0.0_beta3
qca-tls-1.0-r3
Comment 6 Gerald Cox 2008-03-13 04:30:20 UTC
Looks like there may be a possible tie in to the konqueror SSL issue:
https://bugs.kde.org/show_bug.cgi?id=155564
Comment 7 manolis 2008-03-14 21:37:02 UTC
worked fine in 4.0.1 , after upgrade to 4.0.2 it stopped working...
I have alsa qca-*-2* installed ...
Comment 8 Kevin Kofler 2008-04-02 15:56:05 UTC
This is the same Qt issue as Konqueror bug #155564.

*** This bug has been marked as a duplicate of 155564 ***