Bug 158932 - Media content is not reloaded for medias with the same volume name
Summary: Media content is not reloaded for medias with the same volume name
Status: RESOLVED DUPLICATE of bug 161385
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-07 21:52 UTC by András Manţia
Modified: 2010-02-21 16:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description András Manţia 2008-03-07 21:52:49 UTC
Version:            (using Devel)

Let's assume there are two CDs with the same volume name (VOLUME). After inserting the first, it appears under Places as VOLUME, clicking on mounts it. Now eject it, eg. by clicking on the icon in the location area. The content disappears. Insert the second one. The same VOLUME name is shown. Click on it, the content is not shown. Press F5, it will appear.
Comment 1 Dario Andres 2008-12-25 21:05:48 UTC
I'm not sure if I'm experiencing the same problem:

Here using:

Qt: 4.4.3
KDE: 4.1.86 (KDE 4.1.86 (KDE 4.2 >= 20081221))
kdelibs svn rev. 901348 / kdebase svn rev. 901348
on ArchLinux x86_64 - Kernel 2.6.27.10

Steps to reproduce:

- Open Dolphin
- Plug an USB Pendrive
The pendrive entry appears in the Dolphin Places panel
- Click in the pendrive entry in the Dolphin Places panel
The pendrive is mounted and its content is shown in the File List
- Now, do a right click on the Pendrive entry in the Dolphin Places panel and select Safely Remove Volume"
Dolphin now points to "/media/disk" (I suppose this may differ)
- Now, double click again in the pendrive entry in the Dolphin places panel to re-mount the pendrive device.

The pendrive device is mounted, and the Dolphin breadcrumb location bar shows "Volume " with its USB icon, however the file view is empty

- Press F5 (Reload)

The content of the pendrive device is shown.


Comment 2 Frank Reininghaus 2010-01-19 13:47:29 UTC
Comment 1 and probably also the original report is the same as bug 161385.
Comment 3 Dario Andres 2010-02-21 16:32:49 UTC
Merging with bug 161385.

*** This bug has been marked as a duplicate of bug 161385 ***