Bug 158824 - Clipped background in panel with desktop effects enabled
Summary: Clipped background in panel with desktop effects enabled
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: panel (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal with 50 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 158904 158924 158959 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-05 21:41 UTC by Juan Ignacio Pumarino
Modified: 2008-06-01 07:08 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
install to $KDE4ROOT/share/apps/desktoptheme/widgets (13.06 KB, patch)
2008-03-23 19:35 UTC, Cornelius Maihöfer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Ignacio Pumarino 2008-03-05 21:41:54 UTC
Version:            (using KDE 4.0.2)
Installed from:    Ubuntu Packages
OS:                Linux

Using the Ubuntu gutsy packages for KDE 4.0.2, if desktop effects are enabled, the right border of the plasma panel gets clipped, showing the background.

http://img301.imageshack.us/img301/1500/plasmapanelbackgroundclgj6.png
Comment 1 Seb 2008-03-05 23:03:03 UTC
Same here, using openSuse 10.3, KDE 4.0.2

But: The clipping also appears on the left and bottom. 

Notice: on openSuse, the previous 4.0.1 packages contained backpots from 4.0.2 including this bug since around 20/2/2008. Somewhen before it did not appear.
Comment 2 Thomas Georgiou 2008-03-06 04:33:32 UTC
This is a qt bug.  It is fixed in 4.4 though.
Comment 3 Seb 2008-03-06 09:56:19 UTC
But if this is a Qt related bug - why did it NOT appear in the initial 4.0.1 release??
Comment 4 copong 2008-03-06 10:45:29 UTC
Fair point, it didn't happen on 4.0.0 either.

PS: happens here too. Kubuntu Hardy.
Comment 5 Sokraates 2008-03-06 10:49:36 UTC
I confirm this on Kubuntu Hardy 4.0.2 where the error appears on the left, right and bottom of the panel.

As has been noted this error has not appeared before, even though, as far as I know, nothing in QT has changed since 4.0.0. QT 4.4 will only be used for KDE 4.1.

Though there was a new feature in 4.0.2: resizing of the taskbar. You can now select the height of the taskbar, ranging from tiny to huge and also set it by pixels. I use the "normal" = default setting and see this error. I tried some others and saw it as well, though I didn't test the options systematically. 

Maybe this new feature is the root of this error?
Comment 6 Seb 2008-03-06 12:02:52 UTC
This is my impression as well. Since I installed the Suse4.0.1 plasma backport containing the resizing feature I got this problem. I did not file a bug report at that time since the bug was -so- obvious. 
Comment 7 Raphael Fuchs 2008-03-06 17:45:26 UTC
I can confirm this bug. It's pretty annoying! 
Comment 8 Felix H. Dahlke 2008-03-07 17:58:52 UTC
I have a similar issue. But it's not just the right border,it's actually every border. The left one just isn't that obvious because the K button somewhat hides it. I also have like 1 pixel of missing panel background on top and on bottom of the panel.
Using Kubuntu and KDE 4.0.2 (it didn't occur in 4.0.1 either)
Comment 9 Juan Ignacio Pumarino 2008-03-07 18:47:13 UTC
I can confirm that this happens on every border, so this is the same issue that Felix is reporting.
Comment 10 Sebastian Sauer 2008-03-07 20:05:21 UTC
Re comment #3 "But if this is a Qt related bug - why did it NOT appear in the initial 4.0.1 release??"

Cause in 4.0.2 we are using now a SvgPanel and it's exactly those SVG "rendering" that seems to be broken with Qt4.3 and is fixed in Qt4.4.
Comment 11 Sebastian Sauer 2008-03-07 20:08:45 UTC
*** Bug 158904 has been marked as a duplicate of this bug. ***
Comment 12 Marco Martin 2008-03-07 21:01:49 UTC
*** Bug 158924 has been marked as a duplicate of this bug. ***
Comment 13 Sebastian Sauer 2008-03-07 21:42:12 UTC
Since that question may come up;

An option to solve that would be probably to revert those parts to the old aka 4.0.1 code where we didn't used a SvgPanel.

The problem I see here is, that it may introduce more bugs while it just tries to address a "visual bug". So, the real question is imho, if at the end that wouldn't provide more problems then it would solve any :-/
Comment 14 FiNeX 2008-03-08 11:15:52 UTC
*** Bug 158959 has been marked as a duplicate of this bug. ***
Comment 15 Michael 2008-03-09 22:21:19 UTC
I can confirm this on Kubuntu 7.10 with KDE 4.0.2 as well.

When is QT4.4 set to release?
Comment 16 Seb 2008-03-10 10:37:45 UTC
Since another question will come up:
I do not believe, that introducing Qt4.4 in 4.0.x series will help since it certainly will introduce new bugs. Maybe it will indeed be the best to live with it for next months (There are only 3 or 4 left until 4.1?)

I wrote a How-To for replacing the plasma panel by kicker on kde-look.org. At least for me, this is a satisfying temporary solution until 4.1.
Comment 18 Unknown 2008-03-10 19:11:58 UTC
I can confirm this bug for KDE 4.0.2, Kubuntu 7.10. The only solution for me is to disable desktop effects, which is sad as they are really nice.
Why is SvgPanel used when it's known to be broken in Qt 4.3? Why was a working panel in KDE 4.0.1 broken on purpose? I really don't get that decision. Hoping for a fix in 4.0.3 :)
Comment 19 Harald Sitter 2008-03-12 15:42:44 UTC
Corresponding Ubuntu report: http://bugs.launchpad.net/kdebase/+bug/198362
Comment 20 Cornelius Maihöfer 2008-03-23 19:35:47 UTC
Created attachment 24028 [details]
install to $KDE4ROOT/share/apps/desktoptheme/widgets

Replacement for the panel-backround.svg. This new one contains embedded PNGs.
Just a workaround for 4.0.x-branch untill Qt 4.4 arrives, and not 100% looking
the same as the old one. So maybe the Oxygen-team will provide us with an even
better one.
Comment 21 Cornelius Maihöfer 2008-03-23 19:42:22 UTC
see http://bugs.launchpad.net/kdebase/+bug/198362 .... for screenshot

There is a really simple workaround for this bug untill Qt4.4 arrives: one just has to replace the panel-background.svg with another svg that the gradient as PNGs embedded. As the bug affects only svg-rendering and not the png, this could be the workaround...

Note that is does not look 100% exactly as the old one, but I try to provide a better one the next days, if wished. Or: the oxygen-artists will do even better.
Comment 22 Jason Stubbs 2008-06-01 07:08:10 UTC
With 4.1 just around the corner, it's time to close off 4.0 bugs. In the off chance that I'm wrong in believing this to be fixed in 4.1, please reopen. :)