Bug 158677 - Dragging screenshot to a text box should save to temporary file and insert the file name
Summary: Dragging screenshot to a text box should save to temporary file and insert th...
Status: RESOLVED FIXED
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist with 52 votes (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
: 175128 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-02 13:30 UTC by Grósz Dániel
Modified: 2013-07-19 19:54 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Grósz Dániel 2008-03-02 13:30:19 UTC
Version:            (using KDE 4.0.1)
Installed from:    SuSE RPMs
OS:                Linux

If the user drags the screenshot to a text box, ksnapshot should save the screenshot in a temporary file and insert the file name. This would be useful, for example, for uploading screenshots through web forms: one could just drag and drop the shot to the upload box.
Comment 1 FiNeX 2009-08-07 18:33:47 UTC
If your need is to upload the shot using services like imageshack or imagebin you can drag the screenshot to the pastebin plasmoid directly from the ksnapshot preview.

Anyway I'd like this feature too: it could be very useful to attach screenshots into bugzilla bugs for example :-)
Comment 2 FiNeX 2009-08-07 18:41:32 UTC
*** Bug 175128 has been marked as a duplicate of this bug. ***
Comment 3 Pavol Rusnak 2010-05-09 20:59:56 UTC
I would add an extra button to upload to image hosting services (with some predefined ones). Dragging screenshot to text-box could invoke the upload to favorite service and putting URL into the box.
Comment 4 Grósz Dániel 2010-05-09 21:16:24 UTC
Since from dragging the picture it is not inherent that you want to share it over http (what's more, automatic uploading could cause accidental leaking of confidential information) I don't think it is a good idea to not have the opion of saving locally. By saving it locally we also have the option to drag it into the upload field of a html form of an image hosting site or a bugzilla (at least we would have if DnD to text fields wasn't still buggy in KHTML). To have the option of uploading to an image hosting service and inserting the url we could open a popup menu with the options of saving locally and uploading to image hosting services.
Comment 5 Sebastian Kügler 2013-07-19 19:54:59 UTC
Git commit 3bb8fe97096badedf45863ab81f5868ca01cc2de by Sebastian Kügler.
Committed on 19/07/2013 at 19:46.
Pushed by sebas into branch 'master'.

Attach URL to dragged image to mimedata

This makes dropping ksnapshots images into clients work that don't pick up the
image data, but only look for a URL in the dragged mimedata.

REVIEW:111564
Related: bug 256492, bug 256801

M  +3    -0    ksnapshot.cpp

http://commits.kde.org/ksnapshot/3bb8fe97096badedf45863ab81f5868ca01cc2de