Bug 158632 - Attachment icons not correct for IMAP messages
Summary: Attachment icons not correct for IMAP messages
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: SVN trunk (KDE 4)
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-01 17:12 UTC by Magnus
Modified: 2008-04-14 20:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus 2008-03-01 17:12:46 UTC
Version:           1.9.50 (using Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.1 
OS:                Linux

When I receive mails containing one or more attachments via IMAP, the attached files are not recognized while reading the mail in "built in mode" in kmail. If I double click the mail to open it in a new window, the attachments are read fine. Saving a file in "built in mode" results in a 0 bytes file as well, while it works fine if I save from a mail viewed in a new window. Two following two screenshots illustrate the issue:

http://folk.ntnu.no/romnes/kde4/kmail_attachement_bug1.png (built in mode)
http://folk.ntnu.no/romnes/kde4/kmail_attachement_bug2.png (viewing the message in a new window)
Comment 1 Thomas McGuire 2008-03-01 17:28:15 UTC
The zero-sized files when saving has been fixed yesterday.

The remaining problem is that the icon for the attachment is incorrect.
Comment 2 Magnus 2008-03-01 23:36:27 UTC
I just recompiled kmail (revision 781036). While the attached files are > 0 bytes now, they seem to be corrupted (tried saving the attachment from two different mails, one JPEG image and one PDF document) and cannot be opened.

Also, kmail seems to read the mimetype wrong, as it sugguests opening both the JPEG image and the PDF document using kwrite. If I open the mail in a new window by double clicking on it, the PDF is opened in okular, and the JPEG image is shown in the window itself (and opened in gwenview if I press on the link beneath it).
Comment 3 Thomas McGuire 2008-03-15 21:59:15 UTC
The mimetypes are fixed now (with rev. 785997 and 786032): The correct icon is displayed and KMail knows the correct mimetype.

I could not reproduce the attachment corruption: I composed a mail and added a jpeg and a pdf, then saved the message as draft and moved it from the draft folder to an online IMAP folder.
Then I selected the message and saved the attachments. The attachments were not corrupt, I could still view the image and the PDF.

Can you try again with a newer version? If you still get corruption, could you provide more details?
Comment 4 Thomas McGuire 2008-04-14 20:50:26 UTC
Closing. Please reopen if you can still reproduce with the lastest version from SVN.