Bug 158371 - focus the input box when chat window is clicked
Summary: focus the input box when chat window is clicked
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Applications
Component: Chat Window (show other bugs)
Version: 0.50.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 161299 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-02-25 01:09 UTC by Matteo Croce
Modified: 2008-04-27 12:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matteo Croce 2008-02-25 01:09:02 UTC
Version:           0.50.1 (using 4.0.1 (KDE 4.0.1), Kubuntu packages)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.24

In old kopete (kde 3.5) the Input field gets the focus when the chat window is clicked (I refer to the textarea where messages are written)
In newer kopete this doesn't happens, and that's a bit annoyng
Comment 1 FiNeX 2008-02-25 12:37:29 UTC
Confirmed on revision 779032.
Comment 2 Dennis Nienhüser 2008-04-20 12:27:39 UTC
SVN commit 799085 by nienhueser:

Focus proxy on message part; this way the text edit gets the focus when I scroll over the message part. I think it was also this way in the KDE 3 version.
Backport of the fix introduced in revision 778884 by uwolfer
BUG: 158371


 M  +1 -8      chatview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=799085
Comment 3 Dennis Nienhüser 2008-04-27 12:07:59 UTC
*** Bug 161299 has been marked as a duplicate of this bug. ***