Bug 158079 - Organization between user and developer
Summary: Organization between user and developer
Status: RESOLVED NOT A BUG
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-02-20 02:26 UTC by Jeremy Hankenson
Modified: 2011-06-27 10:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Hankenson 2008-02-20 02:26:48 UTC
Version:            (using KDE 4.0.1)
Installed from:    Ubuntu Packages
OS:                Linux

In my opinion, the KDE website needs a little bit of organization; between user centric and developer centric. 
I think something of the way the microsoft does it, keep all the developer stuff in a sub domain like msdn or in KDE's case, techbase or develop.kde.org. 

Then maybe wrap up all the technolgies into that one sub domain like this.
techbase.kde.org/plasma 
or
techbase.kde.org/apps/multimedia/amarok

Then possibly have a sub domain for all the user centric information; like user(Just throwing things out here) and it could look like this.

user.kde.org/apps/amarok
or
user.kde.org/apps/media/amarok

Now, the users can find what they need like features, screenshots, etc on the user domain and developers know where to find there information and its all organized in a proficient way. 

I always see KDE looking into the future, well in the future KDE will have alot of people who aren't developers but average people who will come to expect a expected behavior on the kde website. 

I relize this is quite huge of a job, but If I could help in any way, I will do my best.
Comment 1 groot 2008-02-29 09:39:48 UTC
On Wednesday 20 February 2008 02:26, Jeremy Hankenson wrote:
> In my opinion, the KDE website needs a little bit of organization; between
> user centric and developer centric. I think something of the way the
> microsoft does it, keep all the developer stuff in a sub domain like msdn
> or in KDE's case, techbase or develop.kde.org.


This is the plan, to put the technology articles under techbase. We used to 
have developer.kde.org for this.

> Then maybe wrap up all the technolgies into that one sub domain like this.
> techbase.kde.org/plasma
> or
> techbase.kde.org/apps/multimedia/amarok


Matters of techbase organization lie with the techbase maintainers, but I 
believe they have a structure like that already.


> Then possibly have a sub domain for all the user centric information; like
> user(Just throwing things out here) and it could look like this.
>
> user.kde.org/apps/amarok
> or
> user.kde.org/apps/media/amarok


I'm less convinced of this, simply because of the traditional use of 
<product>.kde.org subdomains to organize things already. Also not all of the 
applications want to live under kde.org (amarok in particular!)


> Now, the users can find what they need like features, screenshots, etc on
> the user domain and developers know where to find there information and its
> all organized in a proficient way.


Yes. Bear this cautionary word in mind, though: "it is easier to *want* to do 
it right than to *actually* do it right." But then I've stood by two previous 
attempts to do this (which have resulted in incremental improvements in the 
organization of the site, but not the complete overhaul that some people 
(myself included) think is needed.


> I relize this is quite huge of a job, but If I could help in any way, I
> will do my best.


Join the KDE website mailing list (kde-www, you can find it via lists.kde.org 
I think) and go from there.

[ade]
Comment 2 Ingo Malchow 2011-06-27 10:22:00 UTC
As much has changed over time and we now have a developer and user centric wiki, closing this bug, even though keyword IRRELEVANT_AS_TOO_OLD would fit better.