Bug 157777 - PDF file closes KPDF instantly
Summary: PDF file closes KPDF instantly
Status: RESOLVED FIXED
Alias: None
Product: kpdf
Classification: Applications
Component: general (show other bugs)
Version: 0.5.8
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Albert Astals Cid
URL:
Keywords:
: 158015 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-02-13 12:55 UTC by Máté Soós
Modified: 2008-03-18 19:08 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Máté Soós 2008-02-13 12:55:58 UTC
Version:           0.5.8 (using KDE 3.5.8)
Installed from:    Debian testing/unstable Packages
Compiler:          gcc (GCC) 4.2.3 20080114 (prerelease) (Debian 4.2.2-7) 
OS:                Linux

KPDF instantly closes when opening the file csg.csail.mit.edu/pubs/memos/Memo-481/Memo-481.pdf

Output:

soos@doom:~/Desktop$ kpdf Memo-481.pdf
Bogus memory allocation size
soos@doom:~/Desktop$

KPDF loads, looks like it starts drawing, and instantly closes. Not a segfault or such, gdb gives "Program exited with code 01.". Maybe libpoppler?
Comment 1 Pino Toscano 2008-02-13 14:53:09 UTC
Confirmed on r774543:

0x00002b0cf15c1db6 in Splash::fillGlyph2 (this=0x8fa030, x0=83, y0=47, glyph=0x7fffc11bca00, noClip=1) at Splash.cc:1685
1685                alpha = *p++;
(gdb) bt
#0  0x00002b0cf15c1db6 in Splash::fillGlyph2 (this=0x8fa030, x0=83, y0=47, glyph=0x7fffc11bca00, noClip=1) at Splash.cc:1685
#1  0x00002b0cf15c2751 in Splash::fillChar (this=0x8fa030, x=218.43200000000002, y=667.44599999999991, c=59, font=0x91c280) at Splash.cc:1644
#2  0x00002b0cf156a5bb in SplashOutputDev::drawChar (this=0x8fb150, state=0x91be90, x=218.43200000000002, y=667.44599999999991, originX=0, originY=0,
    code=59) at SplashOutputDev.cc:1397
#3  0x00002b0cf1506d51 in Gfx::doShowText (this=0x9f5c00, s=0x91c1f0) at Gfx.cc:3252
#4  0x00002b0cf1507912 in Gfx::opShowText (this=0x9f5c00, args=0x7fffc11bce80) at Gfx.cc:3039
#5  0x00002b0cf14ffbe6 in Gfx::execOp (this=0x9f5c00, cmd=0x7fffc11bd090, args=0x7fffc11bce80, numArgs=1) at Gfx.cc:690
#6  0x00002b0cf14ffd5b in Gfx::go (this=0x9f5c00, topLevel=1) at Gfx.cc:581
#7  0x00002b0cf150019d in Gfx::display (this=0x9f5c00, obj=0x7fffc11bd220, topLevel=1) at Gfx.cc:553
#8  0x00002b0cf1548833 in Page::displaySlice (this=0x8fce30, out=0x8fb150, hDPI=27.647058823529413, vDPI=27.636363636363637, rotate=0, useMediaBox=0,
    crop=0, sliceX=-1, sliceY=-1, sliceW=-1, sliceH=-1, printing=0, catalog=0x8fdd20, abortCheckCbk=0, abortCheckCbkData=0x0) at Page.cc:434
#9  0x00002b0cf1548adb in Page::display (this=0x8fce30, out=0x8fb150, hDPI=27.647058823529413, vDPI=27.636363636363637, rotate=0, useMediaBox=0, crop=1,
    printing=0, catalog=0x8fdd20, abortCheckCbk=0, abortCheckCbkData=0x0) at Page.cc:383
#10 0x00002b0cf15459c8 in PDFDoc::displayPage (this=0x85fb00, out=0x8fb150, page=2, hDPI=27.647058823529413, vDPI=27.636363636363637, rotate=0,
    useMediaBox=0, crop=1, printing=0, abortCheckCbk=0, abortCheckCbkData=0x0) at PDFDoc.cc:350
#11 0x00002b0cf15f835a in PDFGenerator::generatePixmap (this=0x8f6e00, request=0x9f3300) at generator_pdf.cpp:319
#12 0x00002b0cf15e7c6e in KPDFDocument::sendGeneratorRequest (this=0x761580) at document.cpp:1169
#13 0x00002b0cf15e8376 in KPDFDocument::requestDone (this=0x761580, req=0x87b5d0) at document.cpp:1141
#14 0x00002b0cf15fa7cb in Generator::signalRequestDone (this=0x8f6e00, request=0x87b5d0) at ./../../core/generator.h:78
#15 0x00002b0cf15f8415 in PDFGenerator::generatePixmap (this=0x8f6e00, request=0x87b5d0) at generator_pdf.cpp:338
#16 0x00002b0cf15e7c6e in KPDFDocument::sendGeneratorRequest (this=0x761580) at document.cpp:1169
#17 0x00002b0cf15e802d in KPDFDocument::requestPixmaps (this=0x761580, requests=@0x7fffc11bd810) at document.cpp:504
#18 0x00002b0cf160e6c4 in ThumbnailList::slotRequestVisiblePixmaps (this=0x7e0180, newContentsY=-1) at thumbnaillist.cpp:424
#19 0x00002b0cf160e7b1 in ThumbnailList::slotDelayTimeout (this=0x7e0180) at thumbnaillist.cpp:438
#20 0x00002b0cf160f1c0 in ThumbnailList::qt_invoke (this=0x7e0180, _id=68, _o=0x7fffc11bd9f0) at thumbnaillist.moc:149
#21 0x00002b0cec336186 in QObject::activate_signal (this=0x909e10, clist=0x909eb0, o=0x7fffc11bd9f0) at kernel/qobject.cpp:2356
#22 0x00002b0cec336d04 in QObject::activate_signal (this=0x909e10, signal=2) at kernel/qobject.cpp:2325
#23 0x00002b0cec6b011a in QTimer::timeout (this=0x909e10) at .moc/debug-shared-mt/moc_qtimer.cpp:82
#24 0x00002b0cec35bfab in QTimer::event (this=0x909e10, e=0x7fffc11bdec0) at kernel/qtimer.cpp:219
#25 0x00002b0cec2ce3aa in QApplication::internalNotify (this=0x7fffc11be2b0, receiver=0x909e10, e=0x7fffc11bdec0) at kernel/qapplication.cpp:2635
#26 0x00002b0cec2d0158 in QApplication::notify (this=0x7fffc11be2b0, receiver=0x909e10, e=0x7fffc11bdec0) at kernel/qapplication.cpp:2358
#27 0x00002b0ceaf3faad in KApplication::notify (this=0x7fffc11be2b0, receiver=0x909e10, event=0x7fffc11bdec0)
    at /tmp/buildd/kdelibs-3.5.8.dfsg.1/./kdecore/kapplication.cpp:550
#28 0x00002b0cec25fabe in QApplication::sendEvent (receiver=0x909e10, event=0x7fffc11bdec0) at ../include/qapplication.h:520
#29 0x00002b0cec2c1b04 in QEventLoop::activateTimers (this=0x6559b0) at kernel/qeventloop_unix.cpp:556
#30 0x00002b0cec274185 in QEventLoop::processEvents (this=0x6559b0, flags=4) at kernel/qeventloop_x11.cpp:389
#31 0x00002b0cec2e8673 in QEventLoop::enterLoop (this=0x6559b0) at kernel/qeventloop.cpp:198
#32 0x00002b0cec2e835f in QEventLoop::exec (this=0x6559b0) at kernel/qeventloop.cpp:145
#33 0x00002b0cec2cfe8c in QApplication::exec (this=0x7fffc11be2b0) at kernel/qapplication.cpp:2758
#34 0x0000000000409a22 in main (argc=2, argv=0x7fffc11be628) at main.cpp:79
Comment 2 Albert Astals Cid 2008-02-13 21:01:57 UTC
Fixed, thanks for reporting.
Comment 3 Albert Astals Cid 2008-02-18 20:44:01 UTC
*** Bug 158015 has been marked as a duplicate of this bug. ***
Comment 4 Albert Astals Cid 2008-02-18 20:45:05 UTC
Unfortunately this fix did not make it into yet-to-be-released KDE 3.5.9, you should bug your distribution to include it as 3.5.9 will be probably the last KDE 3.5 series
Comment 5 Bart Van Assche 2008-02-18 20:53:38 UTC
Logged this crash as an openSUSE 10.3 bug. See also https://bugzilla.novell.com/show_bug.cgi?id=362779
Comment 6 Rex Dieter 2008-03-18 14:50:49 UTC
Re: comment #4
> this fix did not make it into yet-to-be-released KDE 3.5.9

Any references to the commit that fixed this?  Would greatly help so distro packagers don't have to hunt for it.
Comment 7 Albert Astals Cid 2008-03-18 19:08:08 UTC
Rex it is EASY

svn log svn://anonsvn.kde.org/home/kde/branches/KDE/3.5/kdegraphics/kpdf -r774543:HEAD | less

And look for 157777 there