Bug 157274 - Gwenview could have a tool for setting the zoom in percentage
Summary: Gwenview could have a tool for setting the zoom in percentage
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 2.0
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
: 429204 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-02-06 19:09 UTC by Livio
Modified: 2020-12-01 19:48 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Livio 2008-02-06 19:09:00 UTC
Version:           2.0 (using 4.0.1 (KDE 4.0.1), Kubuntu packages)
Compiler:          gcc
OS:                Linux (i686) release 2.6.22-14-generic

Gwenview could have on the toolbar a simple tool for setting the zoom by choosing its percentage, like a text field mixed with an option box (I believe it's an option box).

The user would choose the percentage of the zoom by selecting it from a popup option box or by entering directly on the text field, or it could be a text field with two arrows for setting the zoom, eliminating the popup option box.
Comment 1 Livio 2008-02-06 19:16:27 UTC
complementing: it could also have an option to keep or not the zoom in the next images.
Comment 2 Jekyll Wu 2012-01-03 04:16:26 UTC
There is a slider bar at the right bottom. It can be used for setting zoom level in view mode and thumbnail size in browser mode.
Comment 3 Nate Graham 2017-09-11 15:48:38 UTC
Yeah it might be nice if you could click on the percentage figure to change it to an arbitrary value.
Comment 4 Nate Graham 2020-11-17 17:40:46 UTC
*** Bug 429204 has been marked as a duplicate of this bug. ***
Comment 5 Bug Janitor Service 2020-11-26 19:49:24 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/gwenview/-/merge_requests/25
Comment 6 Nate Graham 2020-12-01 19:48:04 UTC
Git commit 2cdaca95c1303c69466917398ef6e47b0f3de920 by Nate Graham, on behalf of Antonio Prcela.
Committed on 01/12/2020 at 19:48.
Pushed by ngraham into branch 'master'.

Enable custom zoom values with a SpinBox replacing the static label
FIXED-IN: 21.04

M  +19   -10   lib/zoomwidget.cpp
M  +1    -0    lib/zoomwidget.h

https://invent.kde.org/graphics/gwenview/commit/2cdaca95c1303c69466917398ef6e47b0f3de920