Bug 156798 - strange intersections when window on desktop grid intersects several desktops
Summary: strange intersections when window on desktop grid intersects several desktops
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 157260 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-27 17:50 UTC by Stefan Majewsky
Modified: 2008-02-25 12:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Majewsky 2008-01-27 17:50:50 UTC
Version:            (using KDE 4.0.0)

When moving a window on the desktop grid, one can position it to overlap several desktops. Of course, the window can only be on one desktop. However, it happens that the window is displayed over some desktops, and is overlapped by some others. Which desktop covers and which does not, seems to heavily depend on the position of the window (I talk about only some pixels).

The best solution in my opinion would be that the window is cut off at the edges of the desktop (just like if it does not appear at all at the other desktops, and that is the case).
Comment 1 Lubos Lunak 2008-01-29 18:04:59 UTC
SVN commit 768277 by lunakl:

Temporary hack for #156798 until http://lists.kde.org/?l=kwin&m=120138051215450&w=2
is evaluated.
CCBUG: 156798



 M  +19 -0     desktopgrid.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=768277
Comment 2 Lubos Lunak 2008-02-06 16:14:57 UTC
*** Bug 157260 has been marked as a duplicate of this bug. ***
Comment 3 Lubos Lunak 2008-02-25 12:32:47 UTC
SVN commit 779045 by lunakl:

Abstract paint clipping into PaintClipper helper class that allows
stacking of clipping regions.
(http://lists.kde.org/?l=kwin&m=120138051215450&w=2)
BUG: 156798



 M  +1 -1      effects/coverswitch.cpp  
 M  +8 -0      effects/desktopgrid.cpp  
 M  +1 -1      effects/flipswitch.cpp  
 M  +26 -25    effects/magnifier.cpp  
 M  +1 -1      effects/presentwindows.cpp  
 M  +4 -7      effects/shadow.cpp  
 M  +1 -1      effects/shadow.h  
 M  +1 -1      effects/showfps.cpp  
 M  +1 -1      effects/snow.cpp  
 M  +1 -1      effects/trackmouse.cpp  
 M  +164 -0    lib/kwineffects.cpp  
 M  +87 -1     lib/kwineffects.h  
 M  +9 -46     lib/kwinglutils.cpp  
 M  +4 -10     lib/kwinglutils.h  
 M  +2 -0      scene.cpp  
 M  +0 -8      scene.h  
 M  +14 -12    scene_opengl.cpp  
 M  +22 -45    scene_xrender.cpp  
 M  +0 -1      scene_xrender.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=779045