Bug 156120 - Global shortcuts don't work after configuring them in control module
Summary: Global shortcuts don't work after configuring them in control module
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Andreas Hartmetz
URL:
Keywords:
: 154092 156218 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-18 17:34 UTC by Lubos Lunak
Modified: 2008-03-12 19:39 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lubos Lunak 2008-01-18 17:34:10 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Start KDE, Alt+F2 works, run 'kcmshell keys', Alt+F2 works, close the module, Alt+F2 works not longer. The problem is KAction dtor which disables the shortcut.
Comment 1 Lubos Lunak 2008-01-22 18:40:26 UTC
*** Bug 156218 has been marked as a duplicate of this bug. ***
Comment 2 David Faure 2008-01-30 12:51:47 UTC
SVN commit 768573 by dfaure:

Fix Bug 156120: Global shortcuts don't work after configuring them in control module
BUG: 156120


 M  +1 -0      globalshortcuts.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=768573
Comment 3 Lubos Lunak 2008-03-12 19:39:58 UTC
*** Bug 154092 has been marked as a duplicate of this bug. ***