Bug 155873 - kdeinit couldn't load /usr/bin/foo-kde4
Summary: kdeinit couldn't load /usr/bin/foo-kde4
Status: RESOLVED DUPLICATE of bug 75492
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
Depends on:
Reported: 2008-01-16 03:43 UTC by The Marauder
Modified: 2008-05-30 11:06 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:

message box (21.83 KB, image/png)
2008-01-16 03:44 UTC, The Marauder

Note You need to log in before you can comment on or make changes to this bug.
Description The Marauder 2008-01-16 03:43:52 UTC
Version:            (using KDE KDE 4.0.0)
Installed from:    Ubuntu Packages
Compiler:          From Kubuntu Gutsy ppa's repositories 
OS:                Linux

Sometimes whan i try to launch kde4 apps from "lat+F2" command or from the menu. I'have a message say kdeinit can't launch /usr/bin/foo-kde4.
Comment 1 The Marauder 2008-01-16 03:44:22 UTC
Created attachment 23067 [details]
message box
Comment 2 Mohammad Naghavi 2008-01-28 08:31:55 UTC
When I right click on files in dolphin (.txt or .xml or any text files) and select "Kwrite KDE 4", kwrite starts up and opens the file but dolphin gives me this error:

      KDEInit could not launch '/usr/bin/kwrite-kde4'.

I tested in konqueror and it gave me the same error.
Double clicking on file did the same but after giving the error for first time, when I click on OK in error dialog it calls the kwrite for seccond time and again gives me the same error!
as I remember I didn't have such problem with other programs than kwrite and from run (Alt+F2).
Comment 3 Sokraates 2008-03-06 10:24:33 UTC
I can confirm this on Kubuntu Gutsy and Hardy. On Hardy this error has not occurred under KDE 4.0.2 yet. I no longer have my Gutsy installation.
Comment 4 George Kiagiadakis 2008-03-06 18:24:32 UTC
I can confirm this on debian too with kde 4.0.2 installed.
The message normally appears when I click a text file in dolphin or konqueror. kwrite opens, showing the file and when I close kwrite, I get the message:
"KDEInit could not launch /usr/bin/kwrite"
Comment 5 Ambroz Bizjak 2008-03-22 21:52:47 UTC
I can confirm that on Gentoo with KDE 4.0.2. After clicking on a file in dolphin (or konqueror), the file opens; dolphin is frozen while the file is open, and when it is closed, that error message appears and dolphin starts responding.
Comment 6 Peter Grasch 2008-05-04 15:22:45 UTC
I can confirm this on gentoo too.
I am running kde-svn from about yesterday, so the bug is still there!

Atm it even pops up _every_ time I open a textfile with kwrite from within e.g. dolphin. Sometimes it even tries again after closing the application (which effectively starts kwrite again - and after closing it yields to the same error message).
Comment 7 Lubos Lunak 2008-05-30 11:06:55 UTC

*** This bug has been marked as a duplicate of 75492 ***