Bug 155808 - white screen when launching plasma dashbard
Summary: white screen when launching plasma dashbard
Status: RESOLVED WORKSFORME
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 176409 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-15 08:00 UTC by Jean-Baptiste Balleyguier
Modified: 2009-08-03 07:38 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot with white flash effect (886.87 KB, image/png)
2008-12-22 04:34 UTC, Maciej Mrozowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Balleyguier 2008-01-15 08:00:31 UTC
Version:            (using KDE KDE 4.0.0)
Installed from:    Gentoo Packages
Compiler:          GCC-4.1.2 
OS:                Linux

When I hit CTRL+F12 I get a white screen just before the dashboard to appear. This happens when Desktop effects are disabled. And the dashboard is quite long to appear and to come back to desktop.

Don't know if it can help, but : my card is nVidia 8400GS
Comment 1 Luka Renko 2008-01-15 17:07:08 UTC
I can confirm this with ATI FireGL V5000 (using open-source drivers) and w/o desktop effects too.

Runing Kubuntu Hardy (Ubuntu 4.0.0. packages and also up-to-date 4.0.x branch built myself).
Comment 2 Aaron J. Seigo 2008-01-15 17:23:57 UTC
yes, that's the time between show and draw.
Comment 3 Jason Stubbs 2008-06-01 05:36:39 UTC
With 4.1 just around the corner, it's time to close off 4.0 bugs. In the off chance that I'm wrong in believing this to be fixed in 4.1, please reopen. :)
Comment 4 lucas 2008-06-15 14:44:30 UTC
I can still reproduce this in latest SVN.
Comment 5 Anne-Marie Mahfouf 2008-06-16 10:57:42 UTC
NVidia GO 7400, can't reproduce. svn trunk revision 821039. No desktop effects as my settings were reset.
Comment 6 Maciej Mrozowski 2008-11-29 04:40:47 UTC
I can reproduce 100/100 using trunk (dated 28/11/2008) with and without kwin desktop effects.

Using ATI x1950 AGP with xf86-video-ati drivers from git and X.org 1.5.3 on amd64 Gentoo box.

The difference between using desktop effects is that white flash screen is smoothly (doesn't ficker) "transioned" to dashboard view, and without desktop effects - the 'effect' is shorter and flickers more.

Also it may be important - sometimes I am ABLE NOT TO REPRODUCE this bug (I would say) - before I switch to dashboard I need to give focus control to desktop (and not to applet or any window) - this way white flash may not occur. 

White flash will occur always when any window has focus (receives keyboard input - simply any window must be active) before switching to dashboard.
Comment 7 Maciej Mrozowski 2008-11-29 05:06:15 UTC
And yet another suggestion - it may not be related only to plasma dashboard but to all plasma elements/applications as I observe similar white flashes befory every plasma element appears on the screen.

I don't know the internals, but it looks like plasma elements were first painted white and after a while they were repainted again with theme (svn image I guess).

With desktop effects it is easier to spot as whole painting seems to take a bit longer - and it has nothing to do with kwin effects - disabling window/activation effects doesn't "solve" the issue and disabling compositing at all just makes it harder to spot, but those white flashes are there.

I observed white flashes with:
- dashboard-view activation (the easiest to spot - whole screen is white)
- kickoff menu
- kuiserver/knotify messages
- calendar tooltip (when digital clock on panel is LMB-clicked - btw - multiple cliking on calendar sometimes makes it disappear and it can be no longer activated - like it locked itself - mouse icon over panel changes to 'drag' or 'grab' icon - but that's different story)
- it may be totally unrelated - but konsole as well - before terminal is drawn - it's white at the begin (it may be separate issue - definitely not related to this bug)
Comment 8 Aaron J. Seigo 2008-12-01 01:41:55 UTC
*** Bug 176409 has been marked as a duplicate of this bug. ***
Comment 9 Luis Augusto Fretes Cuevas 2008-12-10 05:02:33 UTC
Same here, I'm using an Intel G33. It's quite an annoying bug.
Comment 10 Aaron J. Seigo 2008-12-16 05:12:53 UTC
we're washing the widget at the earlier possible moment with Qt::transparent which helps when compositing is there, and every other source of this problem has been drivers (e.g. the recent nvidia beta drivers seem to eliminate this for people)
Comment 11 Jacopo De Simoi 2008-12-16 18:22:11 UTC
Which nvidia drivers? the 180 series or the 177.xx?

I'm on beta 177.80 and I can still see the white flickering; could it  also be the "fulldebug" build? As far as I remember I started seeing this problem around when compiling trunk with this option... but this coincided with when I started using  the candidate 4.2, so...

Besides (and here comes a naïve question): is  there a reason for  which (for instance) the framesvg of krunner and kickoff are  not precached on startup? Would it matter?
Comment 12 Maciej Mrozowski 2008-12-22 04:34:25 UTC
Created attachment 29532 [details]
screenshot with white flash effect

White flashes reprodible on nvidia legacy drivers (173.14.09) on Geforce FX 5200 as well.
If someone doesn't believe me - I actually I managed to capture it on screenshot :D
Notice cut-out triangle in upper left corner (triangle was not present when I tested it on ATI)
As you can see - this white flash effect is *not* flickering - it's actually 'smooth' transition from normal screen to entirely white.
Comment 13 Maciej Mrozowski 2008-12-22 04:41:16 UTC
Please note that this bug is reproducible with compositing effect enabled in kwin (XRender and OpenGL) and with disabled compositing as well - so it's hardly an issue with driver but of course I may be mistaken.
Please note as well that this triangle on my screenshot can be not issue with NVidia, but because it was tested with recent trunk (and the one with ATI on trunk 3 weeks ago) and something was likely to be changed in code reponsible for it, provided it's really plasma issue.
Comment 14 Maciej Mrozowski 2008-12-22 06:03:27 UTC
Is there possibility that kwin or some other component would interfere in painting process here?

I found something interesting - while this whitescreen effect is best noticed when plasma applets are shown (as some of them take time to load...) I actually noticed (as I stated in earlier comments) it with *konsole* as well - as konsole usually has dark background so it's easy to spot such drastic color changes.

And.. the same exact effect (white flash with this cut-out triangle as on screenshot) is for some windows being opened (windows like konsole).

That being said - it's by no means plasma bug, but supposedly *kwin*

Could anyone try to reproduce this bug, and if confirmed - could you reopen this bug and reassign to kwin developers please? (there's some knowledge attached to this bug that may be worthy reopening instead opening new bug for kwin)
Comment 15 Aaron J. Seigo 2008-12-22 17:19:40 UTC
"reproducible with compositing effect enabled in kwin (XRender and OpenGL) and with disabled compositing as well - so it's hardly an issue with driver"

the driver is still responsible for painting regargless of whether desktop effects are on or not, so this is not a valid test for it being a driver problem or not.

"is for some windows being opened (windows like konsole). "

konsole also uses an argb visual, just like plasma. i'm pretty sure that is the commonality that is causing this problem.
Comment 16 Maciej Mrozowski 2008-12-23 00:38:53 UTC
As a side note - http://bugs.kde.org/show_bug.cgi?id=170462 seems to be related or even the same issue.
Comment 17 Nadav Kavalerchik 2009-01-06 18:44:04 UTC
i confirm this issue with :

(thou, it looks like a feature more then a bug ;-)

hp dv7 + debian sid 64bit + kde 4.1.86 
+ nvidia 9600M GT + nvidia 177.82 + Xorg 1.4.2 

nvidia section from xorg.conf: 
Section "Device" 
Identifier "Device0" 
Driver "nvidia" 
VendorName "NVIDIA Corporation" 
BusID "PCI:1:0:0" 
# compiz(fusion) recommands for nvidia 
Option "RenderAccel" "True" 
Option "AddARGBGLXVisuals" "True" 
Option "DamageEvents" "True" 
Option "UseEvents" "False" 
Option "TripleBuffer" "True" 
Option "BackingStore" "True" 
Option "NoLogo" "True" 
#http://userbase.kde.org/GPU-Performance#NVIDIA 
Option "UseCompositeWrapper" "True" 
Option "AllowIndirectPixmaps" "True" 
Option "PixmapCacheSize" "200000" 
Option "OnDemandVBlankInterrupts" "True" 
EndSection 
Comment 18 veeall 2009-08-03 07:38:06 UTC
This white flash is still noticable with latest nvidia beta drivers (NVIDIA-Linux-x86_64-190.18-pkg2, slackware64, kde4.2.4, GeForce 8500GT) when activating dashboard view. It is clearly visible white flicker for a fraction of second just before activating dasboard overlay view with kwin compositing enabled but without Fade plugin being used.