Bug 155787 - Menu behaves strangely in Fullscreen mode
Summary: Menu behaves strangely in Fullscreen mode
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-14 23:02 UTC by Stephan Burkhardt
Modified: 2012-10-19 13:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Possible fix (663 bytes, patch)
2008-01-17 00:35 UTC, Aurelien Gateau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Burkhardt 2008-01-14 23:02:33 UTC
Version:           2.0 (using KDE 4.00.00 (KDE 4.0.0), Kubuntu packages)
Compiler:          gcc
OS:                Linux (i686) release 2.6.22-14-generic

When in Fullscreen mode, hovering over the menu will make it try to disappear, and then reappear again, over and over. This is quite annoying as it doesn't seem to accept clicks while disappearing.
I would expect it to stay where it is as long as I don't move the mouse-pointer away from it
Comment 1 Aurelien Gateau 2008-01-16 14:16:10 UTC
Are you talking about the fullscreenbar which contains a set of buttons to the 
previous/next image and start the slideshow?

If it's the case, then I can't reproduce the bug. It works as expected for me.

Aurélien
Comment 2 Stephan Burkhardt 2008-01-16 21:48:39 UTC
I checked it and the problem only occurs on my second screen (I have a laptop with a connected VGA Monitor and use them in cinerama mode.
The Menu tries to hide itself about every 4 seconds or so.

	Stephan
Comment 3 Aurelien Gateau 2008-01-17 00:34:38 UTC
Good catch, it could definitely be caused by a Xinerama setup. I created a patch but I don't have the necessary hardware to test right now. Can you try to apply the attached patch to see if it fixes your problem?
Comment 4 Aurelien Gateau 2008-01-17 00:35:21 UTC
Created attachment 23091 [details]
Possible fix
Comment 5 Stephan Burkhardt 2008-01-20 16:33:25 UTC
I compiled it with the fix and now it works. Thanks for the fast response

P.S:This was the first time I actually compiled a package myself, that's why it took some time- I first had to find out how to do it.
Comment 6 Aurelien Gateau 2008-01-20 22:28:35 UTC
Great, then I close it and will backport to 4.0 branch.
Comment 7 Aurelien Gateau 2008-01-20 22:31:38 UTC
SVN commit 764039 by gateau:

Fix disappearing fullscreenbar when running on the 2nd screen of a Xinerama setup.
CCBUG:155787

 M  +6 -1      fullscreenbar.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=764039
Comment 8 Aurelien Gateau 2008-01-20 22:35:06 UTC
SVN commit 764041 by gateau:

Fix disappearing fullscreenbar when running on the 2nd screen of a Xinerama setup.
CCBUG:155787
Backported https://svn.kde.org/home/kde/trunk/KDE/kdegraphics@764039


 M  +6 -1      fullscreenbar.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=764041