Bug 155734 - okular should monitor files for changes
Summary: okular should monitor files for changes
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR wishlist with 10 votes (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-14 11:13 UTC by Gabriel Ambuehl
Modified: 2008-01-15 00:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Ambuehl 2008-01-14 11:13:13 UTC
Version:            (using KDE KDE 4.0.0)
Installed from:    Ubuntu Packages

In kpdf, I could open a PDF and get it automatically reloaded when the underlying file was changed. This was very useful when writing LaTeX documents, as you could simply compile them and the changes would automatically be loaded in kpdf.

This feature sadly does not seem to exist in okular.
Comment 1 Pino Toscano 2008-01-14 11:17:00 UTC
Works here; did you activate the "Relaod document on file change" option (active by default)?
Comment 2 Gabriel Ambuehl 2008-01-14 11:23:49 UTC
Yes I did activate it, not sure why it did not work before. 

And in further testing, it sometimes worked, but sometimes I would get a 
dialog box saying that the file could not be opened (probably because LaTeX 
was writing to it), clicking on Ok would then reload the file nonetheless 
(probably because writing was done). Maybe there should be a short delay, 
then another attempt at opening the file and only then, after a second 
failure, a dialog box shown (I have never seen this behavior in kpdf, 
anyway)?
Comment 3 Pino Toscano 2008-01-14 11:30:20 UTC
Well, the behavious is the very same as in KPDF, nothing changed.
Both KPDF and Okular wait 750ms after a file change event of the current file; if a new change happen during that time, the countdown is restarted, and so on.
Comment 4 Albert Astals Cid 2008-01-14 22:10:51 UTC
Nah, it's a regression, okular shows you an ugly message box saying the document could not be loaded when it tries to load it in the middle, kpdf did not do that.
Comment 5 Albert Astals Cid 2008-01-15 00:04:10 UTC
SVN commit 761490 by aacid:

Don't show an ugly popup saying the document could not be loaded when we come from a file changed reload
BUG: 155734


 M  +13 -6     part.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=761490