Bug 155689 - Dolphin and konqueror crash when trying to open smb:/
Summary: Dolphin and konqueror crash when trying to open smb:/
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 158445 162458 162465 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-13 21:55 UTC by Alejandro Lorenzo
Modified: 2008-12-02 18:52 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
Backtrace of one the crashes (5.75 KB, text/plain)
2008-01-13 21:56 UTC, Alejandro Lorenzo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alejandro Lorenzo 2008-01-13 21:55:45 UTC
Version:           SVN revision 760973 (using KDE KDE 4.0.0)
Installed from:    Compiled From Sources
OS:                Linux

Dolphin and konqueror crash when trying to browse the Samba Machines avaible with "smb:/"

Don't know if it is important but trying to use "remote://smb-network"   gives the error "Could not connect to host smb://smb-network" 

A have a backtrace of the problem as it is quite easy to reproduce.
Comment 1 Alejandro Lorenzo 2008-01-13 21:56:17 UTC
Created attachment 23012 [details]
Backtrace of one the crashes
Comment 2 FiNeX 2008-01-13 23:18:18 UTC
Tried on 761006.
browsing on "smb://..." doesn't make crash dolphin.
It crash instead on "remote://smb-network".

I've no backtrace, but this output on the shell:


dolphin(9280)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::KCoreConfigSkeleton: Creating KCoreConfigSkeleton ( 0x829e808 )
dolphin(9280)/kio (KDirLister) KDirLister::stop:
dolphin(9280)/kio (KDirListerCache) KDirListerCache::listDir: DolphinDirLister(0x8163180) url= KUrl("remote://smb-network") keep= false reload= false
dolphin(9280)/kio (KDirListerCache) KDirListerCache::forgetDirs: DolphinDirLister(0x8163180)  item moved into cache:  KUrl("file:///home/test")
dolphin(9280)/kio (KDirListerCache) KDirListerCache::listDir: Entry not in cache or reloaded: KUrl("remote://smb-network")
dolphin(9280)/kio (Slave) KIO::Slave::createSlave: createSlave ' "remote" ' for  "remote://smb-network"
dolphin(9280)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote: Listening on  "local:/tmp/test-kde4/ksocket-test/dolphinsj9280.slave-socket"
dolphin(9280)/kio (KDirListerCache) KDirListerCache::slotEntries: new entries for  KUrl("remote://smb-network")
ASSERT: "result.second" in file /home/test/kdesvn/kdelibs/kio/kio/kdirmodel.cpp, line 304
dolphin(9280)/kio (KDirListerCache) KDirListerCache::~KDirListerCache: -KDirListerCache
dolphin(9280)/kio (KDirWatch) KDirWatchPrivate::removeEntry: KDirWatchPrivate::removeEntry for "/home/test" sub_entry: 0x0
dolphin(9280)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Cancelled INotify (fd 15, 1) for "/home/test"
dolphin(9280)/kio (KDirWatch) KDirWatchPrivate::removeEntry: Removed Dir "/home/test" for "" ["KDirWatch-1"]
Comment 3 Alejandro Lorenzo 2008-01-14 00:05:49 UTC
forgot to add:

If you enter a valid Host address like "smb://localhost" dolphin does not crash. It only crash when it has to list the aviable hosts, happening when you enter smb:/ to list all avaible workgroups and smb://name_of_workgroup
Comment 4 Alejandro Lorenzo 2008-02-01 23:48:25 UTC
i've been diggin into the source... looks like some serious problem of understanding between kio_smb and the model of KDE for the Kios.

By the way... is it possible that kio_smb remains untouched since KDe2 ?
Comment 5 FiNeX 2008-02-26 13:19:28 UTC
*** Bug 158445 has been marked as a duplicate of this bug. ***
Comment 6 Bruno Laturner 2008-02-29 02:16:58 UTC
Confirmed here.

Listing hosts make kio-enabled apps to crash spectacularly, but when specifying the host, as in smb://hostname/, I can access them.

Should this be a blocker for 4.1, specially with KDE for Windows?
Comment 7 Stephan Kulow 2008-04-28 10:38:37 UTC
the crash is not in smb:/ - only triggered by it
Comment 8 David Faure 2008-04-29 13:48:22 UTC
I think this has been fixed already, by Albert?
Comment 9 Albert Astals Cid 2008-04-29 19:18:24 UTC
Yeah, i fixed it in 4.1, did not backport to 4.0 because it does not have all the necesary changes to make it work
Comment 10 Alejandro Lorenzo 2008-04-29 21:29:51 UTC
Can i ask about a summary introduced to fix this? Maybe a rewrite of the kio_smb? I am curious, because i looked into the code and it seemed to me that the problem was that this kio was left behind in the effort of porting.... ???
Comment 11 Alejandro Lorenzo 2008-04-29 21:32:28 UTC
"Can i ask about a summary introduced to fix this?"

Can i ask for a summary of the changes introduced  to fix this ?

Sorry, i shouldn't write in the bugtracker after studying finite element method... i makes me dizzy :)
Comment 12 David Faure 2008-05-02 10:37:53 UTC
The use of UDS_URL to make a non-hierarchical structure, was the problem. Solved with UDS_TARGET_URL,
which only triggers when clicking on the item, but the URL used for that item it still the normal (part of the hierarchical
URL structure) one.
Comment 13 FiNeX 2008-05-22 19:17:14 UTC
*** Bug 162458 has been marked as a duplicate of this bug. ***
Comment 14 FiNeX 2008-05-22 19:27:13 UTC
*** Bug 162465 has been marked as a duplicate of this bug. ***
Comment 15 David Faure 2008-12-02 18:52:55 UTC
SVN commit 891707 by dfaure:

With today's KDirModel improvements, it is possible for kioslaves to return non-hierarchical URL structures,
so kio_smb can use UDS_URL again instead of UDS_TARGET_URL (which wasn't good enough for treeviews, see #176555).
CCBUG: 155689


 M  +1 -6      kio_smb.cpp  
 M  +2 -2      kio_smb_browse.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=891707