Bug 155650 - window operations keyboard shortcuts are no longer available in KDE4
Summary: window operations keyboard shortcuts are no longer available in KDE4
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 100 votes (vote)
Target Milestone: ---
Assignee: Andreas Hartmetz
URL:
Keywords:
: 155841 156719 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-13 15:51 UTC by Jonathan Marten
Modified: 2008-01-31 21:57 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Marten 2008-01-13 15:51:57 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc version 4.1.2 (Gentoo 4.1.2 p1.0.1)
 
OS:                Linux

This is a bug, or at least a regression.  There are many window operations that in KDE3 could have shortcut keys configured (in Control Centre - Regional & Accessibility - Keyboard Shortcuts - Global Shortcuts).  Now they seem to be no longer available to configure, at least where one would expect (at System Settings - Keyboard & Mouse - Keyboard Shortcuts with the "kwin" component selected):

Maximise Window
Maximise Horizontally
Maximise Vertically
Minimise Window
Shade Window
Move Window
Resize Window
Raise Window
Lower Window
Toggle Window Raise/Lower
Make Window Fullscreen
Hide Window Border
Keep Window Above Others
Keep Window Below Others

All of the "pack" operations
All of the "window to desktop..." operations
Comment 1 Lubos Lunak 2008-01-14 23:01:58 UTC
The shortcuts are there, but they don't show up in the configuration module for some reason.
Comment 2 Lubos Lunak 2008-01-15 18:57:43 UTC
*** Bug 155841 has been marked as a duplicate of this bug. ***
Comment 3 81joe81 2008-01-15 19:43:20 UTC
I think I have a bug related to this one.
Just after the login the kwin shortcuts work properly and if I go to the configuration module I can see and modify them.
But after a while, and I don't know yet if there could be a specific reason, the shortcuts stop to work and then if I go again to the configuration module I find it all blank, no shortcuts are displayed.
The problem affects also the switch window shortcut (alt-tab), as well as the already reported ones
Comment 4 Gabriel Saldana 2008-01-17 04:15:13 UTC
The switch to next/previous desktop shortcuts are missing too.
Comment 5 81joe81 2008-01-20 12:32:17 UTC
Also the shortcut for the new 2.9-beta1 version of yakuake for KDE4 doesn't work after a while for me, making in this way yakuake unusable :(
Comment 6 David Faure 2008-01-21 13:34:26 UTC
About #4: I just sent a patch to Trolltech which adds support in Qt for the Prev_Virtual_Screen and Next_Virtual_Screen keysyms. But of course this is only half the job, I still miss the kwin actions in the configuration module to be able to set the shortcut to them (and one can always use other keysyms like F13 and F14 anyway, but using the right keysym is cleaner :-)
I think Olivier Goffart is working on the configuration module.
Comment 7 Lubos Lunak 2008-01-26 16:20:05 UTC
*** Bug 156719 has been marked as a duplicate of this bug. ***
Comment 8 Lubos Lunak 2008-01-31 13:39:47 UTC
Fixed by Aurelien.
Comment 9 Johannes Ranke 2008-01-31 21:57:02 UTC
Cool, working great here!