Bug 155493 - Web pages load a blank page. After reload the page is loaded correctly
Summary: Web pages load a blank page. After reload the page is loaded correctly
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: 4.0
Platform: Ubuntu Linux
: NOR normal with 10 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 155601 158067 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-12 13:57 UTC by Arnau
Modified: 2008-04-01 22:54 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arnau 2008-01-12 13:57:24 UTC
Version:           4.0.0 (using KDE KDE 4.0.0)
Installed from:    Ubuntu Packages
Compiler:          gcc versió 4.2.3 20080104 (prerelease) (Ubuntu 4.2.2-5ubuntu2) 
OS:                Linux

The www.fotolog.com webpage doesn't work well. I only can enter to my page but when I click to enter to other users pages it loads the page but it doesn't appear nothing. I only can see a white page.
Comment 1 Maksim Orlovich 2008-01-12 17:19:11 UTC
Could you please provide a link to a sample page where this problem occurs? I clicked on one of those from the homepage and it seems to have shown up fine...
Comment 2 Arnau 2008-01-13 03:30:20 UTC
I visited my fotolog -> www.fotolog.com/pukyxd then I click http://www.fotolog.com/sweetkiss_19 one of the comments of my fotolog and it appears a blank page. 
Comment 3 FiNeX 2008-01-13 12:39:08 UTC
Confirmed on a different page of that website.
It seems the "white page" bug which affects the latest versions of Konqueror 4. If you reload the page, will it be loaded correctly?
Comment 4 Arnau 2008-01-13 13:51:40 UTC
Yes it loads corectly.
Comment 5 FiNeX 2008-01-13 14:24:34 UTC
*** Bug 155601 has been marked as a duplicate of this bug. ***
Comment 6 FiNeX 2008-01-13 14:28:00 UTC
The page http://www.coks.si (and sub-pages) doesn't load the first time too. You have to reload the page.
Comment 7 Praveen Srinivasan 2008-01-15 17:26:57 UTC
This happens on nytimes.com a lot too.
Comment 8 Marcel Juhnke 2008-01-18 09:34:35 UTC
This happens to me for several pages, such as heise.de or golem.de, even for dot.kde.org. Sometimes they load after longer waiting, other times I have to click on reload several times. :-(

Very annoying, as Konqueror 3.5 works perfectly for me.

Best regards
Comment 9 Tommi Tervo 2008-02-21 08:04:56 UTC
*** Bug 158067 has been marked as a duplicate of this bug. ***
Comment 10 Onno Molenkamp 2008-03-20 19:28:21 UTC
Using openSUSE's KDE 4.0.66 packages, I'm getting the same thing on different websites, for example all pages on www.postgresql.org. Every page has to be reloaded before konqueror will display anything. The title bar is updated with the correct title before the reload however.
Comment 11 Germain Garand 2008-04-01 22:54:21 UTC
SVN commit 792695 by ggarand:

rework the tracking of stylesheets' loaded state.

@import logic merged from WebCore made it
subject to pathological loss of synchronisation.

BUG:155493


 M  +5 -0      css/css_base.cpp  
 M  +4 -0      css/css_base.h  
 M  +24 -11    css/css_ruleimpl.cpp  
 M  +4 -1      css/css_ruleimpl.h  
 M  +30 -10    css/css_stylesheetimpl.cpp  
 M  +3 -2      css/css_stylesheetimpl.h  
 M  +27 -6     html/html_headimpl.cpp  
 M  +4 -2      html/html_headimpl.h  
 M  +5 -0      xml/dom_docimpl.cpp  
 M  +1 -1      xml/dom_docimpl.h  
 M  +3 -1      xml/dom_nodeimpl.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=792695