Bug 155413 - icons on panel and desktop dont execute programs when doubleclick option is activated
Summary: icons on panel and desktop dont execute programs when doubleclick option is a...
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: panel (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 156217 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-01-10 19:13 UTC by Sebastian Kuźlak
Modified: 2008-04-02 20:30 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Untested backport to 4.0-branch (1.73 KB, patch)
2008-03-09 05:54 UTC, Sebastian Sauer
Details
Updated patch. (1.46 KB, patch)
2008-03-09 06:34 UTC, Sebastian Sauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Kuźlak 2008-01-10 19:13:12 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc-4.22 
OS:                Linux

As in the topic:
icons on panel and desktop dont execute programs when doubleclick option is activated in 
system settings->keyboard&mouse->mouse.

To reporduce this bug follow this steps;
1. set option to "open files/folders with one click" in system settings->keyboard&mouse->mouse. (im translating name of this option from polish so it may not be accurate).
2. add a program icon into panel via kickoff.
3. click icon You added - > result progam is launched.
4. set option to "open files/folders with double click" in system settings->keyboard&mouse->mouse.
5. click icon You added - > result progam is launched.
6. remove added icon.
7. add this icon again.
8, click on the icon -> result progam is NOT launched.

Same situation appears with icons on "desktop".

I hope this helps and i hope there is no other bug report about it (i searched and didnt find anything)
Comment 1 Marco Martin 2008-01-10 19:43:24 UTC
hmmm, i see Object::connect: No such signal Plasma::Icon::doubleClicked()
 indeed :(
Comment 2 Jonathan Thomas 2008-01-10 20:58:39 UTC
Well now (4.0.0) when you have double click enabled and you double click a program icon, two instances of the program will pop up! (Basically, plasma seems to be ignoring the double click option now)
Comment 3 Aaron J. Seigo 2008-01-10 21:18:30 UTC
SVN commit 759525 by aseigo:

implement a doubleClicked signal.

i must admit that using signals that don't exist to implement needed features in applets is an inventive way to force me to implement stuff in libplasma ;)
BUG:155413


 M  +7 -0      icon.cpp  
 M  +9 -4      icon.h  
 M  +2 -0      icon_p.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=759525
Comment 4 Christopher Blauvelt 2008-01-10 21:27:19 UTC
Looks like I forgot to commit those changes.  That must have been why it worked for me.
Comment 5 Chani 2008-01-20 13:05:30 UTC
*** Bug 156217 has been marked as a duplicate of this bug. ***
Comment 6 Iuri Fiedoruk 2008-02-07 18:54:38 UTC
Quick question:
this fix got into kde 4.0.1?
If not, will be in 4.0.2 or only 4.1?
Comment 7 thomas klein 2008-02-07 19:30:45 UTC
kubuntu kde 4.0.1 : not fixed
Comment 8 Ivo Anjo 2008-03-03 21:00:32 UTC
Still not fixed on 4.0.1 openSUSE packages.
Comment 9 thomas klein 2008-03-05 10:30:09 UTC
kubuntu kde 4.0.2 : not fixed

And I got to restart KDE to have the single click / double click applied.
Comment 10 Iuri Fiedoruk 2008-03-05 13:08:28 UTC
Can we please have it backported to KDE4.0?
It is a VERY bad UI bug, both for having to restart the desktop to change mouse behavior as to double-click not working.
Currently I am not using any icon in the desktop because of this bug :-(
Comment 11 CSights 2008-03-06 16:05:54 UTC
please vote to indicate that you hope to have this bug backported to 4.0.x.

Confirming not fixed in 4.0.2 (debian)
Comment 12 Sebastian Sauer 2008-03-09 05:54:20 UTC
Created attachment 23835 [details]
Untested backport to 4.0-branch

The patch above is a plain backport of the commit done with r759525 in trunk
back to the 4.0-branch.

1. download the patch
2. cd kdebase && patch -p0 < ThePatchFile.patch && recompile

Now we only would need someone who likes to test it and to verify that it
really does the job, hint, hint :)
Comment 13 Sebastian Sauer 2008-03-09 06:34:12 UTC
Created attachment 23836 [details]
Updated patch.

Seems beside http://lists.kde.org/?l=kde-commits&m=120000775515531&w=2 there
was so much done between related to icons in trunk, that there are only a hand
full of lines that looks similar to how it was done in 4.0 :-/
Well, anyway. I double and tribble checked the backport and it should work
fine.

But still we would need someone who is motivate enough to try;
* if icon-doubleclicks really work now as expected AND
* if icon-singleclick still work like without that patch.
Comment 14 CSights 2008-03-10 00:18:45 UTC
I've made a patched version of the debian package libplasma1.  Double-click on the desktop works.  I haven't test single-click yet.  (Another bug says that one needs to restart KDE to transition between single- and double- click.)

Thanks for the double-click action at least!
Debian package:
https://filer.case.edu/dav/cws10/public/libplasma1_4.0.2-1_i386.deb
Comment 15 CSights 2008-03-10 00:20:58 UTC
single click works as it always has for me (i.e. not very well).
Comment 16 Sebastian Sauer 2008-03-10 00:40:36 UTC
thank you very much CSights!

So, the fix got committed with r783906 to the 4.0-branch and will be available KDE 4.0.3 :-)
Comment 17 thomas klein 2008-04-02 20:30:37 UTC
in 4.0.3

bug fixed but : 
- Still got to restart kde to activate the new option
- Have to double click shortcuts icons on the panel too !!!