Bug 155187 - Syntax highlighting for Io.
Summary: Syntax highlighting for Io.
Status: RESOLVED WORKSFORME
Alias: None
Product: kate
Classification: Unclassified
Component: syntax (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: investigated, triaged
Depends on:
Blocks:
 
Reported: 2008-01-06 14:06 UTC by Pupeno
Modified: 2018-10-27 02:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Highligting for Io. (2.98 KB, text/xml)
2008-01-06 14:07 UTC, Pupeno
Details
Version 0.2 of the Io syntax highlighting. (3.82 KB, text/xml)
2008-01-06 21:38 UTC, Pupeno
Details
Io highlighting file for Kate distributed with Io (7.50 KB, text/xml)
2008-01-06 22:59 UTC, Jonathan Wright
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pupeno 2008-01-06 14:06:31 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages

I'll be attaching a syntax highlighting file for the Io programming language (http://www.iolanguage.com/)
Comment 1 Pupeno 2008-01-06 14:07:20 UTC
Created attachment 22868 [details]
Highligting for Io.
Comment 2 Pupeno 2008-01-06 21:38:00 UTC
Created attachment 22876 [details]
Version 0.2 of the Io syntax highlighting.
Comment 3 Jonathan Wright 2008-01-06 22:55:43 UTC
The Io distribution and git repo already contain a Kate highlighting file. It can be downloaded from http://repo.or.cz/w/io.git?a=blob_plain;f=projects/SyntaxHighlighters/Kate/io.xml;hb=HEAD .
Comment 4 Jonathan Wright 2008-01-06 22:59:54 UTC
Created attachment 22879 [details]
Io highlighting file for Kate distributed with Io
Comment 5 Christoph Cullmann 2011-08-12 08:28:31 UTC
We need to be allowed to redistribute.
If the author adds a license like LGPL, I am happy to include it.
Comment 6 Andrew Crouthamel 2018-09-22 01:53:24 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Andrew Crouthamel 2018-10-27 02:24:44 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!